[РЕШЕНО] Com соединение из файловой базы к файловой

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем OXED, 2 сен 2014.

  1. TopicStarter Overlay
    OXED
    Offline

    OXED Опытный в 1С

    Регистрация:
    10 апр 2012
    Сообщения:
    256
    Симпатии:
    0
    Баллы:
    26
    Доброе утро. Есть файловая база 8.3, из нее по comсоединению пытаюсь подключиться к другой файловой базе:

    Код:
        Каталог = "C:\Users\1C\Документооборот (тест)";
        Пользователь = "Администратор";
        Пароль = "";
        ПараметрыПодключения = "File="+Каталог+";Usr="+Пользователь+";Pwd="+Пароль+";";
       
        V83 = Новый COMОбъект("V83.COMConnector");
        Попытка
            Соединение = V83.Connect(ПараметрыПодключения);
        Исключение
            Сообщить("Не удалось соединится с документооборотом!");
        КонецПопытки; 

    Вызывается исключение, без описания ошибки.
    Обе базы принудительно запускаются в 8.3. Каталог и пользователь - указаны верно. В чем может быть причина?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.989
    Симпатии:
    399
    Баллы:
    104
    Код:
    Попытка
            Соединение = V83.Connect(ПараметрыПодключения);
        Исключение
            Сообщить(ОписаниеОшибки());
        КонецПопытки; 
    И смотрите уже, что там пишется.
  3. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    а если на латинице папки юзать?
  4. TopicStarter Overlay
    OXED
    Offline

    OXED Опытный в 1С

    Регистрация:
    10 апр 2012
    Сообщения:
    256
    Симпатии:
    0
    Баллы:
    26
    Сделал как вы посоветовали. Сначала вылезла ошибка "Произошла исключительная ситуация (V83.COMConnector.1): Версия компоненты 'comcntr' (8.3.4.465) отличается от версии корневого модуля 'core83' (8.3.4.482)". Зарегистрировал библиотеку. Потом вылез косяк с сообщением "Произошла исключительная ситуация (V83.COMConnector.1): Неверные или отсутствующие параметры соединения с информационной базой". Гугл посоветовал удалить пробелы в каталоге. Удалил. И только тогда все заработало. Спасибо за советы

    Модераторы, закройте тему. Вопрос решен

Поделиться этой страницей