7.7 цикл по строкам и стобцам

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем dreadnout, 2 ноя 2010.

  1. TopicStarter Overlay
    dreadnout
    Offline

    dreadnout

    Регистрация:
    2 ноя 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    извините за нубство, но у меня еще маленький вопрос:

    как правильно написать, что если в списке есть запись с должностью, то Должн=ТабЗ.ПолучитьЗначение(ин, "должн")?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Перефразируйте вопрос - ничего не понятно
  3. TopicStarter Overlay
    dreadnout
    Offline

    dreadnout

    Регистрация:
    2 ноя 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    у меня есть ТЗ, в которой все сотрудники, как првильно создать условие, чтобы в отчет попадали только те, должности которых у меня в спискеЗначений?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) Организуем цикл по списку должностей
    2) Проверяем наличие метки (если это список с пометками)
    3) Получаем значение из списка
    4) Ищем в таблице значений по значению из п.п. 3
  5. TopicStarter Overlay
    dreadnout
    Offline

    dreadnout

    Регистрация:
    2 ноя 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    я пишу так:

    Код:
    Для ин=1 по ТабЗ.КоличествоСтрок() цикл
    Для ин=1 по Должности.РазмерСписка цикл
    
    Если ПустоеЗначение(Должности)=0 тогда
    
    Если ТабЗ.ПолучитьЗначение(ин,"Должн")=Должности тогда ПропуститьСотрудникаДолжности=1 
    иначе
    ПропуститьСотрудникаДолжности=0
    КонецЕсли
    
    иначе ПропуститьСотрудникаДолжности=1
    
    Если (ПропуститьСотрудникаДолжности=1) тогда
    Таб.ВывестиСекцию("заголовок");
    ФИО=ТабЗ.ПолучитьЗначение(ин, "ФИО")
    Должн=-=-=-=-=-=-=-=-=-=-=-=-==-
    
    КонецЕсли
    КонецЦикла
    КонецЦикла
    
    Так, почему-то 1с заглючивает....а если не глючит, то все равно не работает(если в список пуст, то выводит всех, а если там есть записи, то не выводит никого)
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если список должностей пуст она и не войдет во вложенный цикл (ин)
    Поэтому уберите проверку на пустое значение.
    +
    Код:
    ТабЗ.ПолучитьЗначение(ин,"Должн")=Должности 
    
    
    здесь вы сравниваете элемент справочника и список значений... Это недопустимо
  7. TopicStarter Overlay
    dreadnout
    Offline

    dreadnout

    Регистрация:
    2 ноя 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    а как же тогда?, добавлять ведь сначала элементы списка в ТЗ тоже не то, что нужно?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) Внешний цикл д.б. по полжностям, по тз - внутренний
    2) Используйте
    Код:
    ТекДолжн=Должности.ПолучитьЗначение(ин);
    
    
    
    Для получиения значения элемента должности. Вот его уже можно сравнивать с тз))))

    Если хотите оставить как было - используйте метод Принадлежит для списка должностей
  9. TopicStarter Overlay
    dreadnout
    Offline

    dreadnout

    Регистрация:
    2 ноя 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    :D в который раз спасибо...

    да вы не угодник бухгалтерский, вы Гений(для меня, по крайней мере)
    :angry: :D
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Спасибо за комплемент))) Обращайтесь
  11. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29

    Для этого есть кнопка... Ему будет приятнее :D

Поделиться этой страницей