8.х Чтение данных XML

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем rio, 5 авг 2013.

  1. TopicStarter Overlay
    rio
    Offline

    rio

    Регистрация:
    22 мар 2013
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.

    Есть у меня еобходимость прочитать данные с тегов

    Пример (выделенное нужно вывести):

    Через DOM или через ЧтениеXML.Прочитать, у меня получается вывести значения в таких узлах как <Тег> ЗНАЧЕНИЕ </Тег> (благо информации в интернете навалом), а вот как вывести <ТЕГ ДАННЫЕ = "ЗНАЧЕНИЕ" ДАННЫЕ2 = "ЗНАЧЕНИЕ2"> </ТЕГ> ???

    Вот пока мой код:

    Код:
    Процедура ПолеВводаНачалоВыбора(Элемент, СтандартнаяОбработка)
    ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогФыбораФайла.Фильтр = "XML (*.xml)|*.xml";
    ДиалогФыбораФайла.Заголовок = "Выберите файл";
    ДиалогФыбораФайла.ПредварительныйПросмотр = Истина;
    ДиалогФыбораФайла.ИндексФильтра = 0;
    
    Если ДиалогФыбораФайла.Выбрать() Тогда
    Сообщить(ДиалогФыбораФайла.ПолноеИмяФайла);
    Элемент.Значение = ДиалогФыбораФайла.ПолноеИмяФайла;
    ЧтениеXML = Новый ЧтениеXML;
    ПутьКФайлуXML = Элемент.Значение;
    ЧтениеXML.ОткрытьФайл(ПутьКФайлуXML);
    Пока ЧтениеXML.Прочитать() Цикл
    Если ЧтениеXML.Имя = "Работник" и ЧтениеXML.ТипУзла=ТипУзлаXML.НачалоЭлемента Тогда
    // Не знаю что писать
    Сообщить("--" + ?????);
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецПроцедуры;
    
    

    Помогите, не знаю что писать для вывода, к примеру, "04.06.2009" по "ДатаПенс"
  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    вот то, что внутри тэга - называется "атрибут"

    дальше - когда получили начало элемента - получайте его атрибуты и будет вам счастье
  3. TopicStarter Overlay
    rio
    Offline

    rio

    Регистрация:
    22 мар 2013
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Благодарю, не хватало мозгов на ПрочитатьАтрибут

    Код:
    ЧтениеXML.ПрочитатьАтрибут()

Поделиться этой страницей