7.7 Ценник + Вес

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем stasekb, 8 сен 2017.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.611
    Симпатии:
    541
    Баллы:
    204
    справочник цен не содержит информацию о весе! Точнее НАПРЯМУЮ не содержит. В справочнике цен есть единица измерения, которая содержит вес.
    Вся закавыка в том, что у вас для одного и того же товара нельзя задавать две и более позиции цены с одинаковым типом цен. И на дату можно задавать только одну цену для конкретного типа цен
    Ваша "хочуха" реально только в 2х случаях
    1) Поступление разбито попозиционно (см. пост №14)
    2) Вы приняли товар как одну позицию, но потом сделали комплетацию
  2. TopicStarter Overlay
    stasekb
    Offline

    stasekb

    Регистрация:
    8 сен 2017
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Товар всегда приходит. Сколько пришло столько и надо вес на ценнике . Пришло 10 кг в накладной надо вес 10 кг в ценнике. Пришло 10,5 надо 10,5 кг.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.611
    Симпатии:
    541
    Баллы:
    204
    Тогда вообще не вижу проблем (если дробить не будите).
    Основная ЕИ это кг... Количество (вес) для ценника можно брать из документа...
  4. TopicStarter Overlay
    stasekb
    Offline

    stasekb

    Регистрация:
    8 сен 2017
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Да. Но как это сделать? Что прописать в модуле куда и т.д .
    //******************************************************************************
    // ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд, ПечВес)
    //
    // Параметры:
    // Таб - таблица, в которую выполняется вывод ценника
    // ПечНаименование - наименование товара
    // ПечЕдиница - единица измерения товара
    // ПечРозн - цена товара
    // Столбик - номер столбика.
    // Ряд - номер ряда
    //
    // Возвращаемое значение:
    // Нет.
    //
    // Описание:
    // Добавляет ценник в таблицу.
    //
    Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)

    Столбик = ?(Столбик = 0, 1 , 0 );
    Ряд = ?(Столбик = 0, Ряд + 1, Ряд);

    Если Ряд > 3 Тогда
    Таб.НоваяСтраница();
    Ряд = 1;
    КонецЕсли;

    Если Столбик = 0 Тогда
    Таб.ВывестиСекцию("Товар|Ценник");
    Иначе
    Таб.ПрисоединитьСекцию("Товар|Ценник");
    КонецЕсли;

    КонецПроцедуры // ДобавитьЦенник()

    //******************************************************************************
    // Сформировать(ТаблицаТоваров, ПечФирма)
    //
    // Параметры:
    // ТаблицаТоваров - таблица значений, содержащая информацию о цене товара
    // ПечФирма - наименование фирмы, которое будет выводиться вверху ценника
    //
    // Возвращаемое значение:
    // Нет.
    //
    // Описание:
    // Формирует таблицу с ценниками.
    //
    Процедура Сформировать(ТаблицаТоваров,ПечФирма)

    // Создание Таблицы для выходного отчета
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");

    Столбик = 1;
    Ряд = 0;

    ТаблицаТоваров.ВыбратьСтроки();
    Пока ТаблицаТоваров.ПолучитьСтроку() = 1 Цикл
    ПечРозн = глФРМ(ТаблицаТоваров.Цена, ТаблицаТоваров.Валюта);
    ПечНаименование = ТаблицаТоваров.Товар;
    ДобавитьЦенник(Таб, ПечФирма, ТаблицаТоваров.Товар, ТаблицаТоваров.Единица, ПечРозн, Столбик, Ряд);
    глОживить(1);

    КонецЦикла;

    //Вызов выходного отчета в окно просмотра и редактирования.
    Таб.Опции(0,0,0,0,"ПечатьЦенников","ПечатьЦенников");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Товарные ценники","");

    КонецПроцедуры

    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриОткрытии()

    СтатусВозврата(0);
    ДанныеДляПечати = Форма.Параметр;

    Если ТипЗначенияСтр(ДанныеДляПечати) <> "СписокЗначений" Тогда
    Возврат;
    КонецЕсли;

    ПечФирма = ДанныеДляПечати.Получить("Фирма");
    ТаблицаТоваров = ДанныеДляПечати.Получить("Таблица");

    Сформировать(ТаблицаТоваров, ПечФирма);

    КонецПроцедуры // ПриОткрытии()
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.611
    Симпатии:
    541
    Баллы:
    204
    Вы используете обработку ОбновлениеЦенИзДокумента, вызываеваемую из ПоступлениеТМЦ?
  6. TopicStarter Overlay
    stasekb
    Offline

    stasekb

    Регистрация:
    8 сен 2017
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    да. Из поступление вызываем Обновление цен в справочнике . Обновляем цену . И печатаем ценники .
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.611
    Симпатии:
    541
    Баллы:
    204
    Тогда вам нужно
    1) Добавить колонку в таблицу ТаблЗнач. Количество
    2) Сделать ее невидимой (зачем лишняя информация на форме)
    3) Заполнять колонку в процедуре ПриОткрытии
    4) В процедуре ПоКнопкеПечатьЦенников() в таблице ТаблТов добавить колонку (вес или количество без разницы)
    5) Добавить код ее заполнения в цикле из ТаблЗнач
    6) изменить обработку ПечатьЦенников.
    6а) изменить макет (добавить строку веса)
    6б) добавить заполнение переменной печати из получаемой входной таблицы.
    6г) Предусмотреть, что обработка ПечатьЦенников вызыватеся не только из обработки ОбновлениеЦенИзДокумента. Поэтому нужно учесть, что там вес не передается. И если менять код без проверки условия - вывалится в ошибку. Поэтому добавьте проверку на наличие дополнительной колонки.
  8. TopicStarter Overlay
    stasekb
    Offline

    stasekb

    Регистрация:
    8 сен 2017
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Спасибо . попробую .
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.611
    Симпатии:
    541
    Баллы:
    204