7.7 Ценник в ТиС + свойство

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем eugenefromvrn, 1 июл 2014.

  1. TopicStarter Overlay
    eugenefromvrn
    Offline

    eugenefromvrn

    Регистрация:
    12 сен 2011
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    Добрый день, не программист 1С, но очень нужно в стандартный ценник 1С 9.2 добавить Свойство номенклатуры. причем свойств может быть одно или два. в интерфейсе разобрался как добавить свойства ,а вот в модуле не пойму как. Поиском пользовался, такие вещи делали только на 8.х. Может есть у кого-нибудь обработка или совет чайнику, буду очень признателен!
    вот на всякий случай текст обработки, которой сейчас пользуюсь:

    Код:
    //******************************************************************************
    // ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)
    //
    // Параметры:
    //  Таб             - таблица, в которую выполняется вывод ценника
    //  ПечНаименование - наименование товара
    //  ПечЕдиница      - единица измерения товара
    //  ПечРозн         - цена товара
    //  Столбик         - номер столбика.
    //  Ряд             - номер ряда
    //
    // Возвращаемое значение:
    //  Нет.
    //
    // Описание:
    //  Добавляет ценник в таблицу.
    //
    Процедура ДобавитьЦенник(Таб, ШтрихКод, ПечСтрана, ПечАртикул,  ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)
            
        Столбик    = ?(Столбик = 0, 1      , 0  );
        Ряд        = ?(Столбик = 0, Ряд + 1, Ряд);
    
        Если Ряд > 3 Тогда
             Таб.НоваяСтраница();
             Ряд = 1;
         КонецЕсли;
        
         Если Столбик = 0 Тогда
             Таб.ВывестиСекцию("Товар|Ценник");
         Иначе
             Таб.ПрисоединитьСекцию("Товар|Ценник");
         КонецЕсли;
    
    КонецПроцедуры // ДобавитьЦенник()
    
    //******************************************************************************
    // Сформировать(ТаблицаТоваров, ПечФирма)
    //
    // Параметры:
    //  ТаблицаТоваров    - таблица значений, содержащая информацию о цене товара
    //  ПечФирма        - наименование фирмы, которое будет выводиться вверху ценника
    //
    // Возвращаемое значение:
    //  Нет.
    //
    // Описание:
    //  Формирует таблицу с ценниками.
    //
    Процедура Сформировать(ТаблицаТоваров,ПечФирма)
    
        //  Создание Таблицы для выходного отчета
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Таблица");
       
        Столбик = 1;
         Ряд     = 0;
    
         ТаблицаТоваров.ВыбратьСтроки();
         Пока ТаблицаТоваров.ПолучитьСтроку() = 1 Цикл
            ПечРозн    = глФРМ(ТаблицаТоваров.Цена, ТаблицаТоваров.Валюта);
            ПечНаименование    = ТаблицаТоваров.Товар;
            Штрихкод   =  ТаблицаТоваров.ШтрихКод;
            ПечСтрана = ТаблицаТоваров.Страна;
            ПечАртикул = ТаблицаТоваров.Артикул;
            ДобавитьЦенник(Таб, ШтрихКод, ПечСтрана, ПечАртикул, ПечФирма, ТаблицаТоваров.Товар, ТаблицаТоваров.Единица, ПечРозн, Столбик, Ряд);
             глОживить(1);
        
        КонецЦикла;
        
        //Вызов выходного отчета в окно просмотра и редактирования.
        Таб.Опции(0,0,0,0,"ПечатьЦенников","ПечатьЦенников");
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Товарные ценники","");
       
    КонецПроцедуры
    
    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриОткрытии()
       
        СтатусВозврата(0);
        Попытка
            КомпонентABC = СоздатьОбъект("BARCODE.BarcodeCtrl.1");
        Исключение
            Предупреждение("Компонент ActiveBarcode не установлен на данном компьютере!" +
                            РазделительСтрок +
                           "Порядок установки компоненты ActiveBarcode описан в документации.");
            Возврат;
        КонецПопытки;
        ДанныеДляПечати = Форма.Параметр;
                     
        Если ТипЗначенияСтр(ДанныеДляПечати) <> "СписокЗначений" Тогда
            Возврат;
        КонецЕсли;
       
        ПечФирма       = ДанныеДляПечати.Получить("Фирма");
        ТаблицаТоваров = ДанныеДляПечати.Получить("Таблица");
    
       
        Сформировать(ТаблицаТоваров, ПечФирма);
       
    КонецПроцедуры // ПриОткрытии()
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В обработку печати ценника передается не объект, а наименование (строка). Смотрите в модуле справочника номенклатуры. Раз разобрались в свойствах, добавить к наименованию просто
  3. TopicStarter Overlay
    eugenefromvrn
    Offline

    eugenefromvrn

    Регистрация:
    12 сен 2011
    Сообщения:
    20
    Симпатии:
    0
    Баллы:
    1
    я имел в виду, что разобрался как в самой номенклатуре св-во добавить, не более. пихать св-во в наименование не очень бы хотелось. к примеру, есть "ботинок". к нему в ценнике где-то ниже двумя строчками нужно добавить, к примеру, материал верха и материал низа. Вот я думаю, как это можно сделать либо легче будет при печати редактировать сам ценник и дописывать руками типа "кожа" и "замша", чем входить в каждую номенклатуру и в ней выставлять все нужные св-ва....
    за ответ спасибо!
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ну если так обстоит дело - проще заказать доработку печати ценника. Сами вряд ли справитесь

Поделиться этой страницей