8.х БухРегистр.Остатки();

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Dem0lisher, 11 окт 2010.

  1. TopicStarter Overlay
    Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.023
    Симпатии:
    51
    Баллы:
    54
    Здравствуйте!
    Помогите посчитать среднюю цену для номенклатуры с помощью метода "Остатки()" бухгалтерского регистра.
    Структура регистра:
    Измерения:
    Номенклатура-СправочникСсылка.Номенклатура;

    Ресурсы:
    Сумма-Число;
    Количество-Число;

    Пробую делать так:

    Код:
    
    Процедура КнопкаСформироватьНажатие(Кнопка)
    Рег=РегистрыБухгалтерии.РегБух.Остатки(,,,"Номенклатура","Сумма,Количество");
    Для Каждого ТС Из Рег Цикл
    Если ТС.Номенклатура=Номенклатура Тогда
    СумОбщ=СумОбщ+ТС.Сумма;
    КолОбщ=КолОбщ+ТС.Количество;
    КонецЕсли;    
    КонецЦикла;
    СРЦена=СумОбщ/КолОбщ;
    Сообщить("Средняя цена: "+СрЦена);
    КонецПроцедуры
    
    
    
    
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    А вы справку по функции остатки смотрели? Там же все подробно написано.
    Вы уверены, что номенклатура является "Измерением"?
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Тоже склоняюсь к мысли, что попутали субконто с измерением.
Похожие темы
  1. xxx949
    Ответов:
    4
    Просмотров:
    413
  2. xxx949
    Ответов:
    2
    Просмотров:
    303
Загрузка...

Поделиться этой страницей