7.7 БухИтоги 1С:Бухгалтерия v7.7

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Magnum, 17 июн 2006.

  1. TopicStarter Overlay
    Magnum
    Offline

    Magnum Гость Гость

    Такая вот трабла...

    Следующий фрагмент выдает выручку в таблицу значений.
    Для 2005 г. все нормально, т.е. выдавались суммы без НДС.
    В 2006 г. изменился учет, и суммы выдаются с НДС, а надо без.
    Известно, что если из итога вычесть оборот по счету 90.3 (НДС),
    то получается нужный итог. Но помимо этого в каждой строке нужно
    также вычитать счет 90.3.
    КАК???

    Процедура БухИтоги(ВыбНачПериода, ВыбКонПериода);
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Тз = СоздатьОбъект("ТаблицаЗначений");
    Тз.НоваяКолонка("Заказ","Справочник.Заказы");
    Тз.НоваяКолонка("ВН","Справочник.ВидыНоменклатуры");
    Тз.НоваяКолонка("Контр","Справочник.Контрагенты");
    Тз.НоваяКолонка("Выр","Число"); //выручка с НДС (в 2006 г.)
    Тз.НоваяКолонка("НДС","Число"); Сумма НДС (добавлено для 2006 г.)
    Тз.НоваяКолонка("БезНДС","Число"); Сумма без НДС (добавлено для 2006 г.)
    Ит.ИспользоватьСубконто(ВидыСубконто.ВидыНоменклатуры,, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.Заказы,, 1);
    Ит.ИспользоватьКорСубконто(ВидыСубконто.Контрагенты,, 1);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,
    "90.1.1","62.1,62.11",, 2,, "С");

    Ит.ВыбратьСубконто(ВидыСубконто.Заказы);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Заказы) = 1 Цикл
    Ит.ВыбратьСубконто(ВидыСубконто.ВидыНоменклатуры);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.ВидыНоменклатуры) = 1 Цикл
    Ит.ВыбратьКорСубконто(ВидыСубконто.Контрагенты);
    Пока Ит.ПолучитьКорСубконто(ВидыСубконто.Контрагенты) = 1 Цикл
    Если Ит.КорКО() <> 0 Тогда
    Тз.НоваяСтрока();
    Тз.Контр = Ит.КорСубконто(ВидыСубконто.Контрагенты);
    Тз.Заказ = Ит.Субконто(ВидыСубконто.Заказы);
    Тз.ВН = Ит.Субконто(ВидыСубконто.ВидыНоменклатуры);
    ТЗ.Выр = Ит.КорКО(); //Выручка с НДС
    // ТЗ.НДС = ????
    // ТЗ.БезНДС= ????
    //здесь нужно вычислять сумму НДС, или сумму без НДС (используя счет 90.3)
    //или, возможно, после заполнения Тз перебрать ее строки, и как-то
    //вычислить эти значения?...
    КонецЕсли; //есть оборот
    КонецЦикла; //по контрагентам
    КонецЦикла; //по номенклатуре
    КонецЦикла; //по заказам
    КонецПроцедуры
  2. TopicStarter Overlay
    Гость
    Offline

    Гость Гость Гость

    Можно в запрос включить счет 90.3 и корсчет 68.2 или 76.Н.1, и тогда в том месте где требуется вытащить НДС написать примерно так
    Тз.НоваяСтрока();
    Ит.ВыбратьСчета();
    Если Ит.ПолучитьСчет(,СчетПоКоду("90.1.1")) = 1 Тогда
    Тз.Контр = Ит.КорСубконто(ВидыСубконто.Контрагенты);
    Тз.Заказ = Ит.Субконто(ВидыСубконто.Заказы);
    Тз.ВН = Ит.Субконто(ВидыСубконто.ВидыНоменклатуры);
    ТЗ.Выр = Ит.КорКО(); //Выручка с НДС
    ИначеЕсли Ит.ПолучитьСчет(,СчетПоКоду("90.3")) = 1 Тогда
    ТЗ.НДС = ????
    ТЗ.БезНДС= ????
    КонецЕсли;

    на счете 90.3 должны быть такие же аналитические разрезы что и на 90.1.1 (ВН,Контрагенты,Заказы)

Поделиться этой страницей