7.7 Бухгалтерский запрос

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Cooper-Mixal, 29 июл 2010.

  1. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Добрый день Уважаемые!

    делаю отчет по закупке материалов. Нужен счет 60.1 в корреспонденции с 10

    Код:
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,, 1);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "60.1", "10",, 3,, "С");
    Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл 
    
    Таб.ВывестиСекцию("Строка");
    
    КонецЦикла;
    
    

    Как мне взять материалы, которые были получены от поставщика?
  2. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Добрый день Уважаемые!

    делаю отчет по закупке материалов. Нужен счет 60.1 в корреспонденции с 10

    Код:
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,, 1);
    Ит.ИспользоватьКорСубконто(ВидыСубконто.Материалы,, 1);
    
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "60.1", "10",, 3,, "С");
    Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл 
    Ит.ВыбратьКорСубконто(1);
    Пока Ит.ПолучитьКорСубконто(1) = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    КонецЦикла;
    
    
    
    Как мне взять Сумму и количество по материалам, которые были получены от поставщика?
    Надо Брать нижеследующий код?
    Код:
    Ит.ВыбратьКорСчета(1, 2);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл
    ИТ.КорДО();
    КонецЦикла;
    
    
  3. TopicStarter Overlay
    Cooper-Mixal
    Offline

    Cooper-Mixal Опытный в 1С

    Регистрация:
    29 июн 2008
    Сообщения:
    193
    Симпатии:
    0
    Баллы:
    26
    Всё разобрался

    Надо было брать Ит.КорКО(), а не КорДО!

Поделиться этой страницей