7.7 Бухгалтерские итоги с периодичностью "Проводка"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ALL_EG, 4 авг 2010.

  1. TopicStarter Overlay
    ALL_EG
    Offline

    ALL_EG Опытный в 1С

    Регистрация:
    4 авг 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Уважаемые коллеги!!! помогите разобраться в следующей проблеме:

    в 7.7 получаю бух.итоги по определенным счетам с дополнительным разворотом по проводке

    БИ.ВыполнитьЗапрос(НачДата,КонДата,"90.1.1,90.2.1,45,41.1,62.1,50.1,45,41.2",,,,"Проводка",5);

    Синтаксис:
    ВыполнитьЗапрос(<НачалоПериода>,<КонецПериода>,<Счет>,<КоррСчет>,<Валюта>,<ТипИтогов>,<Периодичность>,<ТипСуммы>)

    тип суммы я передаю как "Сумма и Количество"..
    он не видит проводки, в которых один из ресурсов равен 0..
    т.е. если "Количество=0", он эту проводку не получает..и, наоборот, соответственно..

    Пример кода:
    Код:
    ...	
    Т=СоздатьОбъект("ТаблицаЗначений");
    Т.НоваяКолонка("Док",,,,"Документ");
    Т.НоваяКолонка("ДокПредставление",,,,"Представление");
    Т.НоваяКолонка("Контрагент",,,,"Контрагент");
    Т.НоваяКолонка("РеализацияКоличество",,,,"Реализация (Кол)");
    Т.НоваяКолонка("РеализацияСумма",,,,"Реализация (Сумма)");
    Т.НоваяКолонка("СебестоимостьКоличество",,,,"Себестоимость (Кол)");
    Т.НоваяКолонка("СебестоимостьСумма",,,,"Себестоимость (Сумма)");
    
    БИ=СоздатьОбъект("БухгалтерскиеИтоги");
    БИ.ВыполнитьЗапрос(НачДата,КонДата,"90.1.1,90.2.1,45,41.1,62.1,50.1,45,41.2",,,,"Проводка",5);
    
    БИ.ВыбратьПериоды(); 
    
    Т.УдалитьСтроки();
    
    Пока БИ.ПолучитьПериод()=1 Цикл
    
    Оп=БИ.Операция;
    
    
    /////////////////////////////////
    //Реализация (оптовая)          
    /////////////////////////////////
    
    Если Оп.Документ.Вид()="Реализация" Тогда
    
    ВидДок=Оп.Документ.Вид();
    КонтрагентДок=Оп.Документ.Контрагент;
    
    //реализация
    Если (Оп.Дебет.Счет=СчетПоКоду("62.1")) И 
    (Оп.Кредит.Счет=СчетПоКоду("90.1.1"))  Тогда
    
    ВидДок=Оп.Документ.Вид();
    КонтрагентДок=Оп.Документ.Контрагент;
    Оп.Документ.ВыбратьСтроки();
    Пока Оп.Документ.ПолучитьСтроку()=1 Цикл
    Т.НоваяСтрока();
    Т.Док=ВидДок;
    Т.ДокПредставление="Реализация";
    Т.Контрагент=КонтрагентДок;
    Т.РеализацияКоличество= Оп.Документ.Количество;
    Т.РеализацияСумма=Оп.Документ.Сумма;
    Т.СебестоимостьКоличество=0;
    Т.СебестоимостьСумма=0;
    КонецЦикла;
    
    КонецЕсли;//реализация (проводка)
    
    //себестоимость
    //(!!!!!!!!!!!!!!!! НЕ ВИДИТ ПРОВОДКИ У НЕКОТОРЫХ ДОКУМЕНТОВ (если в проводке один ресурсов 0)!!!!!!!!!!!!!)
    Если (Оп.Дебет.Счет=СчетПоКоду("90.2.1")) И 
    (Оп.Кредит.Счет=СчетПоКоду("41.1"))  Тогда
    
    ВидДок=Оп.Документ.Вид();
    КонтрагентДок=Оп.Документ.Контрагент;
    
    Т.НоваяСтрока();
    Т.Док=ВидДок;
    Т.ДокПредставление="Реализация";
    Т.Контрагент=КонтрагентДок;
    Т.РеализацияКоличество= 0;
    Т.РеализацияСумма=0;
    Т.СебестоимостьКоличество=Оп.Количество;
    Т.СебестоимостьСумма=Оп.Сумма;
    
    
    КонецЕсли;//себестоимость (проводка)
    
    КонецЕсли;//Реализация
    
    
    ...
    
    
    Пожалуйста, помогите..
    Спасибо!
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Вообще-то, запрос работает наоборот: если хотя бы по одному из типов сумм есть остаток, то это попадает в запрос.

    Поэтому тут надо смотреть в связке с БД, уверен, что работает правильно)))

    Можно для начала не указывать тип сумм, по умолчанию выбираются все.
  3. TopicStarter Overlay
    ALL_EG
    Offline

    ALL_EG Опытный в 1С

    Регистрация:
    4 авг 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Пробовал и не указывать..не работает..
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Выложи саму обработку и напиши, что за конфигурация.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Я бы пошел "от обратного". Получал документы (если нужно с фильтром по контрагенту/товару) и анализировал проводки этого документа....

Поделиться этой страницей