8.х Бухгалтерия ред. 2.1(РБ) Заполнение табличной части

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем sylverby, 6 авг 2017.

  1. TopicStarter Overlay
    sylverby
    Offline

    sylverby

    Регистрация:
    31 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Не удаётся заполнить табличную часть.
    Не знаю что делаю не так.
    Помогите плиз.
    Заранее благодарю.
    --- Объединение сообщений, 6 авг 2017 ---
    Всё вроде как работает но табличная часть с итогами не наполняется и выводиться.
    --- Объединение сообщений, 6 авг 2017 ---
    // Функция формирует табличный документ с Внешней печатной формой
    //
    // Возвращаемое значение:
    // Табличный документ - печатная форма акта
    //
    Функция ПечатьВнешнейПечатнойФормы(МассивОбъектов, ОбъектыПечати) Экспорт

    ТабДок = новый ТабличныйДокумент;

    ТабДок.АвтоМасштаб = Истина;
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    ТабДок.ЭкземпляровНаСтранице= 1;

    УстановкаМинимальныхПолейДляПечати(ТабДок);
    Макет = ПолучитьМакет("СчетФактура_РФ");

    ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
    ОбластьДанные = Макет.ПолучитьОбласть("Данные");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
    Запрос.Текст ="ВЫБРАТЬ
    | РеализацияТоваровУслуг.АдресДоставки,
    | РеализацияТоваровУслуг.ВалютаДокумента,
    | РеализацияТоваровУслуг.ГлавныйБухгалтер,
    | РеализацияТоваровУслуг.Грузоотправитель,
    | РеализацияТоваровУслуг.Грузополучатель,
    | РеализацияТоваровУслуг.Дата,
    | РеализацияТоваровУслуг.ДоговорКонтрагента,
    | РеализацияТоваровУслуг.Контрагент,
    | РеализацияТоваровУслуг.Номер,
    | РеализацияТоваровУслуг.Организация,
    | РеализацияТоваровУслуг.Руководитель,
    | РеализацияТоваровУслуг.СуммаВключаетНДС,
    | РеализацияТоваровУслуг.СуммаДокумента,
    | РеализацияТоваровУслуг.Товары.Номенклатура,
    | РеализацияТоваровУслуг.Товары.ЕдиницаИзмерения,
    | РеализацияТоваровУслуг.Товары.Количество,
    | РеализацияТоваровУслуг.Товары.Цена,
    | РеализацияТоваровУслуг.Товары.Сумма,
    | РеализацияТоваровУслуг.Товары.СтавкаНДС,
    | РеализацияТоваровУслуг.Товары.СуммаНДС,
    | РеализацияТоваровУслуг.Товары.СтранаПроисхождения,
    | РеализацияТоваровУслуг.Товары.Ссылка КАК Ссылка

    | ИЗ
    | Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    | ГДЕ
    | РеализацияТоваровУслуг.Ссылка В (&МассивОбъектов)";

    //Получаем область "Шапка"

    ОбщаяВыборка = Запрос.Выполнить().Выгрузить();

    Для Каждого СсылкаНаОбъект из МассивОбъектов Цикл

    ОбластьШапки.Параметры.Номер = "Счет-фактура № "+СсылкаНаОбъект.ДоговорКонтрагента+" г.";
    ОбластьШапки.Параметры.НомерИсправления = "Исправление № -- от -- ";
    ОбластьШапки.Параметры.ПредставлениеПоставщика = "Продавец: "+СсылкаНаОбъект.Организация;
    ОбластьШапки.Параметры.АдресПоставщика = "Адрес: "+" 210033, Витебская обл., г. Витебск, пр. ФРУНЗЕ, дом № 81";
    ОбластьШапки.Параметры.ИННПоставщика = "ИНН/КПП продавца: 300237386 / 300237386 ";
    ОбластьШапки.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: он же";
    ОбластьШапки.Параметры.ПредставлениеГрузополучателя = "Грузополучатель и его адрес: "+СсылкаНаОбъект.Контрагент+", "+СсылкаНаОбъект.АдресДоставки;
    ОбластьШапки.Параметры.ПоДокументу = "К платежно-расчетному документу №: от ";
    ОбластьШапки.Параметры.ПредставлениеПокупателя = "Покупатель: "+СсылкаНаОбъект.Контрагент;
    ОбластьШапки.Параметры.АдресПокупателя = "Адрес: "+СсылкаНаОбъект.АдресДоставки;
    ОбластьШапки.Параметры.ИННПокупателя = "ИНН/КПП покупателя: ";
    ОбластьШапки.Параметры.Валюта = "Валюта: наименование, код Российский рубль, 643";

    ТабДок.Вывести(ОбластьШапки);

    //Получаем область "Данные"

    Отбор = Новый Структура;
    Отбор.Вставить("Ссылка",СсылкаНаОбъект);
    Выборка = ОбщаяВыборка.НайтиСтроки(Отбор);

    ИтогоСумма = 0;
    ИтогоСуммаНДС = 0;
    ИтогоВсего = 0;


    Для Каждого Стр из Выборка Цикл
    ЗаполнитьЗначенияСвойств(ОбластьДанные.Параметры,Стр);

    ИтогоСумма = ИтогоСумма + Стр.Сумма;
    ИтогоСуммаНДС = ИтогоСуммаНДС + Стр.СуммаНДС;
    ИтогоВсего = ИтогоВсего + Стр.Всего;

    ТабДок.Вывести(ОбластьДанные);
    КонецЦикла;

    //Получаем область "Подвал"
    ОбластьПодвал.Параметры.ИтогоСумма = ИтогоСумма;
    ОбластьПодвал.Параметры.ИтогоСуммаНДС = ИтогоСуммаНДС;
    ОбластьПодвал.Параметры.ИтогоВсего = ИтогоВсего;

    ТабДок.Вывести(ОбластьПодвал);
    ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЦикла;

    Возврат ТабДок;
    КонецФункции

    Вложения:

    Последнее редактирование: 6 авг 2017
  2. TopicStarter Overlay
    sylverby
    Offline

    sylverby

    Регистрация:
    31 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Должно получиться как-то так
    --- Объединение сообщений, 6 авг 2017 ---
    "Подвал" так же выводиться (Руководитель и т.д.)

    Вложения:

  3. pavl_vs
    Offline

    pavl_vs Профессионал в 1С

    Регистрация:
    18 июн 2011
    Сообщения:
    443
    Симпатии:
    35
    Баллы:
    54
    Вы уж лучше предоставьте целиком саму ВПФ.epf, а то выкладываете только то, что важным кажется Вам.

    Особого смысла в предоставленных картинках нет, уж лучше показали бы результат, а то сказано Руководитель выводится, а в функции соответствующих строк нет -> недоверие к предоставленному материалу.
  4. TopicStarter Overlay
    sylverby
    Offline

    sylverby

    Регистрация:
    31 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Как просили загрузил ВПФ

    Вложения:

  5. pavl_vs
    Offline

    pavl_vs Профессионал в 1С

    Регистрация:
    18 июн 2011
    Сообщения:
    443
    Симпатии:
    35
    Баллы:
    54
    Непонятно откуда Вы взяли такое?
    Основное замечание - не нужен запрос, который Вы привели в топике, а значит не нужно и все последующее, связанное с ним.

    ВПФ при регистрации связывается с документом, получаете ссылку на него, а значит ко всем необходимым реквизитам, а так же к его ТЧ.
    И теперь в самой обработке по ссылке получайте все необходимое.

    Грязи в обработке много, она не мешает работе обработки, но раздражает при чтении.
    Чистить Вам.
    И доделывать тоже Вам.

    Короче, возвращаю Вам поправленную и работающую ВПФ.

    Вложения:

    sylverby нравится это.
  6. TopicStarter Overlay
    sylverby
    Offline

    sylverby

    Регистрация:
    31 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Спасибо за мысль.
    Работает. тока колонки № 2 или № 10 не отображаются и в шапке "ИНН/КПП покупателя".
    где данные драть и главное как? .
    Я переделал запрос вчера - заработало но колонка №10 как не работала так и не работает.
    --- Объединение сообщений, 8 авг 2017 ---
    Вообще за обработку отдельное СПАСИБО !!!
    --- Объединение сообщений, 8 авг 2017 ---
    за опечатки сорри...:( вместо "или" надо "и". Сайт чёта тормозит...-Banghead-
    --- Объединение сообщений, 8 авг 2017 ---
    моя переделанная ВПФ

    Вложения:

    Последнее редактирование: 8 авг 2017
  7. TopicStarter Overlay
    sylverby
    Offline

    sylverby

    Регистрация:
    31 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    как я понимаю в справочнике "номенклатура" нет ни "номера ГТД"-№10 и "страны происхождения"-№10а.
    поэтому "забивается в табличную часть только"беларусь"-10а и то не везде
  8. pavl_vs
    Offline

    pavl_vs Профессионал в 1С

    Регистрация:
    18 июн 2011
    Сообщения:
    443
    Симпатии:
    35
    Баллы:
    54
    Во-первых, ячейке в колонке 2 нужно присвоить параметр, например, ЕдиницаИзмеренияКод и поскольку напрямую в ТЧ документа нет Кода, то следует его заполнять дополнительной строкой ОбластьДанные.Параметры.ЕдиницаИзмеренияКод = Стр.ЕдиницаИзмерения.Код;.
    Аналогично с любой другой.

    Не понимаю и проблемы с ИНН/КПП Контрагента; ведь Контрагент - это объект и в шапке документа он присутствует в этом качестве, а значит доступны его реквизиты, в т.ч. и ИНН и КПП, если они заполнены.
    --- Объединение сообщений, 9 авг 2017 ---
    Для каждой позиции номенклатуры может быть введена и страна (код её по ссылке берется автоматом из справочника стран - для России это 643).
    Для импортных товаров придется заполнять и номер ГТД.

    Ну а теперь все переверните - ведь для Вас, как я понимаю, российские товары это импорт.
    Последнее редактирование: 9 авг 2017
  9. TopicStarter Overlay
    sylverby
    Offline

    sylverby

    Регистрация:
    31 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    строчку внедрил - работает.
    Спасиб ;).
    Завтра попробую разобраться с ИНН/КПП

Поделиться этой страницей