8.х УПП Бухгалтерия Предприятия 2.0

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем American, 24 апр 2010.

  1. TopicStarter Overlay
    American
    Offline

    American Опытный в 1С

    Регистрация:
    28 июл 2008
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    Установил БП 2.0, решил попробовать перенести данные из 1.6. Открыл помощник перехода, опция подключения к базе. А список баз для переноса пуст! Мож кто знает где оно базы ищет? подскажите! :unsure:
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Данные берутся из списка баз, который Вы видите на экране при запуске 1С.
    Это файл ibases.v8i и ibases.v8l

    Если в списке ничего нет - то и выбирать не из чего...
  3. TopicStarter Overlay
    American
    Offline

    American Опытный в 1С

    Регистрация:
    28 июл 2008
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    В списке запуска 1С 8.2 кроме этой новой еще две базы. Одна 2.0 другая 1.6.24. Вот из нее то и нужно перенести данные. А в обработке она не появляется. Пащиму!? :unsure:
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Хм, у меня все появляется... Посмотрите в конфигураторе в событии сбора данных, что там выдает?
  5. TopicStarter Overlay
    American
    Offline

    American Опытный в 1С

    Регистрация:
    28 июл 2008
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    а где это событие сбора данных? Я не программист, сори...
  6. TopicStarter Overlay
    American
    Offline

    American Опытный в 1С

    Регистрация:
    28 июл 2008
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    code:
    //пути к локальным базам
    Путь=СокрЛП(ScrptCtrl.Run("Get1CV8Titles")) + "\1C\1Cv81\ibases.v8i";
    Файл = Новый Файл(Путь);
    Если Файл.Существует() Тогда
    РазложитьПуть(Путь);
    КонецЕсли;

    оно ищет в списке баз 8.1, если я правильно понял, а у меня 8.2. где список баз в предприятии 8.2?
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Это локальные базы 8.1, ниже есть код получения пути к базам 8.2
    А путь можно посмотреть в по кнопке "настройка" в списке баз (при запуске)
  8. Kirill_NN
    Offline

    Kirill_NN Опытный в 1С

    Регистрация:
    2 фев 2007
    Сообщения:
    110
    Симпатии:
    0
    Баллы:
    26
    А БП 1.6 не базовая??
    Если базовая то помошник перехода не работает... Только с версии проф...

    PS
    Кстати кто вобще уже переносил... Мой главбух сказал здать до осени, пока 1С ее не "вылижут", хотя самому мне кажется что уже второй, максимум третий квартал и 1С перестанет поддерживать 1,6 или будут выпускать только обновления с отчетностью, без исправления ошибок...
  9. TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    веду учёт в 2.0, но у меня УСН и это новая база....
    пока вроде нормально...
  10. x-a-d
    Offline

    x-a-d Опытный в 1С

    Регистрация:
    3 сен 2009
    Сообщения:
    184
    Симпатии:
    0
    Баллы:
    26
    http://www.1c.ru/news/info.jsp?id=11651
    цитирую оттуда

    Порядок поддержки редакции 1.6 конфигурации "Бухгалтерия предприятия"

    В течение 2010 года в редакции 1.6 конфигурации "Бухгалтерия предприятия" планируется поддерживать ведение учета, изменения законодательства и обновление форм регламентированной отчетности. В 2011 году поддержку редакции 1.6 планируется завершить, пользователям будет предоставлена возможность сформировать бухгалтерскую и налоговую отчетность за 2010 год.

    Фирма "1С" рекомендует пользователям конфигурации "Бухгалтерия предприятия" переходить на новую редакцию 2.0.
  11. TopicStarter Overlay
    American
    Offline

    American Опытный в 1С

    Регистрация:
    28 июл 2008
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    Тема не о поддержке БП 1.6, а о переносе данных из 1.6 в 2.0. Встроенная обработка переноса данных не работает при попытке забрать данные из конфы сконвертированной под 8.2. Она даже список баз для отбора данных берет только из списка 8.1. При попытке работать с базой в формате 8.2 выдает ошибку о несовместимости формата базы данных.
    Резюме: Не спешить с новинками от 1С - сплошные косяки! Ждем исправления ошибок.

    Тема закрыта!
  12. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Достаточно исправить один символ и все будет работать :)
    Не торопитесь с выводами...
  13. TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.759
    Симпатии:
    147
    Баллы:
    104
    рассказали бы какой символ и где исправить... было бы очень интересно.
  14. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код:
    // Попытка подключения к ИБ
    //
    Функция ПодключитьсяКИБ()
    
    Попытка
    Объект = Новый COMОбъект("V81.ComConnector");
    СтрокаПодключения = "File="""+ПутьКИБ+"""";
    
    СтрПользователь = "";
    СтрПароль = "";
    Если ЗначениеЗаполнено(ПользовательИБ) Тогда
    СтрокаПодключения = СтрокаПодключения + ";Usr=""" + ПользовательИБ + """";
    КонецЕсли;
    Если ЗначениеЗаполнено(ПарольИБ) Тогда
    СтрокаПодключения = СтрокаПодключения + ";Pwd=""" + ПарольИБ + """";
    КонецЕсли;
    
    v8 = Объект.Connect(СтрокаПодключения);
    Возврат Истина;
    Исключение
    ЗафиксироватьОшибку(ЭтапКонвертации, "Не удалось произвести подключение к информационной базе: " + ИмяИБ, ОписаниеОшибки());
    Возврат Ложь;
    КонецПопытки;
    
    //Возврат Открыта;
    
    КонецФункции
    
    
    Как видим, соединение выполняется для 8.1, поэтому достаточно его изменить на 8.2
  15. TopicStarter Overlay
    American
    Offline

    American Опытный в 1С

    Регистрация:
    28 июл 2008
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    СПАСИБО ДОБРЫЙ ЧЕЛОВЕК! Ща только надо проверить корректность переноса.

    Не стоит заниматься оверквоттингом. BabySG

Поделиться этой страницей