[РЕШЕНО] БП 3.0 Внешний отчет

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем Shrek_kz, 31 мар 2015.

  1. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    Код:
    Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды) Экспорт
      // Реализация логики команды
      Если ИдентификаторКоманды = <ЗаданноеИмяКоманды_Строка> Тогда
             КОД_ФОРМИРОВАНИЯ_ОЧТЕТА;
      КонецЕсли;
    КонецПроцедуры
  2. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
    Мне нужно открыть форму отчета
  3. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    Вот отчет, вот результат:
    upload_2015-4-2_9-58-27.png

    upload_2015-4-2_9-59-36.png


    upload_2015-4-2_10-0-1.png

    upload_2015-4-2_10-1-9.png



    upload_2015-4-2_10-1-54.png

    upload_2015-4-2_10-2-29.png

    Что мне нужно сделать, чтобы появились такие же трудности, как у Вас?
  4. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
    Сделал сейчас как в примере вашем через ОткрытиеФормы и снова метод объекта не обнаружден (ВыполнитьКоманду)
    Код:
    функция СведенияОВнешнейОбработке() export
      ПараметрыРегистрации = Новый Структура;
      ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
      ПараметрыРегистрации.Вставить("Наименование", "Остатки в кубах");
      ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
      ПараметрыРегистрации.Вставить("Версия", "1.0");
      ПараметрыРегистрации.Вставить("Информация", "Остатки в кубах");
      ТЗ = Новый ТаблицаЗначений;
      ТЗ.Колонки.Добавить("Представление");
      ТЗ.Колонки.Добавить("Идентификатор");
      ТЗ.Колонки.Добавить("Использование");
      ТЗ.Колонки.Добавить("ПоказыватьОповещение");
      ТЗ.Колонки.Добавить("Модификатор");
      Команды = ТЗ.Добавить();
      Команды.Представление = "Отчет в кубах";
      Команды.ПоказыватьОповещение = Ложь;
      Команды.Использование = "ОткрытиеФормы";
      Команды.Идентификатор = "Отчет в кубах";
      ПараметрыРегистрации.Вставить("Команды", ТЗ);
      Возврат ПараметрыРегистрации;
    КонецФункции
    Последнее редактирование модератором: 2 апр 2015
  5. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    Файл внешнего отчета *.EPF или *.ERF?
  6. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
  7. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    Приложите уже сам отчет что ли, гляну внутрь ибо чудеса какие-то....
  8. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
    Вот он.

    Вложения:

  9. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    Версия конфигурации БУХ какая?
  10. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
  11. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    Типовая?
  12. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
  13. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    Видимо только отладчик сможет сказать причину такого поведения, ибо - магия 5 уровня, а обитающие здесь только на 4-ом :)
  14. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
    Все разобрался! Спасибо друзья за помощь!!! Тут не как в 77 поэтому и не мог вкурить почему же так происходит.
  15. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
    И что же было причиной?
  16. TopicStarter Overlay
    Shrek_kz
    Offline

    Shrek_kz Новичок в 1С

    Регистрация:
    31 мар 2015
    Сообщения:
    37
    Симпатии:
    1
    Баллы:
    4
    То что 8 загружает модуль файла а не обращается к нему как в 7 я то правлю файл в конфигураторе и думаю он тутже меняется в предприятии а нифига подобного надо каждый раз было загружать файл во внешний отчет.
    alexburn нравится это.
  17. tulipe
    Offline

    tulipe

    Регистрация:
    13 апр 2016
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Спасибо, мне помогли -Happy--Kiss-

Поделиться этой страницей