8.х БП БП 2.0 Печать

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем malefik, 21 май 2012.

  1. TopicStarter Overlay
    malefik
    Offline

    malefik Опытный в 1С

    Регистрация:
    17 ноя 2009
    Сообщения:
    97
    Симпатии:
    1
    Баллы:
    26
    Здравствуйте, помогите пожалуйста в решении такой дилеммы:
    Обработка ПечатьТТН, необходимо сделать, так, чтобы во вкладке "Транспортная накладная" в поле пункта 4 ("Перечень прилагаемых к транспортной накладной документов...") можно было путем выбора документа "Поступление товаров и услуг" подставить значение "НомерВходящегоДокумента" и "ДатаВходящегоДокумента".

    Вот какой код я попытался использовать для этого, но он не работает.

    Код:
    Процедура Пункт4_1НачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Форма = Документы.ПоступлениеТоваровУслуг.ПолучитьФормуВыбора("ФормаВыбора", Элемент);
    ВыбранныйДокумент = Форма.ОткрытьМодально();
    СведенияОВходящемДокументе = Документы.ПоступлениеТоваровУслуг.ПолучитьДанныеВыбора (ВыбранныйДокумент, ТекущаяДата());
    ЭлементыФормы.Пункт4_1.Значение = СведенияОВходящемДокументе.НомерВходящегоДокумента;
    КонецПроцедуры
    Спасибо за помощь!
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Странно, зачем форму выбора получать-то ? Достаточно получить ссылку на документ поступления, и выбрать необходимые реквизиты.
  3. TopicStarter Overlay
    malefik
    Offline

    malefik Опытный в 1С

    Регистрация:
    17 ноя 2009
    Сообщения:
    97
    Симпатии:
    1
    Баллы:
    26
    Все дело в том, что в программировании 1С я только-только делаю самые первые шаги.
    Кодом не поможете?
  4. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.949
    Симпатии:
    149
    Баллы:
    104
    Тип данных у того поля - СТРОКА.
    Вы, надеюсь, его не меняли?)) Просто добавили кнопку выбора? Или как?
    Советую именно так и сделать.

    Событие "Начало выбора" выбрали правильно.
    Код можно написать такой:
    Код:
    Процедура Пункт4_1НачалоВыбора(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    Форма = Документы.ПоступлениеТоваровУслуг.ПолучитьФормуВыбора(, Элемент);
    ДокПоступления = Форма.ОткрытьМодально();
    
    Если ЗначениеЗаполнено(ДокПоступления) Тогда
    
    ВходящийНомер = ?(ПустаяСтрока(ДокПоступления.НомерВходящегоДокумента), "", "№ " + ДокПоступления.НомерВходящегоДокумента);
    ВходящаяДата = ?(ДокПоступления.ДатаВходящегоДокумента = '0001-01-01', "", " от " + Формат(ДокПоступления.ДатаВходящегоДокумента, "ДФ=dd.MM.yyyy"));
    
    Пункт4_1 = ВходящийНомер + ВходящаяДата;
    
    КонецЕсли;
    
    КонецПроцедуры
    
  5. TopicStarter Overlay
    malefik
    Offline

    malefik Опытный в 1С

    Регистрация:
    17 ноя 2009
    Сообщения:
    97
    Симпатии:
    1
    Баллы:
    26
    Черт побери, работает великолепно!
Похожие темы
  1. lehin_m
    Ответов:
    3
    Просмотров:
    1.031
Загрузка...

Поделиться этой страницей