7.7 Блокировка кнопки "Delete" программно

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем elektron, 6 авг 2010.

  1. TopicStarter Overlay
    elektron
    Offline

    elektron

    Регистрация:
    9 июл 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Как при в вхождении в проведенный документ блокировать кнопку "Delete" программно, чтобы пользователь не мог удалить введенные строки
  2. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ПриУдаленииСтроки() 
    Предупреждение("Нельзя удалять строки",5); 
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры
    
  3. Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Лучше так:

    Код:
    Процедура ПриУдаленииСтроки() 
    Если Проведен()=1 Тогда
    Предупреждение("Нельзя удалять строки",5); 
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецПроцедуры
    
    
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    А еще лучше использовать метод формы

  5. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Снял с проведения, удалил строку и провел заново - крутняк :)
    Уж лучше так:
    Код:
    Процедура ПриУдаленииСтроки() 
    Если Выбран() = 1 Тогда
    Предупреждение("Нельзя удалять строки",5); 
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецПроцедуры
    
    
    
  6. Black Cat
    Offline

    Black Cat Опытный в 1С

    Регистрация:
    18 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Ну дык автору нужно запретить удалять строки только в ПРОВЕДЕННЫХ документах.

    можно один вопрос не по теме ? Откуда вы взяли эту цитату ? Что за справочник ? И где если можно его скачать ?
  7. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Синтакс-помощник

Поделиться этой страницей