8.х Блокирование ячейки табличной части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем 1С-Ученик, 21 окт 2010.

  1. TopicStarter Overlay
    1С-Ученик
    Offline

    1С-Ученик

    Регистрация:
    21 окт 2010
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Всем привет!
    Проблема такая:

    Имеется много документов Поступление товаров и услуг. Оператор при открытии уже проведенного документа не должен изменять колонку Цена, в табличной части Товары. Это я делаю:

    Процедура ПриОткрытии()

    Если условие Верно

    Тогда
    ЭлементыФормы.Товары.Колонки.Цена.Доступность = верно
    Иначе
    ЭлементыФормы.Товары.Колонки.Цена.Доступность = ложь
    КонецЕсли

    А вот если Оператору нужно в уже проведенный документ добавить новую позицию, то использование

    Если условие Верно
    Тогда
    ЭлементыФормы.Товары.Колонки.Цена.Доступность = верно
    Иначе
    ЭлементыФормы.Товары.Колонки.Цена.Доступность = ложь
    КонецЕсли

    уже не катит, так как снова разблокируется вся колонка

    Как разблокировать именно текущую сттроку при условии - текущая ячейка цена пустая. Причем остальные не пустые ячейки цена, должны остаться заблокированными?

    Очень Вам благодарен!!!
  2. PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Код:
     Процедура ТоварыПередНачаломДобавления(Элемент, Отказ, Копирование)
    ТекСтрока = ЭлементыФормы.Товары.ТекущаяСтрока;
    ТекСтрока.Цена.Доступность = Истина;
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    1С-Ученик
    Offline

    1С-Ученик

    Регистрация:
    21 окт 2010
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1

    Сперва я блокирую табличную часть:
    Код:
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    ЭлементыФормы.Товары.Колонки.Цена.Доступность = Ложь;
    
    
    А затем вставляю Ваш код в
    Код:
    Процедура ТоварыПередНачаломДобавления(Элемент, Отказ, Копирование)
    

Поделиться этой страницей