8.х Блок-схема

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем warshadow, 9 апр 2011.

  1. TopicStarter Overlay
    warshadow
    Offline

    warshadow

    Регистрация:
    29 мар 2011
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Мне надо реализовать блок-схему, как реализовать объекты я знаю, вопрос в том как это выглядит это в 1С...
    Например у меня имеется:
    Справочник-ДарЧитателя
    Документ-ПоступленияКниг(В нем ВидОперации- ОтИздательства и ОтЧитателя)
    Документ-РеализацяиКинг (В нем модуль)
    РегистНакопления-Поступления(типа-приход)
    Отчет- ПоступлениеКниг, реализацияКниг
    Т.е получается чтоли так:

    Как описать модуль в блок схеме я не могу понять....

    Вложения:

    • БС.jpg
      БС.jpg
      Размер файла:
      53,7 КБ
      Просмотров:
      78
    • БС1.jpg
      БС1.jpg
      Размер файла:
      17,7 КБ
      Просмотров:
      67
  2. TopicStarter Overlay
    warshadow
    Offline

    warshadow

    Регистрация:
    29 мар 2011
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Да забыл модуль...
    Код:
    
    Процедура ОбработкаПроведения(Отказ, Режим)
    
    Запрос = Новый Запрос(
    "ВЫБРАТЬ
    |	РеализацияКнигКонтрагентуТаблРеализКниКонтр.НаименованиеКниги,
    |  РеализацияКнигКонтрагентуТаблРеализКниКонтр.Издательство,
    |	СУММА(РеализацияКнигКонтрагентуТаблРеализКниКонтр.Количество) КАК КоличествоПоДокументу,
    |	ЕСТЬNULL(ПоступлениеРеализацияСписаниеКнигОстатки.КоличествоОстаток,0) КоличествоНаСкладе
    |ИЗ
    |	Документ.РеализацияКнигКонтрагенту.ТаблРеализКниКонтр КАК РеализацияКнигКонтрагентуТаблРеализКниКонтр
    |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ПоступлениеРеализацияСписаниеКниг.Остатки КАК ПоступлениеРеализацияСписаниеКнигОстатки
    |		ПО РеализацияКнигКонтрагентуТаблРеализКниКонтр.НаименованиеКниги = ПоступлениеРеализацияСписаниеКнигОстатки.НаименованиеКниги
    |ГДЕ
    |	РеализацияКнигКонтрагентуТаблРеализКниКонтр.Ссылка = &Ссылка
    |
    |СГРУППИРОВАТЬ ПО
    |	РеализацияКнигКонтрагентуТаблРеализКниКонтр.НаименованиеКниги,
    |	РеализацияКнигКонтрагентуТаблРеализКниКонтр.Издательство,
    |	ПоступлениеРеализацияСписаниеКнигОстатки.КоличествоОстаток" 
    );
    Запрос.УстановитьПараметр("Ссылка",Ссылка);
    Результат = Запрос.Выполнить();
    
    //проверка табличной части
    Если Результат.Пустой() Тогда
    Сообщить("Не заполнена табличная часть!",СтатусСообщения.Важное);
    Отказ=Истина;
    КонецЕсли;
    
    Выборка = Результат.Выбрать();
    
    ПроверкаРеквизитов(Отказ, Режим); //ссылка на процедуру проверяющую заполненнсть реквизитов
    
    
    Пока Выборка.Следующий() Цикл
    
    Если Выборка.КоличествоПоДокументу > Выборка.КоличествоНаСкладе  Тогда
    Сообщить("Невозможно реализовать книгу "+""""+Выборка.НаименованиеКниги+"""");
    Отказ= Истина;
    КонецЕсли;
    
    
    
    
    
    //Движение от Издательства		
    Движение = Движения.ПоступлениеРеализацияСписаниеКниг.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.НаименованиеКниги=Выборка.НаименованиеКниги;
    Движение.ВидПоступления = Выборка.Издательство;
    Движение.Количество = Выборка.КоличествоПоДокументу;
    
    
    КонецЦикла;
    
    
    
    КонецПроцедуры
    
    

Поделиться этой страницей