8.х Бизнес-процессы

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Gfdtk, 29 апр 2008.

  1. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    НУ ты на схеме указывал там внизу реквизиты адресации
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Да. И так для всех.
    upload_2015-9-23_14-48-30.png
  3. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    нет. вот утебя схема там на заднем планет. Там директор по маркетингу. написано можетшь мне свойства этого показать - там внизу в свосвах адресация
  4. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    upload_2015-9-24_12-47-20.png
    --- Объединение сообщений, 24 сен 2015 ---
    Здесь же предопределенные данные указываются.
  5. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Да, я же писал выше что можно либо тут предопределнными заполнить, либо уже в коде когда залдача созадется прописывать кому она
  6. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Привет. Исполнитель создает служебную записку, она в зависимости от того кто ее создал попадает к директору марки. Здесь у меня 2 вопроса. Каким образом все таки связан с процессом регистр адресации? И как реализовать возможность комментирования этапа? Т.е. чтобы директор марки не закрывал этап, а отослал служебку назад исполнителю с каким-то комментом?
  7. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Да, определенно нужно разобраться с этим регистром. Народ, объясните пожалуйста связь кто знает?
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Честно скажу - затрудняюсь ответить :(
    nbIpKuH_BaH9I нравится это.
  9. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Адресация напрямую используется для указания исполнителя в создаваемой задаче. Если по БП нужно доп. действие - это будет доп. ветка маршрута БП. В регистре адресации указываются единицы, которым будет доступны задачи в списке задач, появляющиеся на разных стадиях выполнения БП.
    nbIpKuH_BaH9I нравится это.
  10. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Я же выше писал тебе все. из этого регистр можно предпределнные элементы использовать для адресации в БП. Если нет то в коде можно оттуда брать.
    Что бы задачу директор не выполнил то надо ветку ниже прописать свыполненим условия и уходом на предыдущий этап
    nbIpKuH_BaH9I нравится это.
  11. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Не расстраивайся :)
    Все равно не понятно.
    Давайте задачу изначально опишу. Менеджер по продажам автомобилей хочет согласовать скидку на автомобиль. Создает бизнес-процесс. Задача должна направляться к директору марки того подразделения в котором этот менеджер. Директор марки может либо отказать, либо согласовать, либо задать какой-то вопрос инициатору. Я вот это создал.

    Вот смотри. Есть у меня карта маршрута
    upload_2015-9-29_9-1-20.png
    Вот код что прописал
    Код:
    //////////////////////////////////////////////////////////////////////////////////
    //// РАЗДЕЛ ПРОЦЕДУР И ФУНКЦИЙ
    
    Функция ПолучитьОрганизацию(мПользователь)
    
        мОрганизация = Справочники.Организации.ПустаяСсылка();
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ИсполнителиБизнесПроцессов.Организация
        |ИЗ
        |    РегистрСведений.ИсполнителиБизнесПроцессов КАК ИсполнителиБизнесПроцессов
        |ГДЕ
        |    ИсполнителиБизнесПроцессов.Пользователь = &Пользователь";
        Запрос.УстановитьПараметр("Пользователь", мПользователь);
        ВыборкаЗапроса = Запрос.Выполнить().Выбрать();
        Если ВыборкаЗапроса.Следующий() Тогда
            мОрганизация = ВыборкаЗапроса.Организация;
        КонецЕсли;
        Возврат мОрганизация;
    
    КонецФункции // ПолучитьОрганизацию()
    
    Функция ПолучитьДолжность(мПользователь)
    
        мДолжность = Справочники.Должности.ПустаяСсылка();
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ИсполнителиБизнесПроцессов.Должность
        |ИЗ
        |    РегистрСведений.ИсполнителиБизнесПроцессов КАК ИсполнителиБизнесПроцессов
        |ГДЕ
        |    ИсполнителиБизнесПроцессов.Пользователь = &Пользователь";
        Запрос.УстановитьПараметр("Пользователь", мПользователь);
        ВыборкаЗапроса = Запрос.Выполнить().Выбрать();
        Если ВыборкаЗапроса.Следующий() Тогда
            мДолжность = ВыборкаЗапроса.Должность;
        КонецЕсли;
        Возврат мДолжность;
    
    КонецФункции // ПолучитьОрганизацию()
    
    //////////////////////////////////////////////////////////////////////////////////
    //// ОБРАБОТЧИКИ СОБЫТИЙ КАРТЫ БИЗНЕС-ПРОЦЕССА
    
    // Обработчки события "Перед созданием задачи." Директор марки.
    // ................................................................................
    Процедура СогласованиеДиректораМаркиПередСозданиемЗадач(ТочкаМаршрутаБизнесПроцесса, ФормируемыеЗадачи, СтандартнаяОбработка)
    
        НоваяЗадачаДляДиректораМарки               = Задачи.УниверсальнаяЗадача.СоздатьЗадачу();
        НоваяЗадачаДляДиректораМарки.БизнесПроцесс = Ссылка;
        НоваяЗадачаДляДиректораМарки.ТочкаМаршрута = БизнесПроцессы.УтверждениеСкидокНаАвтомобиль.ТочкиМаршрута.СогласованиеДиректораМарки;
        НоваяЗадачаДляДиректораМарки.Наименование  = "Согласование директором марки";
        НоваяЗадачаДляДиректораМарки.Дата          = ТекущаяДата();
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ИсполнителиБизнесПроцессов.Пользователь
        |ИЗ
        |    РегистрСведений.ИсполнителиБизнесПроцессов КАК ИсполнителиБизнесПроцессов
        |ГДЕ
        |    ИсполнителиБизнесПроцессов.Должность = &Должность
        |    И ИсполнителиБизнесПроцессов.Организация = &Организация";
        Запрос.УстановитьПараметр("Должность"  , Справочники.Должности.НайтиПоКоду("ЦБ000054")); // Директор марки
        Запрос.УстановитьПараметр("Организация", ПолучитьОрганизацию(ПараметрыСеанса.Пользователь));
        ВыборкаЗапроса = Запрос.Выполнить().Выбрать();
        Пока ВыборкаЗапроса.Следующий() Цикл
            мПользователь = ВыборкаЗапроса.Пользователь;
        КонецЦикла;
        Если НЕ ЗначениеЗаполнено(мПользователь) Тогда
            Сообщить("Необходимо указать директора марки для организации: """ + ПолучитьОрганизацию(ПараметрыСеанса.Пользователь) + """");
            Возврат;
        КонецЕсли;
        НоваяЗадачаДляДиректораМарки.Пользователь  = мПользователь;
        НоваяЗадачаДляДиректораМарки.Организация   = ПолучитьОрганизацию(мПользователь);
        НоваяЗадачаДляДиректораМарки.Должность     = ПолучитьДолжность(мПользователь);
        ФормируемыеЗадачи.Добавить(НоваяЗадачаДляДиректораМарки);
    
    КонецПроцедуры
    
    Процедура СозданиеСлужебнойЗапискиПередСозданиемЗадач(ТочкаМаршрутаБизнесПроцесса, ФормируемыеЗадачи, СтандартнаяОбработка)
    
        НоваяЗадачаОтИсполнителя               = Задачи.УниверсальнаяЗадача.СоздатьЗадачу();
        НоваяЗадачаОтИсполнителя.БизнесПроцесс = Ссылка;
        НоваяЗадачаОтИсполнителя.ТочкаМаршрута = БизнесПроцессы.УтверждениеСкидокНаАвтомобиль.ТочкиМаршрута.СозданиеСлужебнойЗаписки;
        НоваяЗадачаОтИсполнителя.Наименование  = "Создание служебной записки инициатором";
        НоваяЗадачаОтИсполнителя.Дата          = ТекущаяДата();
        НоваяЗадачаОтИсполнителя.Пользователь  = ПараметрыСеанса.Пользователь;
        НоваяЗадачаОтИсполнителя.Организация   = ПолучитьОрганизацию(ПараметрыСеанса.Пользователь);
        НоваяЗадачаОтИсполнителя.Должность     = ПолучитьДолжность(ПараметрыСеанса.Пользователь);
        ФормируемыеЗадачи.Добавить(НоваяЗадачаОтИсполнителя);
    
    КонецПроцедуры
    Но когда создаю новый бизнес процесс, реквизиты задачи пустые. Не понимаю почему. Где эта связь?
  12. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    1. ПередСозданиемЗадачи там простопишешь стандартнаяОбработка=Ложь
    А уже при создании задачи - создаешь задачу
    2. Это После директора марки у тебя долджен быть условный оператор, возврат на доработку или нет. Т.е директор может согласовать\ не согласовать, а может и вернуть для уточнения.
    nbIpKuH_BaH9I нравится это.
  13. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Давай постепенно. Пока без обратной связи. Хочу связь этого чертового регистра с процессом понять. Что я делаю не так? Почему реквизиты не заполнены? Видишь, даже когда инициатор создал задачу, то здесь не написано, кто именно создал. А должен сейчас быть я.
    upload_2015-9-29_9-26-15.png
  14. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Ну ты первый пункт мой выполнил. перенс в При создании задачи.
  15. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Да, тупанул. Стандартную обработку стер и удивляюсь еще. Я же правильно понимаю, что реквизиты в задачи как у меня Организации, Должность, Пользователь предназначены именно для того, кому именно адресовать ту или иную точку маршрута?
  16. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Именно :)
    nbIpKuH_BaH9I нравится это.
  17. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Тогда у меня опять в голове не уложится связь регистра и задачи. Я сейчас просто взял и прям кодом прописал кому именно направить задачу. Так зачем нужен этот регистр? Я же могу данные хранить в коде.
  18. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Ты можешь задачу не кодом создавать, а 1С сама создаст. Ты же ставишь СтандартнаяОбработка=Ложь
    А так если бы у тебя реквизиты адресации предпределенными значениями были бы заполнены то она автоматом задачи на данных адресатов создавала и код писать не надо
    nbIpKuH_BaH9I нравится это.
  19. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Можешь, но это будет омнокод, т.к. в чистой БД твой код умрет :)
    Ты регистром рулишь видимость задач пользователями в общем списке задач по БП.
  20. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Понял. Спасибо.
    --- Объединение сообщений, 29 сен 2015 ---
    Ну я же по сути могу хранить данные в любом регистре...:)
    --- Объединение сообщений, 29 сен 2015 ---
    Тогда открывается вопрос с комментированием задачи? Как это реализовать? В типовых не увидел нигде, что есть условие. Но возможность комментирования есть. Я вот думаю, что наверное просто менять точку маршрута?
Похожие темы
  1. Dmitrij
    Ответов:
    10
    Просмотров:
    645
Загрузка...

Поделиться этой страницей