8.х Бизнес-процесс Согласование документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем PavelBaryshev, 5 авг 2009.

  1. TopicStarter Overlay
    PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, помогите разобраться, есть БП Согласования, такой же как в книге Радченко "Проф разработка". Там он разом раздает всем Рецензентам задачи:
    Процедура НаСогласованиеПриСозданииЗадач(ТочкаМаршрутаБизнесПроцесса, ФормируемыеЗадачи, Отказ)



    Для Каждого Элемент Из Рецензии Цикл

    НоваяЗадача = Задачи.Задача.СоздатьЗадачу();
    НоваяЗадача.Наименование = ("На Согласование " + ДокументНаСогласование);
    НоваяЗадача.БизнесПроцесс = Ссылка;
    НоваяЗадача.ТочкаМаршрута = БизнесПроцессы.Согласование.ТочкиМаршрута.НаСогласование;
    НоваяЗадача.Дата = ТекущаяДата();
    Если Важное Тогда
    НоваяЗадача.Приоритет = 1;
    КонецЕсли;

    // Даты
    НоваяЗадача.КонтрольныйСрок = КонтрольныйСрок;
    // Реквизиты адресации
    НоваяЗадача.Сотрудник = Элемент.Рецензент;

    ФормируемыеЗадачи.Добавить(НоваяЗадача);
    НоваяЗадача.Записать();

    КонецЦикла;

    Записать();
    КонецЦикла;

    А как сделать чтоб по порядку, пока первый не выполнит, второму рецензенту не давать?
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    убрать цикл)) Конкретнее код то весь не видно
  3. TopicStarter Overlay
    PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    В смысли, как убрать цикл? Можно маленький пример?
  4. bssorsk
    Offline

    bssorsk Новичок в 1С

    Регистрация:
    4 дек 2007
    Сообщения:
    34
    Симпатии:
    2
    Баллы:
    4
    тут только при выполнении задачи текущим исполнителем создавать следуюсщему исполнителю задачу.
    А цикл однозначно убирать

Поделиться этой страницей