8.х Бизнес процесс и задачи

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем megret, 8 июл 2010.

  1. TopicStarter Overlay
    megret
    Offline

    megret

    Регистрация:
    18 апр 2008
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Написали бизнес процесс, который обеспечивает последовательное согласование документа. При выборе из списка задач открывается не сама задача, а Форма бизнес процесса (так задумано). В Форму БизнесПроцесса добавлена кнопка "Согласовано" при нажатии на которую текущая задача должна выполнятся. А у меня при каждом нажатии выполняется последняя задача, и даже те, которые не относятся к данному бизнес процессу.
    Заранее спасибо всем!
    Процедура такая:

    Процедура СогласованоНажатие(Элемент)

    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | MegSer_Задача.Ссылка
    |ИЗ
    | Задача.MegSer_Задача.ЗадачиПоИсполнителю КАК MegSer_Задача
    |
    |ГДЕ
    | Выполнена <> Истина";


    Выборка=Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.Прямой);
    Пока Выборка.Следующий() Цикл
    ТекущаяЗадача = Выборка.Ссылка.ПолучитьОбъект();
    КонецЦикла;

    //**********************************

    НоваяСтрока = ЭлементыФормы.РезультатыСогласования.ТекущаяСтрока;
    НоваяСтрока.РезультатСогласования = Перечисления.MegSer_РезультатыСогласования.Согласовано;

    Попытка
    Записать();
    Если НЕ Стартован Тогда
    Старт(); //запустим бизнес-процесс

    КонецЕсли;
    Исключение
    ОбщегоНазначения.Сообщение(ОписаниеОшибки());
    Возврат;
    КонецПопытки;
    Если ТекущаяЗадача.ПроверитьВыполнение() Тогда
    ТекущаяЗадача.ВыполнитьЗадачу();
    КонецЕсли;
    Закрыть(Истина);
    КонецПроцедуры

Поделиться этой страницей