8.х Библиотека подключаемого оборудования и Сканер ШК.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем TODD22, 28 июл 2015.

  1. TopicStarter Overlay
    TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    Здравствуйте.

    Решил использовать эту библиотеку. Объединил её со своей конфигурацией.

    В форму документа добавил обработчики как и написано в документации к БПО.

    Сканер работает. И если поставить в какое то поле курсор то он в него сканирует.

    Необходимо сделать не сканирование в поле. А через обработку оповещения. Соответствующий обработчик я добавил.

    Далее из БПО (демо) я выгрузил драйвер для сканера ШК и загрузил в к себе в базу. Там же нажал кнопку "Установить драйвер". Пишет что "драйвер успешно установлен".

    Но при подключение сканера к форме в обработчике при открытии выводится ошибка что драйвер не установлен или установлен не правильно. Но я так понимаю что драйвер 1С видит. До этого писала ошибку 999 и файл драйвера не найден.

    Есть у кого нибудь мысли какие нибудь?
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Судя по описанию, драйвер может не подключаться при открытии формы, т.к. он у же подключен ранее (при запуске системы, например) и занял порт.

    СерверТО(или СерверПО) каким-нибудь образом инициализируется вообще до открытия формы?

    Судя по коду:
    Код:
    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
    // ПодключаемоеОборудование
    Если МенеджерОборудованияКлиент.ОбновитьРабочееМестоКлиента() Тогда
        ОписаниеОшибки = "" ;
        ПоддерживаемыеТипыВО = Новый Массив();
        ПоддерживаемыеТипыВО.Добавить( "СканерШтрихкода" );
    Если Не МенеджерОборудованияКлиент.ПодключитьОборудованиеПоТипу(УникальныйИдентификатор, ПоддерживаемыеТипыВО, ОписаниеОшибки) Тогда
          ТекстСообщения = НСтр( "ru = 'При подключении оборудования произошла ошибка:
            |""%ОписаниеОшибки%"".'" );
          ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%" , ОписаниеОшибки);
      ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
    КонецЕсли;
    КонецЕсли;
    Необходимо проверить, что происходит внутри МенеджерОборудованияКлиент.ПодключитьОборудованиеПоТипу()

    Судя по коду:
    Код:
    &НаКлиенте
    Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    // ПодключаемоеОборудование
    Если Источник = "ПодключаемоеОборудование"
    И ВводДоступен() Тогда
    Если ИмяСобытия = "ScanData" Тогда
           Если Параметр[ 1 ] = Неопределено Тогда
            ТекКод = Параметр[ 0 ];
    Иначе
            ТекКод = Параметр[ 1 ][ 1 ];
    КонецЕсли;
          ОбработатьПолученныйШК(ТекКод);
    КонецЕсли;
    КонецЕсли;
    // Конец ПодключаемоеОборудование
    КонецПроцедуры
    Где-то должно быть
    Оповестить("ScanData", ["ШтрихКод"]) Либо Оповестить("ИмяСобытия", [ ,[, "ШтрихКод"]]);
    Последнее редактирование: 29 июл 2015

Поделиться этой страницей