7.7 База пишет объект не найден

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ZEMA, 3 ноя 2009.

  1. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    Проблема в базе Бухгалтерия. Сегодня утром бухгалтера обнаружели что в базе в любом документе исчезла ссылка на договора и пишет "Объект не найден" (за все периоды). что могло произойти? Знает ли кто?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Возможно "рухнули" индексы базы. Попробуйте через конфигуратор сделать тестирование и справление базы (сделайте перед этим на всякий случай копию)
  3. TopicStarter Overlay
    ZEMA
    Offline

    ZEMA Опытный в 1С

    Регистрация:
    5 окт 2007
    Сообщения:
    231
    Симпатии:
    0
    Баллы:
    26
    При тестировании программа выдала
    (что это значет?)
    и
    и как понять это?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Возможно кто-то баловался програмно с объектами. Или у вас начинаются проблемы по железу (сыпется винт). Если есть терминал - возможно некорректно "отвалился" пользователь. Или внезапно выключалось питание. ПРИЧИН МНОГО

    Можно сделайте Выгруку/Загрузку данных для исправления. А можно и програмно
    Код:
    Процедура УдалениеСпр()
    Спр=СоздатьОбъект("Справочник.Контрагенты");
    СпД=СоздатьОбъект("Справочник.Договоры");
    сп=создатьобъект("СписокЗначений");
    
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;
    СпД.ИспользоватьВладельца(Спр.ТекущийЭлемент());
    СпД.ВыбратьЭлементы();
    Пока СпД.ПолучитьЭлемент()=1 Цикл
    сп.ИзСтрокиСРазделителями(ЗначениеВСтрокуВнутр(СпД.ТекущийЭлемент()));
    Если Число(Сп.ПолучитьЗначение(4))=0 Тогда 
    Сообщить("Ошибка в договорах контрагента "+Спр);
    СпД.Удалить();    
    КонецЕсли;    
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
    
    
    
Похожие темы
  1. zayaroslava
    Ответов:
    2
    Просмотров:
    1.066
Загрузка...

Поделиться этой страницей