7.7 Баг (?) из СКДРC (на примере рег.очета "Баланс стандарт №2" Бух. Украина)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Mister-X, 25 апр 2013.

  1. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Формируется этот отчет за 1 кв. 2013 (пробовал на разных релизах рег.отчетности - 2012 №1, 2013 №3,4).
    Строка:
    , колонка -
    .
    При расшифровке этой колонки остатки по 63 счету. Имеем строку:
    Далее ее расшифровка - ОСВ по счету 63; в расшифровке отчета СКДРC (дебетовое развернутое сальдо по субсчетам по субконто на конец периода) - 794.82 (и СККРС проверял этот показатель в отладчике) не отвечает данным из ОСВ по счету.
    Вот данные ОСВ по счету:

    Итого развернутое 1,547.64 29,459.63 6,119.82 21,470.82
    Итого 27,911.99 202,907.37 190,346.38 15,351.00

    Данные из отчета: начальные развернутое сальда и свернутое такие же как и в ОСВ, обороты такие же, конечное свернутое сальдо такое же, а вот развернутые конечные - разные.

    Что сделано:
    1. Выгрузка, загрузка.
    2. Тестирование, исправление базы.
    2. Полный пересчет итогов.
    3. 1SBKTTL і 1SBKTTLС удалял и потом еще раз полный пересчет итогов.

    Ничего не дало - вот за 2012 р. (разные релизы рег.отчетности) все нормально.

    Что за нах?


    в отладчике

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Размер файла проводок какой?
  3. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    1SBKTTL.DBF - 15.2 МВ
    1SBKTTLC.DBF - 209 КБ
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Странно... Номер релиза платформы надеюсь 25-27? А то встречал я у вас на самостийной и 21-23....
  5. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    на 27 релизе в себя на ПК пробовал
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    странно..... м.б. фильтр? Покажите код.
  7. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Код:
    ...
    Итоги = СоздатьОбъект("БухгалтерскиеИтоги");
    Если Форма.ВыбраннаяФирма.Видимость()=1 Тогда
    Итоги.ИспользоватьРазделительУчета( ВыбраннаяФирма );
    КонецЕсли;
    Дата2=КонКвартала(ДатаВКвартале);
    Период = Строка (Формат(Дата2,"ДДДММММГГГГ"));
    
    Если Открывать = 0 Тогда
    СНачалаГода = Форма.Параметр.Получить("СНачалаГода");
    ЗаМесяц = Форма.Параметр.Получить("ЗаМесяц");
    ДатаВКвартале = Форма.Параметр.Получить("Дата");
    Если СНачалаГода = 1 Тогда
    Итоги.ПериодКВН(ДатаВКвартале);
    ИначеЕсли ЗаМесяц = 1 Тогда // за месяц
    Итоги.ПериодМ(ДатаВКвартале);
    Иначе
    Итоги.ПериодКВ(ДатаВКвартале);
    КонецЕсли;
    Иначе
    Итоги.ПериодКВН(ДатаВКвартале);
    КонецЕсли;
    ...
    
    // Інша поточна дебіторська заборгованість (на кінець звітного періоду)  
    
    П2104 = Итоги.СКДРС("37.2") + Итоги.СКД("37.4") + Итоги.СКД("37.5") + Итоги.СКД("37.6") +
    Итоги.СКДРС("37.7.1") + Итоги.СКДРС("37.7.2") + Итоги.СКДРС("37.7.3") +
    Итоги.СКДРС("37.7.4") + Итоги.СКДРС("37.7.5") + Итоги.СКД("37.7.6") +  
    Итоги.СКДРС("65.1") + Итоги.СКДРС("65.2") + Итоги.СКДРС("65.3") +
    Итоги.СКДРС("65.4") + Итоги.СКД("65.5") + Итоги.СКД("65.6") + Итоги.СКДРС("63") +
    Итоги.СКДРС("68.4") + Итоги.СКДРС("68.5");
    ДобавитьСтрокуРасшифровки( "П2104", "Показник ""Інша поточна дебіторська заборгованість"", графа ""На кінець звітного періоду""", "+", "!СКДРС",Итоги.СКДРС("37.2"), "37.2",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКД("37.4"), "37.4",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКД("37.5"), "37.5",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКД("37.6"), "37.6",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("37.7.1"), "37.7.1",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("37.7.2"), "37.7.2",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКДРС("37.7.3"), "37.7.3",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКДРС("37.7.4"), "37.7.4",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКДРС("37.7.5"), "37.7.5",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКД("37.7.6"), "37.7.6",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("65.1"), "65.1",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("65.2"), "65.2",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("65.3"), "65.3",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("65.4"), "65.4",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКД("65.5"), "65.5",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКД",Итоги.СКД("65.6"), "65.6",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("63"), "63",,ВидыСубконто.Контрагенты,"Пусто",,ВидыСубконтоЗаказы,"Пусто",3,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("68.4"), "68.4",,,,,,,,,,,1);
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("68.5"), "68.5",,,,,,,,,,,1);
    Попытка
    Счет = СчетПоКоду("389");
    П2104 = П2104 - Итоги.СКК("389");
    ДобавитьСтрокуРасшифровки( "П2104", "", "-", "!СКК",Итоги.СКК("389"), "389",,,,,,,,,,,1);
    Исключение
    Счет = "";
    КонецПопытки;
    Попытка					
    Счет = СчетПоКоду("378");
    П2104 = П2104 + Итоги.СКДРС("378");  
    ДобавитьСтрокуРасшифровки( "П2104", "", "+", "!СКДРС",Итоги.СКДРС("37.8"), "37.8",,,,,,,,,,,1);
    Исключение
    Счет = "";
    КонецПопытки;
    ...
    

    Код:
    //===========================================
    // Примечание:
    //  Проверка на ненулевую сумму не выполняется, так как выдача расшифровки
    // с пустыми суммами показывает, как должен получаться выбранный показатель.
    Процедура ДобавитьСтрокуРасшифровки( ИмяЯчейки, ИмяПоказателя, ЗнакОперации, ИмяСлагаемого, Сумма, КодСчета, КодКорСчета, ВидСубконто1, Субконто1, ОтборСубконто1, ВидСубконто2, Субконто2, ОтборСубконто2, ВидСубконто3, Субконто3, ОтборСубконто3, Период, Примечание = "")
    СпП.НоваяСтрока();
    СпП.НомСтроки	 = СпП.НомерСтроки;
    СпП.ИмяЯчейки	 = ИмяЯчейки;
    СпП.ИмяПоказателя = ИмяПоказателя;
    СпП.ЗнакОперации  = ЗнакОперации;
    СпП.ИмяСлагаемого = ИмяСлагаемого;
    СпП.Сумма		 = Сумма;
    СпП.КодСчета	  = КодСчета;
    СпП.КодКорСчета   = КодКорСчета;
    СпП.ВидСубконто1  = ВидСубконто1;
    СпП.Субконто1	 = Субконто1;
    СпП.ОтборСубконто1= ОтборСубконто1;
    СпП.ВидСубконто2  = ВидСубконто2;
    СпП.Субконто2	 = Субконто2;
    СпП.ОтборСубконто2= ОтборСубконто2;
    СпП.ВидСубконто3  = ВидСубконто3;
    СпП.Субконто3	 = Субконто3;
    СпП.ОтборСубконто3= ОтборСубконто3;
    СпП.Период		= Период; // 0 - за отчетный квартал, 1 - наростающей суммой с начала года
    СпП.Примечание	= Примечание;
    КонецПроцедуры
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ну а где у вас
    Код:
    Итоги.Рассчитать(.....)
    или мне не по глазам?
  9. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    отчет формируется за 1 кв.2013, в управлении бух.итогами итоги рассчитаны по 1 кв.2013
    Ведь Итоги.Рассчитать(.....) - рассчитывает временные итоги, не?
    ЗЫ. рег.отчет не мой - Киев (АБИ) их пишет

    итоги в файлах итогов ведь хранятся по месяцам, не?
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Все равно Рассчитать нужно... Поэтому-то у вас и итоги не те
  11. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    а че по кварталам 2012 года все ок - ничего не надо рассчитывать?
  12. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Код:
    Итоги.рассчитать();
    Итоги.Актуальность(1);
    вообще ничего не выводит в отчет, период итогов указан
    Код:
    Итоги.ПериодКВН(ДатаВКвартале);
    еще нужно все счета перечислять что-ли?
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    А вы синтаксическом помощнике смотрели параметры метода рассчитать?
  14. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    счета указывать не обязательно

    добавил
    без расчета итогов - итоги те же

    мне кажется, не в этом соль, - так как за 2012 год этот же отчет дает итоги, которые совпадают из ОСВ по 63 счету
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    да не должна она работать без рассчета
  16. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    проблема не в том что мы думали, а вот в чем - описано здесь http://www.forum.mis...c.php?id=662618
    ЗЫ. это не реклама другого форума :)
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    в принципе об этом я и говорил........
  18. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    не думаю, что в этом проблема - так как развернутое сальдо на начало 1 кв. 2013 совпадает из ОСВ, расшифровка из отчета по 63 счету за все кварталы 2012 года совпадает из ОСВ

Поделиться этой страницей