8.х Авторизация в мобильной платформе

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем vitaliy1911, 8 мар 2015.

  1. TopicStarter Overlay
    vitaliy1911
    Offline

    vitaliy1911

    Регистрация:
    10 сен 2012
    Сообщения:
    37
    Симпатии:
    0
    Баллы:
    1
    каким образом в мобильной платформе реализован механизм авторизации? почему можно создать не более одного пользователя? при попытке создать второго выводится сообщение "нельзя создать второго пользователя". почему у объекта "ПользовательИнформационнойБазы" недоступно поле "Пароль"? для чего тогда в настройках ИБ можно указать пароль? подскажите, люди добрые, или покажите где почитать. в книжке Хрусталевой про мобильную платформу об этом ни слова
  2. saha25
    Offline

    saha25 Опытный в 1С

    Регистрация:
    30 окт 2007
    Сообщения:
    95
    Симпатии:
    3
    Баллы:
    29
    В мобильной платформе, насколько я знаю, может быть только один пользователь.
  3. Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.025
    Симпатии:
    51
    Баллы:
    54
    А где вы нашли эту авторизацию? Можете скрин прислать, где у вас сообщение "нельзя создать второго пользователя"?
  4. TopicStarter Overlay
    vitaliy1911
    Offline

    vitaliy1911

    Регистрация:
    10 сен 2012
    Сообщения:
    37
    Симпатии:
    0
    Баллы:
    1
    вот этот код
    Код:
    &НаКлиенте
    Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
        ИмяПользователя = "";
        Пароль = "";
        Если ВвестиСтроку(ИмяПользователя) И ВвестиСтроку(Пароль) Тогда
            СоздатьПользователя(ИмяПользователя, Пароль);
        КонецЕсли;
    КонецПроцедуры
    
    &НаСервере
    Процедура СоздатьПользователя(ИмяПользователя, Пароль)
        Пользователь = ПользователиИнформационнойБазы.СоздатьПользователя();
        Пользователь.Имя = ИмяПользователя;
        Пользователь.Пароль = Пароль;
        Пользователь.Записать();
    КонецПроцедуры
    такая ошибка
    [​IMG]

    вот этот код
    Код:
    &НаКлиенте
    Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
        ИмяПользователя = "";
        Пароль = "";
        Если ВвестиСтроку(ИмяПользователя) И ВвестиСтроку(Пароль) Тогда
            СоздатьПользователя(ИмяПользователя, Пароль);
        КонецЕсли;
    КонецПроцедуры
    
    &НаСервере
    Процедура СоздатьПользователя(ИмяПользователя, Пароль)
        Пользователь = ПользователиИнформационнойБазы.СоздатьПользователя();
        Пользователь.Имя = ИмяПользователя;
        //Пользователь.Пароль = Пароль;
        Пользователь.Записать();
    КонецПроцедуры
    после второго запуска с другим именем вот такая ошибка
    [​IMG]

Поделиться этой страницей