8.х Автонумерация по условию для двух разных префиксов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем wary, 30 дек 2009.

  1. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Нужно событие для первого переключателя только писать, для второго удалите процедуру.
    Код:
    Процедура Переключатель1ПриИзменении(Элемент)
    Если Переключатель1 Тогда
    УстановитьНовыйНомер("V");
    Иначе
    УстановитьНовыйНомер("P");
    КонецЕсли;
    КонецПроцедуры
    
  2. TopicStarter Overlay
    wary
    Offline

    wary Опытный в 1С

    Регистрация:
    5 авг 2009
    Сообщения:
    139
    Симпатии:
    1
    Баллы:
    26
    Теперь заработало! Скажите а как правильно написать код, чтобы он проверял условие после нажатия на кнопки ЗАПИСАТЬ. Я добавил эти строки в главный модуль формы

    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    Если Переключатель1 Тогда
    УстановитьНовыйНомер("V");
    Иначе
    УстановитьНовыйНомер("P");
    КонецЕсли;
    
    
    Для Каждого СтрокаТЧ Из Продукция Цикл
    Если СтрокаТЧ.ВидВоспроизводства <> Перечисления.ВидыВоспроизводстваНоменклатуры.Производство Тогда
    СтрокаТЧ.ВидВоспроизводства = Перечисления.ВидыВоспроизводстваНоменклатуры.Производство;
    КонецЕсли;
    КонецЦикла;
    
    // Проверка заполнения единицы измерения мест и количества мест
    ОбработкаТабличныхЧастей.ПриЗаписиПроверитьЕдиницуИзмеренияМест(Продукция);
    ОбработкаТабличныхЧастей.ПриЗаписиПроверитьЕдиницуИзмеренияМест(Материалы);
    
    мУдалятьДвижения = НЕ ЭтоНовый();
    
    КонецПроцедуры // ПередЗаписью()
    
    
    Вываливает ошибку

    Код:
    {Документ.ЗаказНаПроизводство(1149,7)}: Переменная не определена (Переключатель1)
    Если <<?>>Переключатель1 Тогда
    
    
    Как мне определить эту переменную, как правильно написать??

    Заранее спасибо!
  3. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Что значит в "Главном модуле формы"?
    Есть модуль формы, а есть модуль объекта. Во втором не видны реквизиты, добавленные в форму. Если дописали туда, то переносите код в модуль формы.

Поделиться этой страницей