8.х Автоматом сделать основной адрес

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Romik, 24 апр 2009.

  1. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Подскажите..как проставить основным факт адрес контрагента автоматически?....
  2. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Код:
    Рег = РегистрыСведений.КонтактнаяИнформация;
    Рег.СоздатьМенеджерЗаписи();
    
    Запрос 			= Новый Запрос;
    Запрос.Текст 	=
    "ВЫБРАТЬ
    |	КонтактнаяИнформация.Объект КАК Объект,
    |	КонтактнаяИнформация.Вид КАК Вид,
    |	КонтактнаяИнформация.Представление КАК Представление,
    |	КонтактнаяИнформация.ЗначениеПоУмолчанию КАК ЗначениеПоУмолчанию
    |ИЗ
    |	РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |ГДЕ
    |	КонтактнаяИнформация.ЗначениеПоУмолчанию = ИСТИНА
    |	И КонтактнаяИнформация.Вид >= 1";     
    РезультатЗапроса  = Запрос.Выполнить();
    ТЗ = РезультатЗапроса.Выгрузить();
    ТЗ.ВыбратьСтроку();
    ОбходРег= РезультатЗапроса.Выбрать();
    
    Конт = Справочники.Контрагенты.Выбрать();
    Рег = РегистрыСведений.КонтактнаяИнформация.СоздатьМенеджерЗаписи();
    
    Пока Конт.Следующий() Цикл
    
    Рег.Объект = Конт.Ссылка;
    
    Если Не ЗначениеЗаполнено(Рег.Объект) Тогда 
    Предупреждение("Не заполнено значение");							
    КонецЕсли;
    
    Рег.Записать(Истина);
    
    Не получается объект и не даёт записать?
    Суть в том что надо у тех контрагентов которые отобрались в запросе..сделать Основными...и записать)
  3. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Ну вот тебе пример для одного контрагента. Сам в цикл загонишь.

    Код:
    	
    // Выборка контактной информации по контрагенту
    КонтактнаяИнформация = РегистрыСведений.КонтактнаяИнформация.Выбрать(Новый Структура("Объект",Контрагент));
    // Просматриваем выборку
    Пока КонтактнаяИнформация.Следующий() Цикл
    
    // Получаем ЗАПИСЬ регистра
    Запись = КонтактнаяИнформация.ПолучитьМенеджерЗаписи();
    
    // пробрасываем не адреса
    Если Запись.Тип <> Перечисления.ТипыКонтактнойИнформации.Адрес Тогда
    Продолжить;
    КонецЕсли; 
    
    // фактический адрес - основной		
    Если Запись.Вид = Справочники.ВидыКонтактнойИнформации.ФактАдресКонтрагента Тогда
    Запись.ЗначениеПоУмолчанию = Истина;
    
    // остальные - нет
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе	</span>
    Запись.ЗначениеПоУмолчанию = Ложь;
    КонецЕсли; 
    
    // не забываем записать		
    Запись.Записать();
    
    КонецЦикла;  
    
    
  4. ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    Хотела свою создать. Нашла поиском это.
    Спрошу здесь.
    Задача такая же, автоматом простаивть один из адресов ФизЛицам основным.
    НО, хотела сначала посмотреть регистр, не удалось. Хотела его в консоли отчетов посмотреть.
    Что я сделала не так? и да, у меня ЗУП
    Код:
    ВЫБРАТЬ
        ВЫРАЗИТЬ(КонтактнаяИнформация.Объект КАК Справочник.ФизическиеЛица) КАК Объект,
        КонтактнаяИнформация.Тип,
        ВЫРАЗИТЬ(КонтактнаяИнформация.Вид КАК Справочник.ВидыКонтактнойИнформации) КАК Вид,
        КонтактнаяИнформация.Представление,
        КонтактнаяИнформация.Поле1,
        КонтактнаяИнформация.Поле2,
        КонтактнаяИнформация.Поле3,
        КонтактнаяИнформация.Поле4,
        КонтактнаяИнформация.Поле5,
        КонтактнаяИнформация.Поле6,
        КонтактнаяИнформация.Поле7,
        КонтактнаяИнформация.Поле8,
        КонтактнаяИнформация.Поле9,
        КонтактнаяИнформация.Поле10,
        КонтактнаяИнформация.Комментарий,
        КонтактнаяИнформация.ЗначениеПоУмолчанию,
        КонтактнаяИнформация.ТипДома,
        КонтактнаяИнформация.ТипКорпуса,
        КонтактнаяИнформация.ТипКвартиры
    ИЗ
        РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    

Поделиться этой страницей