8.х Автоматическое заполнение табличной части документа выборкой из справочника по владельцу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем JediAlex, 11 фев 2015.

  1. TopicStarter Overlay
    JediAlex
    Offline

    JediAlex Опытный в 1С

    Регистрация:
    27 авг 2011
    Сообщения:
    140
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и подчиненный ему справочник "КритерииОценки", где создал реквизит НаименованиеКритерия -стандартное наименование по длине не устраивало. Для второго справочника изменил представление в менеджере:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    Код:
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
      
        СтандартнаяОбработка = Ложь;
        Представление = Данные.НаименованиеКритерия;
      
    КонецПроцедуры
    Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
      
        СтандартнаяОбработка = Ложь;
        Поля.Добавить("НаименованиеКритерия");
    КонецПроцедуры 
    Справочники заполнил. Далее нужен документ, которым сотрудники и их руководители записывают оценки своей работы. Сделал я такой документ с реквизитами: Сотрудник - СправочникСсылкаСотрудники, Подразделение - СправочникСсылкаПодразделения, Должность -СправочникСсылкаДолжности. Сдела табличную часть документа с реквизитами: Критерий - СправочникСсылкаКритерииОценки,ВесовойКоэффициент - число,ОценкаСотрудника - число; ОценкаРуководителя- число.
    Появилась такая задача: заполнить табличную часть критериями оценки автоматически при выборе сотрудника в форме документа. Я сделал такой код:
    Код:
    &НаСервере
    Функция ВыгрузкаКритериев()
    ВыгрузкаКритериев = Справочники.КритерииОценки.Выбрать( ,Объект.Сотрудник);
    Возврат ВыгрузкаКритериев;
    КонецФункции  
    &НаКлиенте
    Процедура СотрудникПриИзменении(Элемент)
        //Выборка = Справочники.КритерииОценки.Выбрать( ,Объект.Сотрудник);
    Результат=ВыгрузкаКритериев();
        Пока Результат.Следующий() Цикл
            Элементы.КритерииОценки.ДобавитьСтроку();     
            НоваяСтрока=Элементы.КритерииОценки.ТекущиеДанные; 
            //НоваяСтрока.КритерийОценкиКритерий=Результат.Ссылка;
            НоваяСтрока.КритерийОценкиНольБаллов=Результат.НольБаллов;
            НоваяСтрока.Записать();
        КонецЦикла;
    КонецПроцедуры 
    при изменении реквизита Сотрудник в документе вылетает ошибка:
    Ошибка отображения типов: отсутствует отображение для типа Справочниквыборка.КритерииОценки
    Отображение справочника КритерииОценки я описывал в менеджере этого справочника:
    Код:
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
      
        СтандартнаяОбработка = Ложь;
        Представление = Данные.НаименованиеКритерия;
      
    КонецПроцедуры
    Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
      
        СтандартнаяОбработка = Ложь;
        Поля.Добавить("НаименованиеКритерия");
      
    КонецПроцедуры 
    Что тут не так? помогите пожалуйста

    оформляйте код тегами

Поделиться этой страницей