8.х Автоматическое формирование отчета в указанное время

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Hel, 15 авг 2007.

  1. TopicStarter Overlay
    Hel
    Offline

    Hel

    Регистрация:
    15 авг 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Подскажите пожалуйста, как в определенное время сформировать необходимый отчет?
    Пробую в глобальный модуль в конец процедуры ПриНачалеРаботыСистемы() добавить:

    Если ИмяПользователя() = "xxx" Тогда
    ОткрытьФорму("Отчет", , "C:\xxxxx.ert");
    ЗавершитьРаботуСистемы(0);
    КонецЕсли


    Строка ОткрытьФорму...... не отрабатывает. В чем ошибка?
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Посмотри в Синтаксис-помошнике "МенеджерВнешнихОбработок ". :)
  3. coder1cv8
    Offline

    coder1cv8 Опытный в 1С

    Регистрация:
    30 авг 2007
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Ну если упрощенно, то можно так:

    Процедура ПриНачалеРаботыСистемы()
    Если РольДоступна("Автозапуск") Тогда
    Отчеты.МойОтчет.ПолучитьФорму().Открыть();
    КонецЕсли;
    КонецПроцедуры

    А вообще, вот здесь http://www.coder1cv8.narod.ru/Publication1.html я привожу пример универсального механизма для автозапуска обработок.
Похожие темы
  1. Vagner
    Ответов:
    0
    Просмотров:
    1.548
  2. almat
    Ответов:
    0
    Просмотров:
    1.480
  3. Arnage
    Ответов:
    3
    Просмотров:
    3.148
  4. Asintelekt
    Ответов:
    7
    Просмотров:
    1.701
  5. Сандра
    Ответов:
    5
    Просмотров:
    745
Загрузка...

Поделиться этой страницей