7.7 Автоматическое формирование файла для обмена с сайтом

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Сандра, 14 ноя 2012.

  1. TopicStarter Overlay
    Сандра
    Offline

    Сандра Опытный в 1С

    Регистрация:
    5 июл 2010
    Сообщения:
    76
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!
    Программа Торговля и склад 7,7.
    Поставлена задача: для автоматического обновления данных на сайте необходимо каждый час выгружать данные в файл, который затем автоматически загрузится на сайт.
    Нашла специальную процедуру в описании языка - ОбработкаОжидания.
    Но не пойму как она работает и в конфигурации она не используется.
    Подскажите, как используется данная процедура / маленький пример/ или я иду не тем путем и есть что-нибудь другое?
    Заранее спасибо.
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    У данного метода есть 2 применения: документированное и недокументированное.
    1. Используется согласно документации

    Пример:
    Код:
    Процедура СформироватьТекущийОтчетПродаж
    КонецПроцедуры;
    ОбработкаОжидания("СформироватьТекущийОтчетПродаж", 60);
    2. Недокументированное использование - у любой формы имеется такой метод, который работает "локально", не затрагивая работу основного метода. То есть открываем любую форму, вызываем метод формы "Форма.ОбработкаОжидания(...)".
  3. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    ОбработкаОжидания - будет выполнятся под всеми пользователями, по мне так лучше через внешний планировщик запускать 1С под юзером "ВыгрузкаСайт"
    и в
    Код:
    Процедура ПриНачалеРаботыСистемы()
    //.......................
    Если ПолноеИмяПользователя()="ВыгрузкаСайт" Тогда
    //	Запустить выгрузку
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    //.......................
    КонецПроцедуры
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Ну обработку ожидания тоже можно выполнять не для всех пользователей, а использовать условие, аналогичное условию выше.

    А вот каждый раз стартовать 1С ради одной выгрузки.... тут необходимо обосновать используемый вариант. Например, если выгрузка нужна каждые 5 минут (а бывает и чаще), то каждый раз стартовать 1С очень не оптимально.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    если работаем терминалоно - оптимальный вариант отдельная сессия с консоли.
  6. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    все равно лучше использовать отдельную сессию (у меня запуск 1С укладывается в 10 сек), если нужно с частотой нескольких минут то тогда пусть будет ОбработкаОжидания(), но запустить ее только для одного нужного пользователя! :sm_wink:

Поделиться этой страницей