7.7 Автоматический запуск обработки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем zamik15rus, 14 май 2013.

  1. TopicStarter Overlay
    zamik15rus
    Offline

    zamik15rus

    Регистрация:
    14 май 2013
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток, уважаемые форумчане.
    Только недавно начал писать на 1С так что вопросы у меня ламерские.
    Так вот есть задача, в час ночи автоматически запустить внешний отчет на 1С 7.7. Отчет должна запуститься и после того как она отработает закрыть не только себя но и саму 1С.
    Как решал:
    1. создал пользователя и написал батник который с этим пользователем запускает 1С
    2. В глобальном модуле написал код:

    Если ИмяПользователя() = "RobAdmin" Тогда
    ОткрытьФорму("Отчет", "RobAdmin", КаталогИБ() + "ExtForms\Отчетность.ert");
    КонецЕсли;
    который запускает форму отчета.
    3. В самом отчете написал процедуру:

    Процедура ПриОткрытии()
    Если ИмяПользователя() = "RobAdmin" Тогда
    Сообщить("При открытии");
    ВыбКлиенты.ДобавитьЗначение("ТП");
    ВыбТовары.ДобавитьЗначение("""ООО Бла бла бла""");
    ВыбПоставщики.ДобавитьЗначение("ООО ""Бла бла бла""");
    Конецесли;
    КонецПроцедуры
    Так вот не получается после того как открывается форма автоматически нажать кнопку Сформировать.
  2. Vlan
    Offline

    Vlan Гость Гость

    Смотрите процедуру, которую запускает кнопка Сформировать. Чаще всего это Сформировать(). Ее и запускайте перед концом процедуры.
  3. TopicStarter Overlay
    zamik15rus
    Offline

    zamik15rus

    Регистрация:
    14 май 2013
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Vlan пытался так делать, но не получается выдает ошибку, Процедура не обнаружена (Сформировать)
    Не пропускает даже синтаксический контроль.
  4. Vlan
    Offline

    Vlan Гость Гость

    В свойствах самой кнопки какая процедура установлена?
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Чего гадать-то... Выложите файл Отчетность.Ert
  6. TopicStarter Overlay
    zamik15rus
    Offline

    zamik15rus

    Регистрация:
    14 май 2013
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    В свойствах самой кнопки так и стоит Сформировать()

    приведу пример кода с процедурой

    //******************************************************************************
    Процедура ПриОткрытии()
    Если ИмяПользователя() = "RobAdmin" Тогда
    Сообщить("При открытии");
    ВыбКлиенты.ДобавитьЗначение("ТП");
    ВыбТовары.ДобавитьЗначение("""ООО Бла бла бла""");
    ВыбПоставщики.ДобавитьЗначение("ООО ""Бла бла бла""");
    Сформировать();
    Конецесли;
    КонецПроцедуры


    //******************************************************************************

    Процедура Сформировать()
    и тут дальше обработка которая нам и нужна.

    прикрепил отчет посмотрите код?

    Вложения:

  7. Vlan
    Offline

    Vlan Гость Гость

    Процедура Сформировать должна быть перед ее запуском!

    PS Поменяйте местами ПриОткрытии и Сформировать
  8. TopicStarter Overlay
    zamik15rus
    Offline

    zamik15rus

    Регистрация:
    14 май 2013
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Понятненько невозможно обратиться к процедуре если она не инициализированна раньше. Спасибо, как я сам не догадался. Буду копать дальше.
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В принципе можно.. Если ее объявить перед вызовом... Смотри в документации метод "далее"

Поделиться этой страницей