7.7 Автоматический запуск 1С 7.7 (регламентное задание)

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем egorkin, 31 окт 2012.

  1. TopicStarter Overlay
    egorkin
    Offline

    egorkin Опытный в 1С

    Регистрация:
    28 мар 2011
    Сообщения:
    109
    Симпатии:
    0
    Баллы:
    26
    Доброго дня, жители форума. В фирме установлена 1С:Предприятие 7.7 (сетевая 7.70.025) информационная база Е-Фарма. И есть у ней одна хитрость, каждое 1-ое число месяца на ней надо переводить остатки!!! Это заключается в следущем:
    1. Первого числа месяца монопольно открываешь базу
    2. Спрашивает "перевести остатки на 1 число" соответственно нажимаю "Да"
    3. Правда чаще всего при открытии базы монопольно требует сделать переиндексацию данных, которая примерно занимает 10-20 минут (база не маленькая).
    Все эти манипуляции нужно проводить до открытии касс (рано утром), либо я удаленно это делал.
    Вопрос к Вам таков: Каким образом можно автоматизировать этот процесс? Может регламентное задание?
    Заранее благодарен ответам.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Правильно мыслите... Регламентое задание с запуском батника. Только вот еще вопрос из конфигурации нужно убрать.
  3. TopicStarter Overlay
    egorkin
    Offline

    egorkin Опытный в 1С

    Регистрация:
    28 мар 2011
    Сообщения:
    109
    Симпатии:
    0
    Баллы:
    26
    Допустим батник на запуск 1С будет написан. Но как будет происходить процедура "нажатия на кнопку" при выводе сообщения о переиндексации данных?
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    А почему требует переиндексации? Аварийный выход был?
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    при необходимости - через командную строку
  6. TopicStarter Overlay
    egorkin
    Offline

    egorkin Опытный в 1С

    Регистрация:
    28 мар 2011
    Сообщения:
    109
    Симпатии:
    0
    Баллы:
    26
    Да, такое редко, но увы случается.

    Примерчик можно?
    Запуск ркализую батником
    "C:\Program Files\1Cv77.ADM\BIN\1cv7.exe" enterprise /D"C:\1cBazaALL\Paracels" /Администратор//
    правда в базу все равно не входит, выводит окно выбора пользователя...
  7. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    avto.cmd
    в 1с
    Код:
     //Автоматическое открытие периода
    ДатаТА=ПолучитьДатуТА();
    Если (РабочаяДата()>ДатаТА)И
    ((ДатаМесяц(ДатаТА)<>ДатаМесяц(РабочаяДата()))ИЛИ(ДатаГод(ДатаТА)<>ДатаГод(РабочаяДата()))) Тогда
    Если МонопольныйРежим()=0 Тогда
    Ответ=Вопрос("Не открыт период!"+РазделительСтрок+
    "Для открытия периода запустите программу в монопольном режиме!"+РазделительСтрок+
    "Завершить работу программы?","Да+Нет",60);
    Если (Ответ="Да") или (Ответ="Таймаут") Тогда
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    Иначе // монопольный режим
    Ответ=Вопрос("Не открыт новый период!"+РазделительСтрок+"Выполнить открытие периода? "
    +РазделительСтрок+"(Автооткрытие через 30 сек)","Да+Нет",30);
    Если (Ответ="Да") или (Ответ="Таймаут") Тогда
    УстановитьТАНа(РабочаяДата());
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    
  8. TopicStarter Overlay
    egorkin
    Offline

    egorkin Опытный в 1С

    Регистрация:
    28 мар 2011
    Сообщения:
    109
    Симпатии:
    0
    Баллы:
    26
    Не сработало у меня... файл создал и все записал... запускаю маргнет и все... и кстати что за файл 1Cv7.LCK? не нашел такого.
    создавать обработчик и запускать? Правильно я понял?
  9. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    для того чтобы работал батник нужен файл для пакетного задания (в моем примере Repair.pfc в каталоге базы)
    примерно такого содержания
    1Cv7.LCK и 1SUSERS.DBF - это файлы содержат инфу кто счаз подключен к этой базе, создаются когда кто-то к ней подключен
    они заблокированы пока с базой работают
    если их удалить то переиндексацию спрашивать не будет :)

    кусок кода 1с уменя в глобальном модуле в процедуре ПриНачалеРаботыСистемы() то есть он выполняется при каждом запуске 1с
    при входе в монопольном режиме автоматически открывается период (30 сек даны на отмену и продолжить работу как есть)

Поделиться этой страницей