7.7 Автоматически перенос точки актуальности при первом документе каждый день

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем lexi2, 6 сен 2009.

  1. TopicStarter Overlay
    lexi2
    Offline

    lexi2

    Регистрация:
    27 сен 2008
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Как реализовать эту схема?
    Проблема в том, что при заходе в 1С с утра у продавцов создавших первый документ за текущий день - возникает табличка - перенести ТА на следующий день и частенько они этого не делают (боятся и нажимают - НЕТ) и в итоге все последующие документы идут уже вчерашним числом со всеми вытекающими.
    Как сделать, так что бы точка актуальности сразу автоматом переносилась каждый день на новую дату?
    1C 7.7 Торговля и Склад
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Если ТекущаяДата()>ПолучитьДатуТА() Тогда
    Предупреждение("Необходимо перенести точку актуальности!");
    Если МонопольныйРежим()=1 Тогда
    УстановитьТАна(КонМесяца(ТекущаяДата()));
    Иначе
    Предупреждение("Перезапустите программу в монопольном режиме!");
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;	   	
    КонецЕсли;
    
    
    в таком варианте ТА придется переносить только раз в месяц
  3. TopicStarter Overlay
    lexi2
    Offline

    lexi2

    Регистрация:
    27 сен 2008
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    а в настройках этого нет?
    нужно обязательно конфигурацию менять?

    где именно в конфигурации изменить (заменить) нужно?

    и на что это может повлиять в худшую сторону (если внести этот код)?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В худшую сторону никак не повлияет. Вставлять в глобальном модуле в процедуру ПриНачалеРаботыСистемы
  5. TopicStarter Overlay
    lexi2
    Offline

    lexi2

    Регистрация:
    27 сен 2008
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    ясно - попробую - спасибо!
  6. TopicStarter Overlay
    lexi2
    Offline

    lexi2

    Регистрация:
    27 сен 2008
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Хотел уточнить:
    как я понял из кода - нужно обязательно хотя бы одному пользователю запускать в монопольном режиме 1С чтобы сработал автоматический перенос ТА или не обязательно?

    код я никакой не заменяю на этот - просто вставляю его в конце перед:
    КонецПроцедуры //ПриНачалеРаботыСистемы()

    верно?
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Верно. А монопольный режим нужен потоу, что метод

    Код:
    УстановитьТАна()
    
    
    работет только монопольно
  8. TopicStarter Overlay
    lexi2
    Offline

    lexi2

    Регистрация:
    27 сен 2008
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    а как же тогда быть елси у продавцов нет монопольного доступа?
    я имею в виду что нужно каждый раз при создании нового документа (первого документа за день) чтобы не возникала табличка - перенести ТА на новый день а сразу же уже переносилась.
    как это сделать?

    про 1-н раз в месяц переносить ТА в монопольном режиме - с этим понятно и вопросов не вызывает - это можно и в ручную заранее сделать.


  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Очень просто - заведи пользователя без пароля и назови его "Могопольный". При этом отбери у него все права на метаданные (справочники, документы....) оставь только монопольный режим.
  10. TopicStarter Overlay
    lexi2
    Offline

    lexi2

    Регистрация:
    27 сен 2008
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Так еще 5-ть лет назад и было сделано - все так и пользуются - так что эта проблема решена еще давно.
    Видимо ты меня не понял - проблема не в этом!!!

    Еще раз:
    проблема при создании первого любого документа при начале работы с 1С каждый день при его проведении.
    Тоесть поработали в 1С сегодня - все вышли и выключили компьютеры.
    Пришли на следующий день - запустили 1С и создали и захотели провести этот первй документ за день - то возникакт окно (картинку прилагаю)
    Посмотреть вложение 2641

    и если нажать НЕТ (а именно это они частенько и делают так как пугаются) то все документы последующие идут уже вчерашним числом а не сегоднешним!!!!
    Вот в чем проблема то!!!

    Теперь понятно?


    Вложения:

    • 1c_ta.jpg
      1c_ta.jpg
      Размер файла:
      19,1 КБ
      Просмотров:
      55
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Что мешает использовать код который я описал выше - ТА придется переность раз в месяц и без участия администратора. Сами себе проблемы создаете........
  12. TopicStarter Overlay
    lexi2
    Offline

    lexi2

    Регистрация:
    27 сен 2008
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    тоесть тот код что приведен выше решит эту проблему, а раз в месяц уже монопольно отдельно будем открывать?

    просто я попытался понять сам кусочек этой программы и возник вопрос - там везде ссылается на монопольный режим и если он не открыт то и переноса не будет - поэтому и возник вопрос о том а как же будет тогда перенос ТА каждый день автоматом делаться без монопольного режима?

Поделиться этой страницей