8.х Авто-заполнение полей строк табличной части на сервере в 1С

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем GiGi, 30 мар 2017.

  1. TopicStarter Overlay
    GiGi
    Offline

    GiGi

    Регистрация:
    7 мар 2017
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Привет всем!
    В 1С конфигураторе начал недавно....
    Поэтому понятное дело, что вопрос возник не от сильно глубокого знания …
    Просто рыл по форумам .. и все равно не нашел то, что нужно. Не смотря на то, что нужно не сильно оригинальное действие.
    Дело в чем?
    Внизу код того, как данные выгрузить из сервера.
    В этом худо-бедно вроде чуть разобрался.
    Но мне нужно, что бы после выгрузки, данные опять загружались табличную часть документа но это после сложных расчетов между полями, где значения цифр.
    Это удается сделать в режиме: «Сообщить()», но никак не получается полученные расчетные данные вбить в соответствующие поля указанного столбца в табличной части.

    Хоту подчеркнуть, мне нужно не добавить новые строки, что уже знаю, как сделать, а просто заполнить имеющиеся поля, новыми цифрами, после их выгрузки из сервера в табличную часть.
    В данном случае поле для заполнения это ДокТест1.ЦыфраРасчета в табличной части.
    И взят простой пример расчета .. ну допустим Строка. ЦыфраРасчета = Строка. Цыфр1+ Строка. Цыфр2;


    &НаКлиенте
    Процедура РасходПриемМинусОтпуск(Команда)
    Тест_АвтозаполнениеПолей ();
    КонецПроцедуры

    &НаСервере
    Процедура Тест_АвтозаполнениеПолей()
    //------------------------------------------------------------
    Запрос = Новый Запрос();
    Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
    |ДокТест1.НомерСтроки,
    |ДокТест1.Объект,
    |ДокТест1.Цыфр1,
    |ДокТест1.Цыфр2,
    |ДокТест1.ЦыфраРасчета,
    |ИЗ
    |Документ.ДокТест1.ТаблЧасть1 КАК ДокТест1";
    //------------------------------------------------------------
    Список = Запрос.Выполнить().Выгрузить();
    //------------------------------------------------------------
    Для Каждого Строка из Список Цикл
    Строка. ЦыфраРасчета = Строка. Цыфр1+ Строка. Цыфр2;
    Сообщить(Строка. ЦыфраРасчета)

    //ТУТ НЕ ЗНАЮ КАК ПОЛУЧЕННОЕ ЗНАЧЕНИЕ: Строка. ЦыфраРасчета ВБИТЬ В поля реквизита: ЦыфраРасчета.


    КонецЦикла;
    //------------------------------------------------------------
    КонецПроцедуры


    Буду очень признателен за помощь!
    Последнее редактирование: 30 мар 2017
  2. ИринаМО
    Offline

    ИринаМО

    Регистрация:
    7 апр 2017
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
  3. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.828
    Симпатии:
    1.024
    Баллы:
    204
    может для начала все таки почитать книги по программированию 1с с прорешиванием примеров, не?