8.х ASP Linux 12 + PostgreSQL 8.4.1 = не получается создать базу данных

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем Dm81, 6 янв 2010.

  1. TopicStarter Overlay
    Dm81
    Offline

    Dm81

    Регистрация:
    22 окт 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Не получается создать базу данных :(

    ASPLinux 12. Ставлю систему с нуля. Ставлю postgresql 8.4.1 от 1С (взял отсюда v8.1c.ru/overview/postgr... »») из сырцов (файл postgresql-8.4.1-1.1C.src.rpm).

    Последовательность установки:
    1) после установки системы ставлю icu:
    yum install icu libicu libicu-devel
    ставится icu версии 3.6;



    2) затем postgres: копирую сырец в /usr/src, затем команда
    rpm -ivh postgresql-8.4.1-1.1C.src.rpm.
    ругается на неудовлетворенные зависимости, дополнительно ставлю
    python-devel, tcl-devel, openssl-devel, zlib-devel (еще какая=то была).



    3) запускаю сборку rpm-ов:
    cd /usr/src/asplinux/SPECS

    rpmbuild -ba postgresq-8.4.1C.spec
    пошел процесс. В итоге создается набор rpm-ок в /usr/src/asplinux/RPMS/i386
    перехожу туда, команда
    rpm -ivh *.rpm.
    Ставится постргес.
    затем
    mkdir /1c/v8/data
    chown -v -R postgres /1c/v8
    su - postgres
    /usr/bin/initdb -D /1c/v8/data
    меняю способ авторизации, размер кэша, назначаю пароль пользователю postgres, запускаю заново сервер
    /usr/bin/pg_ctl -D /1c/v8/data -l /1c/v8/logfile restart

    Сервер стартует, работает (ps axu | grep postgres).

    Ставлю сервер 8.2.10.77 (rpm -ivh *.rpm), пакеты ставлятся автоматически в нужной последовательности, все запускается.


    Из оснастки пытаюсь создать базу данных и получаю сообщения:
    1) DATABASE непригоден для использования;
    или
    2) type 'mvarchar' does not exist.

    До этого поднимал еще на платформе 8.1.12, прошел через обновления постргеса с 8.1.5 до 8.2.4 и затем до 8.3.3. Проблем не было, а тут тр..хаюсь уже 4 дня.

    постгрес 8.3.8 вылетает еще на этапе сборки (из .spec-файла) с ошибкой "Неверный код возврата из /var/tmp/rpm-tmp"
  2. TopicStarter Overlay
    Dm81
    Offline

    Dm81

    Регистрация:
    22 окт 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Короче, победил. Сделал, как написано тут
    http://omsklug.ru/wiki/index.php5?title=%D...QL_%E4%EB%FF_1C
    Взял исходные коды и сам наложил патчи, выложенные здесь:
    http://v8.1c.ru/overview/postgres_patches_notes.htm

    Версия 8.4.1 не взлетела: после загрузке базы из .dt и перезапуска конфигуратора выходит сообщение "конвертация из ознакомительной версии не поддерживается данной версией 1С:Предприятия", и конфигуратор закрывается.

    Поставил 8.3.8, работает. Платформа 8.2.10.77. Система ASP Linux 12. Все нужные библиотеки входят в состав ASP Linux 12.

Поделиться этой страницей