7.7 Артикул в этикетке

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем bojinja, 10 ноя 2012.

  1. TopicStarter Overlay
    bojinja
    Offline

    bojinja

    Регистрация:
    10 ноя 2012
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Подскажите, пожалуйста, как можно вывести функцию печати артикула в этикетке. Не путайте ценник и этикетку, нужно именно последнее. В этикетке на данный момент штрихкод, наименование товара и номер. Возможно ли прописать туда артикул? Если да, то буду признательна за пошаговое объяснение. С базой работаю недавно, поэтому могу не понять технический сленг или сокращения.

    Если уже где-то объяснялось, прошу направить по ссылке и извиняюсь за дубликат темы.
  2. SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    К вам встречный вопрос. Вы эту этикетку хотите распечатывать на термопринтере штрихкодов?
    Ну и по делу. Конфигуратор/ Справочники/Номенклатура/ Формы Списка/Для выбора
    Переходим на вкладку Модуль ищем процедуру ПечатьЭтикетки
    Здесь 2 варианта либо артикул приплюсовать к намиенованию(имеет отрициательный момент, если наименование длинное очень то артикул может не поместится)
    Либо отдельно вставим в этикетку и он всегда будет(этот вариант и рассмотрим)
    Код:
    Процедура ПечатьЭтикетки()
    Перем Парам;
    ТекЭлем = ТекущийЭлемент();
    Если ПустоеЗначение(ТекЭлем) = 1 Тогда
    Предупреждение("Не выбрана номенклатурная позиция!", 60);
    Возврат;
    КонецЕсли;
    
    Если ТекЭлем.ЭтоГруппа() = 1 Тогда
    Предупреждение("Этикетка для группы номенклатуры не печатается!", 60);
    Возврат;
    КонецЕсли;
    
    Если ТекЭлем.Весовой = 0 Тогда
    Баркод = ТекЭлем.БазоваяЕдиница.Штрихкод;
    Табл = СоздатьОбъект("ТаблицаЗначений");
    Табл.НоваяКолонка("Товар", "Строка");
    Табл.НоваяКолонка("Штрихкод", "Строка");
    //Добавили артикул
    Табл.НоваяКолонка("Артикул", "Строка");
    
    Табл.НоваяСтрока();
    Табл.Товар    = СокрЛП(ТекЭлем.Наименование);
    Табл.Штрихкод = Баркод;
    //Добавили в артикул значение
    Табл.Артикул =  СокрЛП(ТекЭлем.Артикул);
    
    
    Парам = СоздатьОбъект("СписокЗначений");
    Парам.ДобавитьЗначение(Табл, "ТаблицаТоваров");
    
    ОткрытьФормуМодально("Обработка.ПечатьЭтикетки", Парам);
    Иначе
    // в штрихкоде храниться 5 правых цифр кода товара
    // перед печатью нужно сформировать
    
    // получаем вес товара
    Парам = СоздатьОбъект("СписокЗначений");
    Парам.ДобавитьЗначение(ТекЭлем	 , "Номенклатура");
    Парам.ДобавитьЗначение(ТекЭлем.БазоваяЕдиница , "Единица");
    
    
    
    ОткрытьФорму("Обработка.Этикетирование#", Парам);
    КонецЕсли;
    
    КонецПроцедуры // ПечатьЭтикетки()
    Переходим в Обработки/Печать Этикетки/Этикетка
    Если хотим добавить в наименование тогда где написанно ТаблицаТоваров.Товар дописываем + " "+ТаблицаТоваров.Артикул
    И в общем получается так ТаблицаТоваров.Товар+ " "+ТаблицаТоваров.Артикул
    Если артикул отдельно нужно. Напишите я до объясню.

Поделиться этой страницей