8.х Анализ дня

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем solnce, 13 янв 2010.

  1. TopicStarter Overlay
    solnce
    Offline

    solnce Опытный в 1С

    Регистрация:
    16 июл 2009
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    Доброе время суток.
    У меня есть отчет в котором выводится список клиентов с наличным видом расчета( признак расчета нал/безнал указывается в справочники/контраенты/вкладка дополнительно/нал или безнал) появился один клиент который платит через день, как сделать так чтобы он выводился через день?
    Заранее благодарю!
  2. wertklop
    Offline

    wertklop Опытный в 1С

    Регистрация:
    12 май 2008
    Сообщения:
    321
    Симпатии:
    0
    Баллы:
    26
    а если в запрос отчёта поставить условие: выводить в отчёт тех контрагентов, которые заплатили в день, на который создаётся отчёт.
    (если я правильно понял вашу задачу)
  3. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.400
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    1.
    - можно сделать так чтобы по виду документа отчет определял налом или по безналу рассчитался клиент.
    2.
    Через день после чего, после реализации? Скиньте пример отчетика и опишите последнее условие, подскажем.
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    НЕ совсем задучу понял приведите пример отчета
  5. TopicStarter Overlay
    solnce
    Offline

    solnce Опытный в 1С

    Регистрация:
    16 июл 2009
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    вот собственно мой отчет,мне нужно чтобы покупатель(грузополучатель) с кодом 00003 выводился через день
    Код:
    ТабДок1 = Новый ТабличныйДокумент;
    Макет = Документы.ТТН.ПолучитьМакет("ДенежныйОтчет");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Строка=  Макет.ПолучитьОбласть("Строка");
    Итого = Макет.ПолучитьОбласть("Итого");
    Подвал = Макет.ПолучитьОбласть("Подвал");
    
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |	ТТН.Ссылка КАК Ссылка,
    |	ТТН.Грузополучатель.Код КАК КодГр,
    |	ТТН.Грузополучатель.Наименование КАК НаимГр,
    |	ТТН.Покупатель КАК НаимПок,
    |	ТТН.Покупатель.Код КАК КодПок,
    |	ТТН.Номер КАК НомерН,
    |	ТТН.Грузополучатель.ВидПлатежа КАК ВидПлатежа,
    |	ТТН.Договор,
    |	СУММА(ТТНТаблЧастьНоменклатураТТН.Всего) КАК Всего,
    |	ТТН.Грузополучатель.Предоплата КАК Предоплата,
    |	ТТН.Грузополучатель.Заметки КАК Заметки
    |ИЗ
    |	Документ.ТТН.ТаблЧастьНоменклатураТТН КАК ТТНТаблЧастьНоменклатураТТН
    |		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ТТН КАК ТТН
    |		ПО ТТНТаблЧастьНоменклатураТТН.Ссылка = ТТН.Ссылка
    |ГДЕ
    |	ТТН.Маршрут = &Маршрут
    |	И ТТН.Смена = &Смена
    |	И ТТН.Напечатан = ИСТИНА
    |	И ТТН.Грузополучатель.ВидПлатежа = &ВидПлатежа
    |
    |СГРУППИРОВАТЬ ПО
    |	ТТН.Ссылка,
    |	ТТН.Грузополучатель.Код,
    |	ТТН.Грузополучатель.Наименование,
    |	ТТН.Покупатель,
    |	ТТН.Покупатель.Код,
    |	ТТН.Номер,
    |	ТТН.Грузополучатель.ВидПлатежа,
    |	ТТН.Договор,
    |	ТТН.Грузополучатель.Предоплата
    |
    |УПОРЯДОЧИТЬ ПО
    |	НомерН";
    Запрос.УстановитьПараметр("Маршрут",ЭлементыФормы.ЖурналДокументовСписок.ТекущаяСтрока.Маршрут);
    Запрос.УстановитьПараметр("Смена",ЭлементыФормы.ЖурналДокументовСписок.ТекущаяСтрока.Смена);
    Запрос.УстановитьПараметр("Водитель",ЭлементыФормы.ЖурналДокументовСписок.ТекущаяСтрока.Водитель);
    Запрос.УстановитьПараметр("ВидПлатежа",Перечисления.ВидПлатежа.Нал);
    
    ТЗ=Запрос.Выполнить().Выгрузить();
    Шапка.Параметры.Дата=Дата(Формат(ТекущаяДата()));
    Шапка.Параметры.ДН=Дата(Формат(ТекущаяДата()));
    Дата=Дата("00010101"+Формат(ТекущаяДата(), "ДФ = ""ЧЧммсс"""));
    Шапка.Параметры.Водитель=ЭлементыФормы.ЖурналДокументовСписок.ТекущаяСтрока.Водитель;
    
    ////////////////////////////////////////////
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |	КонтактнаяИнформация.Представление,
    |	ТТН.Водитель
    |ИЗ
    |	Документ.ТТН КАК ТТН
    |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |		ПО ТТН.Водитель = КонтактнаяИнформация.Объект
    |ГДЕ
    |	КонтактнаяИнформация.Тип = &Тип
    |	И КонтактнаяИнформация.Вид = &Вид
    |	И ТТН.Водитель = &Водитель
    |	И ТТН.Смена = &Смена
    |	И ТТН.Маршрут = &Маршрут";
    Запрос.УстановитьПараметр("Тип"   , Перечисления.ТипыКонтактнойИнформации.Телефон);
    Запрос.УстановитьПараметр("Вид"   , Справочники.ВидыКонтактнойИнформации.ТелефонФизЛица);
    Запрос.УстановитьПараметр("Водитель",ЭлементыФормы.ЖурналДокументовСписок.ТекущаяСтрока.Водитель);
    Запрос.УстановитьПараметр("Маршрут",ЭлементыФормы.ЖурналДокументовСписок.ТекущаяСтрока.Маршрут);
    Запрос.УстановитьПараметр("Смена",ЭлементыФормы.ЖурналДокументовСписок.ТекущаяСтрока.Смена);
    РезультатЗапроса = Запрос.Выполнить();
    Если РезультатЗапроса.Пустой() Тогда
    Телефон = "";
    Иначе
    Телефон = РезультатЗапроса.Выгрузить()[0].Представление;
    КонецЕсли;
    Шапка.Параметры.Тел=Телефон;
    //////////////////////////////////////////////
    ТабДок1.Вывести(Шапка);
    Дата=Дата("00010101"+Формат(ТекущаяДата(), "ДФ = ""ЧЧммсс"""));
    Номер=1;
    Итог=0;
    Для каждого Стр Из ТЗ Цикл
    Строка.Параметры.Ном=Номер;
    Номер=Номер+1;
    Строка.Параметры.Наим= ""+Стр.НаимПок+"";	                                      
    СведенияОГрузополучателе = СведенияОЮрФизЛице(Справочники.Контрагенты.НайтиПоКоду(Стр.КодГр), Дата);
    СтрГрузополучатель = ОписаниеОрганизации(СведенияОГрузополучателе, "ФактическийАдрес,");
    Адрес= СтрГрузополучатель;
    Строка.Параметры.Адрес=Адрес;
    Строка.Параметры.Ном2=Стр.НомерН;
    Строка.Параметры.Код = ""+Стр.КодПок+"";
    а=Стр.Всего;
    б=ТекущийДолг(Стр.Договор,,);
    Строка.Параметры.сум=Стр.Всего;
    Если (б<0 И (-1)*(б+а)>0) ИЛИ Стр.Предоплата= Истина Тогда 
    Строка.Параметры.аванс= "Предоплата";
    Иначе
    Строка.Параметры.аванс= "";  //"предоплата";
    КонецЕсли;	   
    Строка.Параметры.сум=Стр.Всего;
    Итог=(Итог+ а);
    ТабДок1.Вывести(Строка);
    КонецЦикла;
    
    Сумма=	Строка.Параметры.сум;
    Итого.Параметры.ИтСум=Итог;
    ТабДок1.Вывести(Итого); 
    ТабДок1.ВывестиГоризонтальныйРазделительСтраниц();
    ТабДок1.Вывести(Подвал);
    
  6. TopicStarter Overlay
    solnce
    Offline

    solnce Опытный в 1С

    Регистрация:
    16 июл 2009
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    Если кто нибудь сможет подсказать буду очень признательна
  7. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.400
    Симпатии:
    40
    Баллы:
    54
    Вот стану телепатом, перестану задавать глупые вопросы, Вы так и не описали задачу, зато скинули кусок кода, нате вот разбирайтесь :unsure: Вообщем ставьте корректно вопрос что за
    и куда выводися, пожалейте пожалуйста и наше и Ваше время.
  8. TopicStarter Overlay
    solnce
    Offline

    solnce Опытный в 1С

    Регистрация:
    16 июл 2009
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    есть документы ТТН, из ТТН вытягиваются данные(на текущую дату) и попадают в отчет,то есть идет анализ документов, скажем у меня 2 маршрут и по этому 2 маршруту просматриваются все ТТН и данные заносятся в отчет.мне нужно,чтобы грузополучатель (грузополучатель это реквизит документа ТТН) с кодом 00003 попадал в отчет через день.
    ну как более подробно описать я незнаю...
Похожие темы
  1. Angie
    Ответов:
    0
    Просмотров:
    1.807
  2. maryska2010
    Ответов:
    0
    Просмотров:
    641
  3. malefik
    Ответов:
    8
    Просмотров:
    2.599
  4. кларк
    Ответов:
    8
    Просмотров:
    353
Загрузка...

Поделиться этой страницей