7.7 Активизировать строку

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем djyarilo, 25 апр 2011.

  1. TopicStarter Overlay
    djyarilo
    Offline

    djyarilo Опытный в 1С

    Регистрация:
    18 апр 2011
    Сообщения:
    435
    Симпатии:
    0
    Баллы:
    26
    Задача следующая, поиск по ИНН и активизация найденного контрагента в форме списка. Короче я нашел ИНН Сравнил есть ли такое наименование в контрагентах если есть, то надо активизировать строку. Все находит а активизировать не могу((((
    СпрЮрЛицо= СоздатьОбъект("Справочник.ЮрЛица");
    СпрЮрЛицо.ВыбратьЭлементы();
    Пока СпрЮрЛицо.ПолучитьЭлемент() = 1 Цикл
    //а=1;
    а =Найти(СпрЮрЛицо.ИНН, реквизитПоиска);
    Если а =1 Тогда
    //Сообщить(СпрЮрЛицо.Наименование);
    СпрКОнтрагенты = СоздатьОбъект("Справочник.Контрагенты");
    СпрКОнтрагенты.ВыбратьЭлементы();
    Пока СпрКОнтрагенты.ПолучитьЭлемент() = 1 Цикл
    Если СпрЮрЛицо.Наименование = СпрКОнтрагенты.Наименование Тогда

    параметр =СпрКОнтрагенты.Наименование;
    Сообщить(СпрКОнтрагенты.Наименование);
    Активизировать();

    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    конеццикла;

    СпрКонтрагенты.Наименование = Название определенного контрагента.
  2. TopicStarter Overlay
    djyarilo
    Offline

    djyarilo Опытный в 1С

    Регистрация:
    18 апр 2011
    Сообщения:
    435
    Симпатии:
    0
    Баллы:
    26
    Сделал

Поделиться этой страницей