7.7 Активация модуля "клиент-банк" в 7.7

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем laikovski, 6 дек 2012.

  1. TopicStarter Overlay
    laikovski
    Offline

    laikovski

    Регистрация:
    6 дек 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Добрый день столкнулся с такой проблемой. При активации модуля клиент-банка, запрашивает пароль, который конечно нам не известен, существует ли возможность каким либо образом обойти этот пароль. Спасибо.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Что за конфигурация? Какой пароль? В первый раз слышу
  3. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    + Тоже первый раз слышу. Может, все-таки у банка спросить?
  4. TopicStarter Overlay
    laikovski
    Offline

    laikovski

    Регистрация:
    6 дек 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    а такое бывает)))
    (7.70.027)

    в константах выбираешь "разрешить обмен клиент банк?" запрашивает пароль, пароль от конфигурации не подходит. установлен какой-то свой, отдельный. прилагаю скрин. скорее всего разработчики что то изменили, но хотелось бы как то обойти это.


    http://yadi.sk/d/wgHmoWye156-j
  5. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    В глобальном модуле смотрите процедуру ПриЗаписиКонстанты.

    P.S. Скрины лучше размещать в самом сообщении.
  6. TopicStarter Overlay
    laikovski
    Offline

    laikovski

    Регистрация:
    6 дек 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    если не сложно опишите подробнее, не очень силен в этих вопросах. спасибо
  7. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    После установки значения константы у вас "выскакивает" окно с запросом пароля. Это нетиповое поведение платформы. Значит открывайте конфигуратор, затем редактирование конфигурации (Конфигурация - Открыть конфигурацию), заходите в глобальный модуль (Действия - Глобальный модуль), найдите там предопределенную процедуру ПриЗаписиКонстанты и смотрите, как вызывается окно.

    P.S. Но если не сильны, то лучше обратиться к тому, кто "сильнее", а лучше к разработчику (что-то мне каатца ©, что там будет запароленная внешняя обработка).
  8. TopicStarter Overlay
    laikovski
    Offline

    laikovski

    Регистрация:
    6 дек 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Есть это:
    Процедура ПриЗаписиКонстанты(ИмяКонстанты,Значение)
    Если глПроверкаКонстанты(ИмяКонстанты)=1 Тогда
    Если глПроверкаКакЗаполненаКонстанты(ИмяКонстанты,Значение)=0 Тогда
    СтатусВозврата(0);
    КонецЕсли;
    Иначе
    СтатусВозврата(0);
    КонецЕсли;
    КонецПроцедуры

    и это нашел:

    ИначеЕсли ИмяКонстанты="РазрешитьОбменКлиентБанк" тогда
    Если Константа.РазрешитьОбменКлиентБанк<>Да тогда
    ПарольКоторыйНадоВвести=Симв(192)+Симв(225)+Симв(240)+Симв(224)+Симв(234)+Симв(224)+Симв(228)+Симв(224)+Симв(225)+Симв(240)+Симв(192);
    РезультатПроверки=глПроверкаПароля(ПарольКоторыйНадоВвести);

    каким образом шифруется пароль?
  9. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Почти никаким :). Через коды символов занесен.
    Искомое слово: АбракадабрА
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ага... а можно в функции ГМ глПроверкаПароля первой строкой вернуть нужное значение
  11. TopicStarter Overlay
    laikovski
    Offline

    laikovski

    Регистрация:
    6 дек 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Ребята, всем спасибо за помощь)

Поделиться этой страницей