7.7 АКт сверки

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем nany, 9 июл 2009.

  1. TopicStarter Overlay
    nany
    Offline

    nany

    Регистрация:
    8 авг 2008
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Всем привет. Можно кто знает, как выбросить счета при переборе:

    Дт 62.04 Кт 62.03
    Дт 76.20 Кт 68.03

    Делаю так они не выбрасываются :unsure:

    Код:
    ///////////////////////////////////////////////////////////////////////////////////////////////////////	
    Если СписокВыбранныхСчетов.НайтиЗначение(СчетПоКоду("62.04")) > 0 Тогда
    БИ = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент);
    Если Договор.Выбран() = 1 Тогда
    БИ.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор);
    КонецЕсли;
    БИ.ВключатьСубсчета(0, 0);
    БИ.ВыполнитьЗапрос(НачДата, КонДата, "62.04, 62.03"); 
    СальдоНач = 0;
    СальдоКон = 0;
    КонецЕсли;
    
    Если СписокВыбранныхСчетов.НайтиЗначение(СчетПоКоду("76.20")) > 0 Тогда
    БИ = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент);
    Если Договор.Выбран() = 1 Тогда
    БИ.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор);
    КонецЕсли;
    БИ.ВключатьСубсчета(0, 0);
    БИ.ВыполнитьЗапрос(НачДата, КонДата, "76.20, 68.03"); 
    СальдоНач = 0;
    СальдоКон = 0;
    КонецЕсли;
    ///////////////////////////////////////////////////////////////////////////////////////////////////////////
    
    Заранее спасибо :)

    Вложения:

  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Читай справку по методу ВыполнитьЗапрос.
    Счет и корсчет - это разные параметры и должны идти в разных строках, пример,

    Код:
    БИ.ВыполнитьЗапрос(НачДата, КонДата, "76.20", "68.03");
    
  3. TopicStarter Overlay
    nany
    Offline

    nany

    Регистрация:
    8 авг 2008
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    можете удалить эту тему или закрыть я всё сделала.
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Мы все очень рады за тебя. Но может поделишся знаниями, как ты это сделала?
  5. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Да как ты сказал, так она и сделала. Или ты "спасибо" от дамы выпрашиваешь? :unsure:
  6. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    "Спасибов" уже хватает (может где-нить их на $ меняют??? :unsure: )

    Я бы за прекрасную половину так определенно не заступался.... Там проблема могла быть в чем угодно, от того случая что я описал, вплоть до того, что этих счетов там вообще нет (может ТиС?).
  7. nzksm
    Offline

    nzksm

    Регистрация:
    1 дек 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Дайте модуль Акта сверки с использованием счета 58
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) А где пожалуйста?
    2) Здесь никто ничего не дает - за "дай" обращайтесь на www.infostart.ru
  9. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Тому кто знает, делов на 2 мин, кто не знает -вызывать спеца. Такого типового модуля нет. Вам надо было сказать не "Дайте", а "Подайте".
  10. nzksm
    Offline

    nzksm

    Регистрация:
    1 дек 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Да я почти сделал Сальдо на начало и на конец показывает ,а обороты не показывает. Помоги советом. Только не про спеца 2х минутного.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выкладывай что сделал.... Телепатических услилий не хватает дотянуться до твоего компа и заглянуть в код.....
  12. nzksm
    Offline

    nzksm

    Регистрация:
    1 дек 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Вот модуль

    Вложения:

Поделиться этой страницей