7.7 акт сверки 2

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Archivar, 2 янв 2014.

  1. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте. Помогите плз с созданием акта сверки:
    http://files.mail.ru/381B45D31B2A4296876F33BB301982B6 - данный внешний отчет, выводит акт сверки по Индивидуальным Предпринимателям(Нашей организации) т.к. у нас их несколько, и по контрагентам( Наши покупатели и наши поставщики) - по каждому контрагенту в отдельности!

    Надо; модернизировать отчет, чтобы он выводил по всем контрагентам.

    Ранее тема уже создавалась и вот что там получилось: http://files.mail.ru/A3DC97924FFE457F8C6D104239869CBB - в нем мне так и не удалось разбить по предпринимателям, но он все-равно не выводил так как надо, т.к. бухгалтер сказал что цифры не совпадают. Не совпадают между двумя выше упомянутыми внешними отчетами.

    Я решил переделать Самый первый ответ что я привел в самом начале: http://files.mail.ru/59A38888E54C4F76B35DFB9F792B0BC7 - но он не выводит вообще(((

    Прошу Вас помочь...
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    1)Для того чтобы выводило ПО ВСЕМ нужно было просто убрать проверку на альт....
    http://disk.tom.ru/1uql4uc
    2) Там где у вас не правильно: обращаю внимание на тот же альт...
    В случае с накладными вы сравниваете код (правильно), а в ПКО и РКО - жестко прописан код 1 что не может не сказаться на достоверности данных......
  3. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Я забыл сказать - Альт это как раз и есть ИП(индивидуальные предприниматели) По ним надо по отдельности.
    В самом первом внешнем отчете там это показано: поле выбора Альт и поле выбора Контрагент.
    По той внешке что вы прислали: я поставил назад Альт, т.к. он нужен. Но она выводит судя по всему сумму начального остатка(это сумма на начало месяца что должны мы) и конечный остаток( т.е. на конец месяца) всех контрагентов одной строкой. НО контрагенты не выводятся - пустая строка. Что в принципе так и было.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    зачем то закомментировали вывод строки

    Код:
    Процедура ВыводСтроки()
    Если Д.Вид()="Накладная" Тогда
    НазвДок="Накладная № "+сокрл(Д.НомерДок);
    Сумма1=0;  Сумма2=Д.Итог("Всего");
    ИначеЕсли (Д.Вид()="ПоступлениеТМЦ") Тогда
    НазвДок="Поступление ТМЦ № "+сокрл(Д.НомерДок);
    Сумма1=Д.Итог("Всего");  Сумма2=0;
    ИначеЕсли Д.Вид()="ПриходныйОрдер" Тогда
    НазвДок="Приходный ордер № "+сокрл(Д.НомерДок);
    Сумма1=Д.Сумма;  Сумма2=0;
    ИначеЕсли Д.Вид()="РасходныйОрдер" Тогда
    НазвДок="Расходный ордер № "+сокрл(Д.НомерДок);
    Сумма1=0; Сумма2=Д.Сумма;
    ИначеЕсли Д.Вид()="Выписка" Тогда
    НазвДок="Выписка банка № "+сокрл(Д.НомерДок)+" ("+сокрлп(Д.НазначениеПлатежа)+")";
    Если Д.ПервичныйДокумент.Выбран()=1 Тогда
    НазвДок=НазвДок+" по "+Д.ПервичныйДокумент;
    КонецЕсли;
    Сумма1=Д.Приход;  Сумма2=Д.Расход;
    КонецЕсли;
    Сумма1и=Сумма1и+Сумма1; Сумма2и=Сумма2и+Сумма2;
    Т.ВывестиСекцию("Строка");//тут убрать комментарий!
    
    КонецПроцедуры	   
    
  5. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    просто у меня там строки то нет. строка выводила дебет и кредит по каждому документу каждого контрагента в отдельности....Т.е. берется контрагент и по нему документы входящие и исходящие.


    Ладно...

    Мне думается, что моя попытка переделать именно эту внешку таким образом была глупой.

    Посмотрите пожалуйста на эту: http://files.mail.ru...C6D104239869CBB это именно та, с которой Вы мне помогали.

    Там не подскажите почему она не делит на ИП(индивидуальных предпринимателей) это реквизит - Альт.

    Хотя вроде же прописано Что делить на Альт.код
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    вот кусок кода в котором вы получаете начальные остатки
    Код:
     Если Число(Альт.Код)=1 Тогда
    КР=СчетПоКоду("КР.0");
    ИначеЕсли Число(Альт.Код)=2 Тогда	
    КР=СчетПоКоду("КР.1");
    ИначеЕсли Число(Альт.Код)=3 Тогда
    КР=СчетПоКоду("КР.2");
    КонецЕсли;
    Т.ВывестиСекцию("Шапка")
    ;
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,,1);
    Ит.ВыполнитьЗапрос(Дата1,,КР,,,1,,1);
    Корр=Ит.СНД();
    
    Получить то вы их получили... Только нигде не применили!

    Затем сделали запрос по счету 60 по контрагентам
    Код:
     Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,,1);
    Ит.ВыполнитьЗапрос(Дата1,Дата2,"60",,,1,,1);
    Ит.ВыбратьСубконто();
    НомерСтроки=0;			   
    
    Пока Ит.ПолучитьСубконто()=1 Цикл 
    
    НомерСтроки=НомерСтроки+1;
    Т.ВывестиСекцию("Строка");
    КонецЦикла;	 
    
    и вывели результат....
    В ДАННОМ разрезе невозможно определить к какому альту относятся итоги. Все валится в кучу...

    А вот дальнейший перебор по документам (где в принципе работает фильтр по альту) вообще безсмыленный, ибо вы там ничего не выводите
  7. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    ситуация то в том что я не знаю как это сделать...т.к. нет опыта я даже не могу применить прием

    Я там пытался выводить "строку" - но это было бессмысленно((( он не выводил
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В том отчете что я вам высылал должно все работать В ЦЕЛОМ (без учета ИП) если вы уберете комментарий в процедуре ВыводСтроки()
  9. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    так у меня там в таблице секции строки нет....и не должно по сути т.к. строка отвечала за дебет и кредит документов, Она выводила грубо говоря: выбирается контрагент и выводит по нему все документы
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Не документы.. А проводки.
    В вашем варианте вообще не получится дотянутся до документа, а следовательно и не получится узнать несчастную "альту"
    Попробуйте применить конструкцию типа

    Код:
    Опер = СоздатьОбъект("Операция");
    Опер.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент);
    Опер.ВыбратьОперацииСПроводками(НачДата, КонДата, "60");
    Пока Опер.ПолучитьПроводку() = 1 Цикл
    //тут через реквизит операции "документ" можно вытянуть документ и как следствие узнать альт и наложить фильтр.
    КонецЦикла;
    
  11. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    так мб проводок то и хватит.....
    Вы видели? files.mail.ru/381B45D31B2A4296876F33BB301982B6 - оригинал, все что надо то это по всем контрагентам чтобы выводил, а по ИП деление то оно и так есть.
    Нас это вполне устраивает.
    Я думал там пару взмахов и все... а тут не так все просто
  12. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    прошу Вас посмотрите Вот эту http://files.mail.ru/B745DAD762494D8DAAD805CA85FF4B37 -там вроде по документам...или я ошибаюсь...только там по альту нет
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Нет. Там только обороты. Если вам действительно нужно ПО ДОКУМЕНТАМ - выложите вашу базу на файлообменник, а ссылку - в личку.
    Я покажу вам как нужно правильно составить отчет.
  14. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    мне МД скинуть?


    Вот вопрос: если на основании документов она будет выводить....она будет выводить и не по проведенным документам?

    просто у нас существуют аннулированные документы

    я думаю хватит и по проводкам:

    http://files.mail.ru...76F33BB301982B6 - если Вы говорите что эта по проводкам . то значит - так и надо
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Нужна конфигурация с данными..
    В конфигураторе: меню-администрирование-сохранить данные
  16. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    я сейчас вышлю ссылку в личку, покажите лучше если с проводками делать - как надо было мне разделить по ИП
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    хорошо... я гляну по возможности
  18. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Искренне благодарю Вас.
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Документы вида ПриходныйОрдер и РасходныйОрдер не имеют реквизита "альт". С ними то как быть?
  20. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Там действительно нет, но как мне сказал бухгалтер она относит их к одному из ИП(ТуковВН) - тк он нал использует.

    Мб просто по проводкам? или вы думаете по документам вернее? У Нас бывают непроведенные документы ...она по ним тоже считать будет?((

Поделиться этой страницей