7.7 акт оказания услуг

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем denn-m, 12 окт 2010.

  1. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!
    1. подскажите как в 1с 7.7 упращенная система налогообложения в акте оказания услуг в строке "Всего оказано услуг на сумму:________________________." добавить слово "Без НДС."?

    2. и как сделать чтобы этот акт печатался на одном листе в 2-х экземплярах?

    Вложения:

    • акт.jpg
      акт.jpg
      Размер файла:
      244,9 КБ
      Просмотров:
      366
  2. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    1. Откройте "конфигуратор" найдите эту печатную форму и добавте то что хотите.
    2. Синтаксис:

    ПараметрыСтраницы(<Ориентация>, <Масштаб>, <РежимПечатиКопий>, <ПолеСлева>,
    <ПолеСправа>, <ПолеСверху>, <ПолеСнизу>, <КолонтитулСверху>,
    <КолонтитулСнизу>, <Автомасштаб> , <ФлагЧерноБелойПечати>,
    <ИмяПринтера>)

    Параметры:
    <Ориентация>
    Необязательный параметр. Числовое выражение — ориентация вывода на печать: 1 — портрет; 2 — ландшафт.
    <Масштаб>
    Необязательный параметр. Числовое выражение — масштаб (в процентах) вывода на печать.
    <РежимПечатиКопий>
    Необязательный параметр. Числовое выражение — режим вывода нескольких копий на печать: 0 — (collate) выводить сначала первые страницы всех копий, затем вторые и т. д.;1 — (разобрать) выводить страницы копий по порядку.
    <ПолеСлева>
    Необязательный параметр. Числовое выражение — расстояние (в миллиметрах) от правого края страницы.
    <ПолеСверху>
    Необязательный параметр. Числовое выражение — расстояние (в миллиметрах) от верхнего края страницы.
    <ПолеСнизу>
    Необязательный параметр. Числовое выражение — расстояние (в миллиметрах) от нижнего края страницы.
    <КолонтитулСверху>
    Необязательный параметр. Числовое выражение — размер (в миллиметрах) верхнего колонтиту­ла.
    <КолонтитулСнизу>
    Необязательный параметр. Числовое выражение — размер (в миллиметрах) нижнего колонтиту­ла.
    <Автомасштаб>
    Необязательный параметр. Числовое выражение — указывает режим автоматического подбора масштаба для размещения документа при печате на листе по ширине. 1 — Включить; 0 — Выклю­чить. По молчанию — 0.
    <ФлагЧерноБелойПечати>
    Необязательный параметр. Число: 1 — черно-белая печать; 0 — обычный режим печати. Зна­чение по умолчанию — 0.
    <ИмяПринтера>
    Необязательный параметр. Строка как в стан­дартном диалоге печати.

    Описание:

    Метод ПараметрыСтраницы позволяет установить параметры страницы вывода на печать.

    Пример:

    Таб.ПараметрыСтраницы(1, 100, 1, 17, 17, 25, 25, 10, 10);

    КоличествоЭкземпляров(<Колич>)
    Параметры:

    <Колич>
    Необязательный параметр. Числовое выражение — количество печатаемых экземпляров.

    Возвращаемое значение:
    Текущее заданное количество печатаемых экземпляров (на момент до ис­полнения метода).
    Описание:
    Метод КоличествоЭкземпляров позволяет установить количество печа­таемых экземпляров. Если для текущей таблицы используется набор опций печати (см. Опции), то данный метод следует вызывать только после вызова метода Показать, т. к. иначе будут действовать автоматически устанавливаемые настройки печати.
    Пример:

    Таб.КоличествоЭкземпляров(5);
  3. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    1. вставить ндс у меня получилось
    2. напишите подробнее, где мне найти синтаксис?
  4. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    печатная форма где была? отдельно или с формой документа? открывайте Конфигуратор - Форма.НазваниеВашегоДокумента и там в процедуре печпти изменяйте!


    можешь скинуть документ с печатной формой, я посмотрю!
  5. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    документы-> реализация нажимаю правой кнопкой выбераю редактировать форму-> выбераю модуль, тут править?

    подскажи где его взять чтобы тебе скинуть?
  6. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    печатную форму где нашли? она у вас было в виде чего? просто печатная форма или форма документа?
  7. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    в 1с выбераю печатная форма "Акт оказания услуг" в папке "PrnForms" с таким названием нету
  8. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    документы->реализация-> в модуле нашел такую запись
    Код:
    //  ПечатьАкт()
    //
    // Вызывается из формул элементов диалога:
    //  Кнопка "Печать".
    //
    // Описание:
    //  Формирование печатной формы документа.
    //
    Процедура ПечатьАкт()
    
    Таб = СоздатьОбъект("Таблица");
    ИмяФайлаПечатнойФормы = КаталогИБ()+"ExtForms\PrnForms\1cbakt.mxl";
    Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда
    
    
    
    но в базе 1с такого файла "1cbakt.mxl" нету
  9. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    смотрите с разрешением ert в extForms
  10. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    в папке "extForms" нет такого файла

    Вложения:

    • 1.jpg
      1.jpg
      Размер файла:
      370,9 КБ
      Просмотров:
      84
  11. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    ошибся )) в PrnForms посмотрите
  12. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    Вот как то так! Только параметры свои задайте! на последние строчки обратите внимание.

    Код:
    Процедура ПечатьАкт()
    
    Таб = СоздатьОбъект("Таблица");
    ИмяФайлаПечатнойФормы = КаталогИБ()+"ExtForms\PrnForms\1cbakt.mxl";
    Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда
    Таб.ИсходнаяТаблица(ИмяФайлаПечатнойФормы);
    Иначе
    Таб.ИсходнаяТаблица("Таблица");
    КонецЕсли;
    
    АдресТелефон = "Адрес: "+глПредставлениеАдреса(Константа.АдресОрганизации);;
    Таб.ВывестиСекцию("Шапка");
    
    Ном 		= 0;
    ИтогСумма	= 0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Если (Номенклатура.ТипНоменклатуры<>Перечисление.ТипыНоменклатуры.Услуга) и
    (Номенклатура.ТипНоменклатуры<>Перечисление.ТипыНоменклатуры.ПосредническаяУслуга)и
    (Номенклатура.ТипНоменклатуры<>Перечисление.ТипыНоменклатуры.УслугаЕНВД) Тогда
    Продолжить;
    КонецЕсли;
    Ном = Ном + 1;
    Наименование = ?(ПустаяСтрока(Номенклатура.ПолнНаименование)=1, Номенклатура.Наименование, Номенклатура.ПолнНаименование);
    Таб.ВывестиСекцию("Строка");
    ИтогСумма	= ИтогСумма + Сумма;
    Состояние("Выведено строк: " + НомерСтроки);
    КонецЦикла;
    
    Таб.ВывестиСекцию("Итоги");
    Таб.ВывестиСекцию("Подвал");
    
    Таб.Опции(0,0,0,0,"ОпцииПечатиАкта","ОкноАкта"); 
    Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);    
    Таб.КоличествоЭкземпляров(2);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Печать акта");
    
    КонецПроцедуры // ПечатьАкт()
    
    
  13. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    все получилось, все работает. Спасибо за советы!!!

Поделиться этой страницей