8.х Акт об оказании услуг

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Eler0n, 15 янв 2014.

  1. TopicStarter Overlay
    Eler0n
    Offline

    Eler0n

    Регистрация:
    14 янв 2014
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте помогите с печатной формой. В продолжение этой темы. http://www.1c-pro.ru/topic55305.html

    Мне нужно добавить дополнительное поле для ввода, куда будет вводится договор.
    Работа ведётся через веб-клиент, хочу сразу сказать что в веб-клиенте вставка из буфера не работает.
    Пробовал сделать сам но ни чего не получается, мне не понят что нужно менять в модуле на СсылкаНаОбъект

    [​IMG]
    Если открыть модуль объектов, то я не нашел там функцию печати
    [​IMG]

    [​IMG]

    Вот если открыть модуль менеджера, то там я нашел печать.

    [​IMG]

    Это меня запутало т.к во всех мануалах все берут печать из модуля объектов.

    Мне не понятно что нужно менять на СсылкаНаОбъект, пересмотрел много видео и перечитал све маны что нашел в сети. Так и не разобрался.

    Тут вроде всё сделал верно.

    [​IMG]


    В самом макете создал дополнительное поле Строка1 это для Договора.

    [​IMG]


    Как я догадываюсь мне нужен модуль

    Код:
    Функция ПечатьАктаОбОказанииУслуг(МассивОбъектов, ОбъектыПечати)
    УстановитьПривилегированныйРежим(Истина);
    ВалютаРеглУчета = ОбщегоНазначенияБПВызовСервераПовтИсп.ПолучитьВалютуРегламентированногоУчета();
    ДополнительнаяКолонкаПечатныхФормДокументов = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если НЕ ЗначениеЗаполнено(ДополнительнаяКолонкаПечатныхФормДокументов) Тогда
    ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    КонецЕсли;
    ВыводитьКоды = ДополнительнаяКолонкаПечатныхФормДокументов <> Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.АвтоМасштаб = Истина;
    ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_АктОбОказанииПроизводственныхУслуг_Акт";
    Макет = УправлениеПечатью.ПолучитьМакет("Документ.АктОбОказанииПроизводственныхУслуг.ПФ_MXL_Акт");
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("МассивОбъектов",  МассивОбъектов);
    Запрос.УстановитьПараметр("ВалютаРеглУчета", ВалютаРеглУчета);
    Запрос.УстановитьПараметр("ДополнительнаяКолонкаПечатныхФормДокументов", Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить());
    Запрос.Текст =
    "ВЫБРАТЬ
    | АктОбОказанииПроизводственныхУслуг.Ссылка КАК Ссылка,
    | АктОбОказанииПроизводственныхУслуг.Номер,
    | АктОбОказанииПроизводственныхУслуг.Дата КАК Дата,
    | АктОбОказанииПроизводственныхУслуг.Проведен,
    | АктОбОказанииПроизводственныхУслуг.Исполнитель,
    | АктОбОказанииПроизводственныхУслуг.ИсполнительПоПриказу,
    | АктОбОказанииПроизводственныхУслуг.ПодразделениеОрганизации,
    | АктОбОказанииПроизводственныхУслуг.ДоговорКонтрагента,
    | АктОбОказанииПроизводственныхУслуг.ДоговорКонтрагента.ВалютаВзаиморасчетов КАК ВалютаВзаиморасчетов,
    | ЕСТЬNULL(АктОбОказанииПроизводственныхУслуг.ДоговорКонтрагента.РасчетыВУсловныхЕдиницах, ЛОЖЬ) КАК РасчетыВУсловныхЕдиницах,
    | АктОбОказанииПроизводственныхУслуг.КурсВзаиморасчетов КАК КурсВзаиморасчетов,
    | АктОбОказанииПроизводственныхУслуг.КратностьВзаиморасчетов КАК КратностьВзаиморасчетов,
    | АктОбОказанииПроизводственныхУслуг.Контрагент КАК Получатель,
    | АктОбОказанииПроизводственныхУслуг.Организация КАК Поставщик,
    | АктОбОказанииПроизводственныхУслуг.Организация,
    | АктОбОказанииПроизводственныхУслуг.СуммаДокумента,
    | АктОбОказанииПроизводственныхУслуг.ВалютаДокумента,
    | АктОбОказанииПроизводственныхУслуг.СчетУчетаРасчетовСКонтрагентом,
    | АктОбОказанииПроизводственныхУслуг.СуммаВключаетНДС,
    | АктОбОказанииПроизводственныхУслуг.Услуги.(
    | НомерСтроки КАК НомерСтроки,
    | Номенклатура,
    | Номенклатура.НаименованиеПолное КАК Товар,
    | Количество,
    | Номенклатура.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    | ВЫБОР
    | КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    | ТОГДА АктОбОказанииПроизводственныхУслуг.Услуги.Номенклатура.Артикул
    | КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    | ТОГДА АктОбОказанииПроизводственныхУслуг.Услуги.Номенклатура.Код
    | КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    | ТОГДА """"
    | КОНЕЦ КАК КодАртикул,
    | ВЫБОР
    | КОГДА АктОбОказанииПроизводственныхУслуг.ВалютаДокумента = &ВалютаРеглУчета
    | ТОГДА АктОбОказанииПроизводственныхУслуг.Услуги.Цена
    | КОГДА АктОбОказанииПроизводственныхУслуг.КратностьВзаиморасчетов = 0
    | ТОГДА 0
    | ИНАЧЕ ВЫРАЗИТЬ(АктОбОказанииПроизводственныхУслуг.Услуги.Цена * АктОбОказанииПроизводственныхУслуг.КурсВзаиморасчетов / АктОбОказанииПроизводственныхУслуг.КратностьВзаиморасчетов КАК ЧИСЛО(15, 2))
    | КОНЕЦ КАК Цена,
    | ВЫБОР
    | КОГДА АктОбОказанииПроизводственныхУслуг.ВалютаДокумента = &ВалютаРеглУчета
    | ТОГДА АктОбОказанииПроизводственныхУслуг.Услуги.Сумма
    | КОГДА АктОбОказанииПроизводственныхУслуг.КратностьВзаиморасчетов = 0
    | ТОГДА 0
    | ИНАЧЕ ВЫРАЗИТЬ(АктОбОказанииПроизводственныхУслуг.Услуги.Сумма * АктОбОказанииПроизводственныхУслуг.КурсВзаиморасчетов / АктОбОказанииПроизводственныхУслуг.КратностьВзаиморасчетов КАК ЧИСЛО(15, 2))
    | КОНЕЦ КАК Сумма,
    | СтавкаНДС,
    | ВЫБОР
    | КОГДА АктОбОказанииПроизводственныхУслуг.ВалютаДокумента = &ВалютаРеглУчета
    | ТОГДА АктОбОказанииПроизводственныхУслуг.Услуги.СуммаНДС
    | КОГДА АктОбОказанииПроизводственныхУслуг.КратностьВзаиморасчетов = 0
    | ТОГДА 0
    | ИНАЧЕ ВЫРАЗИТЬ(АктОбОказанииПроизводственныхУслуг.Услуги.СуммаНДС * АктОбОказанииПроизводственныхУслуг.КурсВзаиморасчетов / АктОбОказанииПроизводственныхУслуг.КратностьВзаиморасчетов КАК ЧИСЛО(15, 2))
    | КОНЕЦ КАК СуммаНДС
    | ) КАК Услуги
    |ИЗ
    | Документ.АктОбОказанииПроизводственныхУслуг КАК АктОбОказанииПроизводственныхУслуг
    |ГДЕ
    | АктОбОказанииПроизводственныхУслуг.Ссылка В(&МассивОбъектов)
    |
    |УПОРЯДОЧИТЬ ПО
    | Дата,
    | Ссылка,
    | НомерСтроки";
    Шапка = Запрос.Выполнить().Выбрать();
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("МассивОбъектов",  МассивОбъектов);
    Запрос.УстановитьПараметр("ВалютаРеглУчета", ВалютаРеглУчета);
    Запрос.Текст =
    "ВЫБРАТЬ РАЗЛИЧНЫЕ
    | АктОбОказанииПроизводственныхУслугУслуги.Ссылка КАК Документ,
    | АктОбОказанииПроизводственныхУслугУслуги.Ссылка.СчетУчетаРасчетовСКонтрагентом КАК СчетРасчетов,
    | АктОбОказанииПроизводственныхУслугУслуги.СчетДоходов КАК СчетДоходов
    |ПОМЕСТИТЬ ВалютныеДокументы
    |ИЗ
    | Документ.АктОбОказанииПроизводственныхУслуг.Услуги КАК АктОбОказанииПроизводственныхУслугУслуги
    |ГДЕ
    | АктОбОказанииПроизводственныхУслугУслуги.Ссылка В(&МассивОбъектов)
    | И АктОбОказанииПроизводственныхУслугУслуги.Ссылка.Проведен
    | И АктОбОказанииПроизводственныхУслугУслуги.Ссылка.ДоговорКонтрагента.ВалютаВзаиморасчетов <> &ВалютаРеглУчета
    |
    |ИНДЕКСИРОВАТЬ ПО
    | Документ,
    | СчетРасчетов,
    | СчетДоходов
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    | РегистрСведенийРублевыеСуммыДокументовВВалюте.НомерСтрокиДокумента,
    | РегистрСведенийРублевыеСуммыДокументовВВалюте.Всего,
    | РегистрСведенийРублевыеСуммыДокументовВВалюте.НДС,
    | РегистрСведенийРублевыеСуммыДокументовВВалюте.НалоговаяБазаНДС,
    | РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор КАК Документ
    |ИЗ
    | РегистрСведений.РублевыеСуммыДокументовВВалюте КАК РегистрСведенийРублевыеСуммыДокументовВВалюте
    |ГДЕ
    | РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор В (ВЫБРАТЬ ВалютныеДокументы.Документ ИЗ ВалютныеДокументы КАК ВалютныеДокументы)
    | И РегистрСведенийРублевыеСуммыДокументовВВалюте.ТабличнаяЧастьДокумента = ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.Услуги)
    |";
    ВалютныеДокументы = Запрос.Выполнить().Выгрузить();
    ВалютныеДокументы.Индексы.Добавить("Документ, НомерСтрокиДокумента");
    ПервыйДокумент = Истина;
    НомерСтрокиНачало = ТабДокумент.ВысотаТаблицы + 1;
    Пока Шапка.Следующий() Цикл
    Если НЕ ПервыйДокумент Тогда
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;
    ПервыйДокумент = Ложь;
    ТаблицаУслуги = Шапка.Услуги.Выгрузить();
    СтрокаВалютногоДокумента = ВалютныеДокументы.Найти(Шапка.Ссылка, "Документ");
    ЭтоВалютныйДокумент = СтрокаВалютногоДокумента <> Неопределено;
    Если ЭтоВалютныйДокумент Тогда
    СтруктураПоиска = Новый Структура("Документ, НомерСтрокиДокумента");
    СтруктураПоиска.Документ = Шапка.Ссылка;
    Для каждого СтрокаТовар Из ТаблицаУслуги Цикл
    СтруктураПоиска.НомерСтрокиДокумента = СтрокаТовар.НомерСтроки;
    МассивНайденныхСтрок = ВалютныеДокументы.НайтиСтроки(СтруктураПоиска);
    Если МассивНайденныхСтрок.Количество() > 0 Тогда
    Если Шапка.СуммаВключаетНДС Тогда
    СтрокаТовар.Сумма	= МассивНайденныхСтрок[0].Всего;
    Иначе
    СтрокаТовар.Сумма	= МассивНайденныхСтрок[0].Всего - МассивНайденныхСтрок[0].НДС;
    КонецЕсли;
    СтрокаТовар.СуммаНДС = МассивНайденныхСтрок[0].НДС;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначенияБПВызовСервера.СформироватьЗаголовокДокумента(Шапка, "Акт");
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
    СведенияОПоставщике							 = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
    ПредставлениеПоставщика						 = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПоставщике, "НаименованиеДляПечатныхФорм,");
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ПредставлениеПоставщика;
    ОбластьМакета.Параметры.Поставщик			   = Шапка.Поставщик;
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
    СведенияОПолучателе							 = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
    ПредставлениеПолучателя						 = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОПолучателе, "НаименованиеДляПечатныхФорм,");
    ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;
    ОбластьМакета.Параметры.Получатель			  = Шапка.Получатель;
    ТабДокумент.Вывести(ОбластьМакета);
    // Вывести табличную часть
    ОбластьШапки = ?(ВыводитьКоды, "ШапкаСКодом", "ШапкаТаблицы");
    ОбластьМакета = Макет.ПолучитьОбласть(ОбластьШапки);
    ОбластьМакета.Параметры.Заполнить(Шапка);
    Если ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
    ОбластьМакета.Параметры.ИмяКодАртикул = "Артикул";
    ИначеЕсли ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
    ОбластьМакета.Параметры.ИмяКодАртикул = "Код";
    КонецЕсли;
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьСтроки = ?(ВыводитьКоды, "СтрокаСКодом", "Строка");
    ОбластьСтроки = Макет.ПолучитьОбласть(ОбластьСтроки);
    НомерСтроки = 0;
    Для каждого СтрокаТабличнойЧасти Из ТаблицаУслуги Цикл
    НомерСтроки = НомерСтроки + 1;
    ОбластьСтроки.Параметры.Заполнить(СтрокаТабличнойЧасти);
    Если ЭтоВалютныйДокумент Тогда
    ОбластьСтроки.Параметры.Цена  = СтрокаТабличнойЧасти.Сумма / ?(СтрокаТабличнойЧасти.Количество = 0, 1, СтрокаТабличнойЧасти.Количество);
    КонецЕсли;
    ТабДокумент.Вывести(ОбластьСтроки);
    КонецЦикла;
    Сумма	= ТаблицаУслуги.Итог("Сумма");
    СуммаНДС = ТаблицаУслуги.Итог("СуммаНДС");
    ОбластьМакета = Макет.ПолучитьОбласть("Итого");
    ОбластьМакета.Параметры.Всего = ОбщегоНазначенияБПВызовСервера.ФорматСумм(Сумма);
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("ИтогоНДС");
    Если СуммаНДС <> 0 Тогда
    ОбластьМакета.Параметры.ВсегоНДС = ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаНДС);
    ОбластьМакета.Параметры.НДС	  = ?(Шапка.СуммаВключаетНДС, "В том числе НДС", " Сумма НДС");
    Иначе
    ОбластьМакета.Параметры.НДС	  = "Без налога (НДС)";
    ОбластьМакета.Параметры.ВсегоНДС = "-";
    КонецЕсли;
    ТабДокумент.Вывести(ОбластьМакета);
    СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
    ОбластьМакета.Параметры.ИтоговаяСтрока = "Всего оказано услуг " + НомерСтроки
    + ", на сумму " + ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаКПрописи, ВалютаРеглУчета);
    ОбластьМакета.Параметры.СуммаПрописью  = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаКПрописи, ВалютаРеглУчета);
    ТабДокумент.Вывести(ОбластьМакета);
    ОтветственныеЛицаОрганизации = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата, Шапка.ПодразделениеОрганизации);
    Если ЗначениеЗаполнено(Шапка.Исполнитель) Тогда
    Если Шапка.Исполнитель = ОтветственныеЛицаОрганизации.Руководитель Тогда
    ЗаместительПоПриказу = ОтветственныеЛицаОрганизации.РуководительПредставление;
    ДолжностьИНазваниеОрганизации = "" + ОтветственныеЛицаОрганизации.РуководительДолжностьПредставление;
    Если ЗначениеЗаполнено(ПредставлениеПоставщика) Тогда
    ДолжностьИНазваниеОрганизации = ДолжностьИНазваниеОрганизации + ", " + ПредставлениеПоставщика;
    КонецЕсли;
    Иначе
    ЗаместительПоПриказу = ФизическиеЛица.ФамилияИнициалыФизЛица(Шапка.Исполнитель);
    Если ЗначениеЗаполнено(Шапка.ИсполнительПоПриказу) Тогда
    ЗаместительПоПриказу = ЗаместительПоПриказу + ", " + Шапка.ИсполнительПоПриказу;
    КонецЕсли;
    ДанныеОтветственногоЛица = ОбщегоНазначенияБПВызовСервера.ДанныеФизЛица(Шапка.Организация, Шапка.Исполнитель, Шапка.Дата);
    Если ЗначениеЗаполнено(ДанныеОтветственногоЛица.Должность) И ЗначениеЗаполнено(ПредставлениеПоставщика) Тогда
    ДолжностьИНазваниеОрганизации = "" + ДанныеОтветственногоЛица.Должность + ", " + ПредставлениеПоставщика;
    ИначеЕсли ЗначениеЗаполнено(ДанныеОтветственногоЛица.Должность) Тогда
    ДолжностьИНазваниеОрганизации = "" + ДанныеОтветственногоЛица.Должность;
    Иначе
    ДолжностьИНазваниеОрганизации = ПредставлениеПоставщика;
    КонецЕсли;
    КонецЕсли;
    Иначе
    ЗаместительПоПриказу = ОтветственныеЛицаОрганизации.РуководительПредставление;
    ДолжностьИНазваниеОрганизации = "" + ОтветственныеЛицаОрганизации.РуководительДолжностьПредставление;
    Если ЗначениеЗаполнено(ПредставлениеПоставщика) Тогда
    ДолжностьИНазваниеОрганизации = ДолжностьИНазваниеОрганизации + ", " + ПредставлениеПоставщика;
    КонецЕсли;
    КонецЕсли;
    ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
    ОбластьМакета.Параметры.ДолжностьИНазваниеОрганизации = ДолжностьИНазваниеОрганизации;
    ОбластьМакета.Параметры.ЗаместительПоПриказу = ЗаместительПоПриказу;
    ТабДокумент.Вывести(ОбластьМакета);
    УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДокумент,
    НомерСтрокиНачало, ОбъектыПечати, Шапка.Ссылка);
    КонецЦикла;
    Возврат ТабДокумент;
    КонецФункции
    И в нём я полагаю нужно что-то заменить на СсылкаНаОбъект

    Помогите разобраться в этих дебрях.
  2. TopicStarter Overlay
    Eler0n
    Offline

    Eler0n

    Регистрация:
    14 янв 2014
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Забыл сообщить о версии.

    [​IMG]

    Случайно нашел готовую версию, если это она. http://infostart.ru/public/248644/

    Всеравно хочется разобраться в этом деле.
  3. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    у вас конфигурация на базе библиотеки стандартных подсистем, поэтому процедуры печати и находятся в модуле менеджера.
    кроме другого расположения процедур печати в модулях конфигурации, сами дополнительные печатные формы также делаются по-другому.

    в качестве примера - http://www.1c-pro.ru/topic26882.html/page__p__114677#entry114677

    процедуру печати, по образу которой нужно делать свою нашли правильно, осталось для ячейки в макете задать, что данные получаются из параметра, а также получить область, заполнить этот параметр и вывести область в печатную форму после вывода шапки.
  4. TopicStarter Overlay
    Eler0n
    Offline

    Eler0n

    Регистрация:
    14 янв 2014
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Это значит что нужна только та чать в модуле которую я нашел?
    Функция ПечатьАктаОбОказанииУслуг(МассивОбъектов, ОбъектыПечати)
    Не нужно ли еще мне что-то выдергивать из модуля? кроме
    ПечатьАктаОбОказанииУслуг
  5. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    да, скорее всего больше ничего не понадобится.

    но в модуле обработки должно быть еще много сервисных функций для того, чтобы эта обработка распозналась базой как внешняя печатная форма - смотрите пример, на который я ссылку дал
  6. TopicStarter Overlay
    Eler0n
    Offline

    Eler0n

    Регистрация:
    14 янв 2014
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Теперь такая ошибка.

    [​IMG]
  7. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    процедуры сервисные все есть?
    технология создания внешних печатных форм изменилась...
  8. TopicStarter Overlay
    Eler0n
    Offline

    Eler0n

    Регистрация:
    14 янв 2014
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    // Устанавливаем признак доступности печати покомплектно.
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина; //<БН> не понятно, что это. Распечатать несколько печатных форм сразу не получается
    // Проверяем, нужно ли для макета ПКО формировать табличный документ.
    // Формируем табличный документ и добавляем его в коллекцию печатных форм.
    //УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,"М11","М11 (Требовние-накладная)",ПечатьМ11(МассивОбъектов, ОбъектыПечати));
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "АктОбОказанииУслуг1", "Акт об оказании услуг с договором",  ПечатьАктаОбОказанииУслуг(МассивОбъектов, ОбъектыПечати));
    
    КонецПроцедуры
    
  9. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
  10. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    вот тут http://www.1c-pro.ru/topic26882.html/page__p__114677#entry114677
    внимательно почитайте - печатные формы для БП3 делаются так же
  11. TopicStarter Overlay
    Eler0n
    Offline

    Eler0n

    Регистрация:
    14 янв 2014
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Я даже пробовал устанавливать результат этого мануала - Вылетает ошибка про переменные.
  12. TopicStarter Overlay
    Eler0n
    Offline

    Eler0n

    Регистрация:
    14 янв 2014
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1

Поделиться этой страницей