8.х Администрирование пользователей

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем LxS, 5 апр 2007.

  1. TopicStarter Overlay
    LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Столкнулся с такой проблемой (думаю, не я один)
    Пользователей много. Конфу иногда необходимо модифицировать и обновлять.
    Приходится обзванивать каждый отдел, чтобы товарищи отвалились из базы.
    Подкиньте идеи, как осуществить дисконнект пользователей с предварительным оповещением.
    В семерке у меня реализована данная возможность. Там блокировку могу даже поставить на вход на определенный период. Открываю форму, где вижу активных пользователей, устанавливаю время окончания блокировки и, собсно, отрубаю. Могу и мессагу сначала кинуть, дескать, работы ведутся.
    В восьмере просто не могу найти методов соответствующих.
  2. jon
    Offline

    jon Опытный в 1С

    Регистрация:
    4 сен 2006
    Сообщения:
    76
    Симпатии:
    0
    Баллы:
    26
    Перем = Сообщений;
    Процедура ВыкинутьПользователей() экспорт
    Если Константы.ВыгнатьПользователей.Получить()=истина Тогда
    Если Сообщений = 5 Тогда // 5 – время ожидания в периодах вызова
    //процедуры ВыкинутьПользователей
    ЗавершитьРаботуСистемы();
    Иначе
    Сообщений = Сообщений + 1;
    Сообщить("Закройте документы и приложение!"
    "Приложение автоматически закроется через " + (5 - Сообщений) + " минут.");
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    Эта процедурка в течении 5 минут выдает всем пользователям сообщение, а потом закрывает
  3. TopicStarter Overlay
    LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Немного подробнее.
    Это лишь малая часть всего необходимого, как я понимаю.

    Покопался в бухгалтерии, там возможность управления пользователями реализована(странно, почему сие обошло стороной зарплату, можно подумать, зп не обновляется и не корректируется!).
    Используются следующие объекты:

    1.Подсистема - универсальные механизмы - пользователи.

    2.Перечисления - РежимыЗавершенияРаботыПользователей (В значениях содержит следующие данные:

    -РазрешитьРаботу
    -ПредупредитьПользователейОЗаершенииРаботы
    -ЗавершитьССохранениемДанныхПользователей
    -ПрекратитьРаботуБезусловно).

    3.Константы - РежимыЗавершенияРаботыПользователей (Зацеплена с подсистемой Пользователи
    и использует тип данных ПеречислениеСсылка.РежимыЗавершенияРаботыПользователей).

    4.Кое-какие процедурки из общего модуля.

    Вот как раз по последнему пункту и возникла куча вопросов.
    Пока еще не разобрался, не хватает времени.
    Возможно, пытаюсь изобрести велосипед, тогда прошу помощи у тех, кто в ЗУП реализовал подобное.

Поделиться этой страницей