7.7 Админ Лол в 1С. Не могу сформировать отчет=(

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Aptemii, 24 июн 2009.

  1. TopicStarter Overlay
    Aptemii
    Offline

    Aptemii Опытный в 1С

    Регистрация:
    11 июн 2009
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    КодМодуля

    Код:
    //*******************************************
    Процедура Сформировать()
    Запрос = СоздатьОбъект("Запрос");
    
    ТекстЗапроса = "
    |ИнвКомпьютеров=Регистр.Компьютер.Компьютер;
    |Расположение=Регистр.Компьютер.Расположение;
    |Сотрудник=Справочник.Сотрудник;
    |Группировка Компьютер;
    |Группировка Расположение;
    |Условие(Компьютер в ВыбрКомпьютерГруппа);
    |Условие(Расположение в ВыбрРасположение);
    |";
    
    Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
    Возврат;
    КонецЕсли;
    
    Таб = СоздатьОбъект("Таблица");
    Таб.ВывестиСекцию("Заголовок");
    
    Пока Запрос.Группировка(1)=1 Цикл
    Если Запрос.Компьютер.ЭтоГруппа()=1 Тогда
    ...Таб.ВывестиСекцию("Группа");
    Иначе 
    Таб.ВывестиСекцию("Компьютер");
    Если Фл_НеВыводитьРасположение = 0 Тогда
    ...Пока Запрос.Группировка(2)=1 Цикл
    ......Таб.ВывестиСекцию("Расположение");
    ...КонецЦикла;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    Таб.Опции(0);
    Таб.Показать("ОстаткиКомпьютеров", "");
    
    КонецПроцедуры
    

    Ошибки

  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    ...Таб.ВывестиСекцию("Группа");

    ...Пока Запрос.Группировка(2)=1 Цикл
    ......Таб.ВывестиСекцию("Расположение");
    ...КонецЦикла;

    нахера ты точек впереди наставил?
  3. TopicStarter Overlay
    Aptemii
    Offline

    Aptemii Опытный в 1С

    Регистрация:
    11 июн 2009
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26

    Это табуляция так скопировалась. Их нет в коде.
  4. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    без них код рабочий
Похожие темы
  1. sks_68
    Ответов:
    4
    Просмотров:
    545
  2. prorab
    Ответов:
    2
    Просмотров:
    1.933
  3. tori131313
    Ответов:
    6
    Просмотров:
    675
  4. dia1000
    Ответов:
    3
    Просмотров:
    2.600
  5. Flora
    Ответов:
    3
    Просмотров:
    591
Загрузка...

Поделиться этой страницей