[РЕШЕНО] 2 ТЗ на форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ЕкатеринаНик, 6 авг 2014.

  1. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    В документе нужно две табличных части. Решила что будет 2 ТЗ разбирать что кому.
    ТЗ1 - НоменклатураСписания, Количество
    ТЗ2 - НоменклатураПриходования, Количество
    Кнопочки ДобавитьСтроку("ТЗ1") - ОткрытьПодбор(), а потом ведь ОбработкаПодбора?
    Как обработкой подбора управлять какую ТЗ заполнять?
  2. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.775
    Симпатии:
    509
    Баллы:
    204
    Либо явно указывать владельца, либо два подбора :)
  3. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    //Добавить строку
    Процедура ДобавитьСтроку(Движение)
    // Движение = "Минус" для расхода, "Плюс" для прихода
    ОткрытьПодбор("Справочник.Номенклатура","Для выбора",,,1);
    КонецПроцедуры
    Процедура ОбработкаПодбора(Элемент,ФормаДляПодбора)
    Расход.НоваяСтрока();
    Расход.Номенклатура = Элемент;
    Расход.Артикул = Элемент.Артикул;
    ЧислоЗамены = 0;
    ВВестиЧисло(ЧислоЗамены, "Введите количество для замены", 9, 4);
    Расход.Количество = ЧислоЗамены;
    КонецПроцедуры

    Какие два подбора? в спр Ном сделать две формы для подбора и в обработке подбора спрашивать какая форма была открыта?
  4. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.775
    Симпатии:
    509
    Баллы:
    204
    Блин, не увидел что под семерку кодите:)
    Нее, ну если две формы подбора, тогда зачем спрашивать какая форма ?
  5. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    Не... подождите... ОбработкаПодбора одна? это ж предопределенная? без нее из формы списка ном не получить значение, не так ли?
  6. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.775
    Симпатии:
    509
    Баллы:
    204
    Про семерку ничего не могу сказать, т.к. ни строчки кода в ней не писал. Я по восьмерке судил.
  7. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    Контекст формы.
    Процедура ДобавитьСтроку(Движение)
    ОткрытьПодбор("Справочник.Номенклатура","Для выбора",Движение,,1);
    КонецПроцедуры
    Процедура ОбработкаПодбора(Элемент,ФормаДляПодбора)
    Если ФормаДляПодбора.Форма.Параметр = "Минус" Тогда
    Расход.НоваяСтрока();
    Расход.Номенклатура = Элемент;
    ИначеЕсли ФормаДляПодбора.Форма.Параметр = "Приход" Тогда
    Приход.НоваяСтрока();
    Приход.Номенклатура = Элемент;
    КонецЕсли;
    КонецПроцедуры​
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Весь вопрос.. Как вы храните 2 табличные части в документе.... Надеюсь не в 2х ТЗ
  9. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    В табл части документа- НомПриход, НомРасход, Кол-во. Получается так
    ПриходНоменклатура, ..., 5
    ..., РасходНоменклатура, 15
    Две ТЗ - Приход, Расход, колонки в них Ном-ра и Кол-во.
    Да, документ типа комплектации/разукомплектации.
    Последнее редактирование: 7 авг 2014
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Да. В целом все у вас верно сделано.

Поделиться этой страницей