7.7 2-НДФЛ по новой форме

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Mona, 22 янв 2019.

  1. TopicStarter Overlay
    Mona
    Offline

    Mona Новичок в 1С

    Регистрация:
    5 ноя 2014
    Сообщения:
    46
    Симпатии:
    4
    Баллы:
    4
    День добрый!
    Вопрос в следующем:
    При печати справки 2-НДФЛ раздел «Приложение. Сведения о доходах и соответствующих вычетах по месяцам налогового периода» если отведенных строк не хватает для всех сумм начислений (больше 15 сумм) программа формирует еще один лист и на нем полностью дублирует первый. При этом подпись может вообще одну на листе оставить.
    На первом листе справки использованы разные шрифты. Это с какой-то целью?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.535
    Симпатии:
    536
    Баллы:
    204
    не понял
  3. TopicStarter Overlay
    Mona
    Offline

    Mona Новичок в 1С

    Регистрация:
    5 ноя 2014
    Сообщения:
    46
    Симпатии:
    4
    Баллы:
    4
    все цифры на одном листе а подпись (подвал формы) кидает на отдельный лист
  4. TopicStarter Overlay
    Mona
    Offline

    Mona Новичок в 1С

    Регистрация:
    5 ноя 2014
    Сообщения:
    46
    Симпатии:
    4
    Баллы:
    4
    Там что-то с циклом напутано. Не отслеживает кол-во строк на странице
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.535
    Симпатии:
    536
    Баллы:
    204
    Вот теперь понятно. Релиз 370? Постараюсь глянуть сегодня
  6. TopicStarter Overlay
    Mona
    Offline

    Mona Новичок в 1С

    Регистрация:
    5 ноя 2014
    Сообщения:
    46
    Симпатии:
    4
    Баллы:
    4
    да 370 релиз
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.535
    Симпатии:
    536
    Баллы:
    204
    посмотрел - да, не учитывает вообще
  8. TopicStarter Overlay
    Mona
    Offline

    Mona Новичок в 1С

    Регистрация:
    5 ноя 2014
    Сообщения:
    46
    Симпатии:
    4
    Баллы:
    4
    В бухгалтерии 647 тоже самое
  9. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.549
    Симпатии:
    59
    Баллы:
    54
    внизу процедуры ВывестиСправкуОДоходах2019_ФНС замени кусок кода

    //------------ от сюда
    // Приложение

    ТаблицаДоходов = ТаблицаДанныеСправки.ТаблицаДоходов;
    КолДоходов = ТаблицаДоходов.КоличествоСтрок();

    КолСтраниц = Цел(КолДоходов/15);
    Если КолСтраниц<>(КолДоходов/15) Тогда
    КолСтраниц = КолСтраниц +1;
    КонецЕсли;

    СчетчикДоходов = 1; //исправлено

    Для СчСтраниц = 1 По КолСтраниц Цикл

    ПриложениеШапка = Таб.ПолучитьСекцию("ПриложениеШапка");
    НомерСтраницыОтчета = НомерСтраницыОтчета + 1;

    ВывестиПриложениеШапка(ПриложениеШапка,ОтправительЮрЛицо,ИНННалоговогоАгента,КППСправки,
    НомерСтраницыОтчета,НомерСправки,СтавкаНалога);
    Таб.ВывестиСекцию(ПриложениеШапка);

    КолДоходов = 0;

    ПоследняяСтрокаОбхода = мин(СчСтраниц * 15, ТаблицаДоходов.КоличествоСтрок()); //исправлено

    //Для СчДоходов=1 по ТаблицаДоходов.КоличествоСтрок() Цикл;
    Для СчДоходов=СчетчикДоходов по ПоследняяСтрокаОбхода Цикл; //исправлено

    ТаблицаДоходов.ПолучитьСтрокуПоНомеру(СчДоходов);

    СтрНомерМесяца = Формат(ТаблицаДоходов.Месяц, "Ч(0)2");

    КодДохода =СокрЛП(ТаблицаДоходов.КодДохода);
    СуммаДохода=ФорматироватьЗначениеДляФайла(ТаблицаДоходов.СуммаДохода);

    КодВычета =СокрЛП(ТаблицаДоходов.КодВычета);
    СуммаВычета=ФорматироватьЗначениеДляФайла(ТаблицаДоходов.СуммаВычета);

    ПриложениеСтрока = Таб.ПолучитьСекцию("ПриложениеСтрока");

    ВывестиСтрокуПосимвольно(СтрНомерМесяца,ПриложениеСтрока,"Мес_",2);
    ВывестиСтрокуПосимвольно(КодДохода,ПриложениеСтрока,"КодДохода_",4);
    СуммаДохода = ФорматироватьЧислоПосимвольно(СуммаДохода,2,17);
    ВывестиСтрокуПосимвольно(СуммаДохода,ПриложениеСтрока,"СуммаДохода_",17);

    Если (ПустоеЗначение(КодВычета)=0) И (СуммаВычета<>0) Тогда
    ВывестиСтрокуПосимвольно(КодВычета,ПриложениеСтрока,"КодВычета_",3);
    СуммаВычета = ФорматироватьЧислоПосимвольно(СуммаВычета,2,16);
    ВывестиСтрокуПосимвольно(СуммаВычета,ПриложениеСтрока,"СуммаВычета_",16);
    КонецЕсли;

    Таб.ВывестиСекцию(ПриложениеСтрока);

    КолДоходов = КолДоходов +1;

    КонецЦикла;

    СчетчикДоходов = СчетчикДоходов+15; //исправлено

    Для Сч = (КолДоходов+1) По 15 Цикл
    ПриложениеСтрока = Таб.ПолучитьСекцию("ПриложениеСтрока");
    Таб.ВывестиСекцию(ПриложениеСтрока);
    КонецЦикла;


    ПриложениеПодвал = Таб.ПолучитьСекцию("ПриложениеПодвал");
    Таб.ВывестиСекцию(ПриложениеПодвал);
    Таб.НоваяСтраница();

    КонецЦикла;

    //------------------------ до сюда
    КонецЦикла;

    КонецПроцедуры //ВывестиСправкуОДоходах2019_ФНС
  10. TopicStarter Overlay
    Mona
    Offline

    Mona Новичок в 1С

    Регистрация:
    5 ноя 2014
    Сообщения:
    46
    Симпатии:
    4
    Баллы:
    4
    Спасибо, попробую

Поделиться этой страницей