8.х 1С: ЗУП 8.1

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем tag, 17 июн 2011.

  1. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Я добилась того, что хотела, высылаю код, если кому нужно:
    Код:
    КатегорияППф = Справочники.КатегорииОбъектов.НайтиПоНаименованию("Б");
    Если  не КатегорияППф.Пустая() Тогда
    Запрос = Новый Запрос();
    Запрос.Текст = "
    |ВЫБРАТЬ РАЗЛИЧНЫЕ ПЕРВЫЕ 1
    |    РегистрСведений.КатегорииОбъектов.Категория КАК Категория
    |ИЗ
    |    РегистрСведений.КатегорииОбъектов
    |
    |ГДЕ
    |    РегистрСведений.КатегорииОбъектов.Категория = &Категория и
    |    РегистрСведений.КатегорииОбъектов.Объект = &Объект
    |";
    Запрос.УстановитьПараметр("Объект", ДокументОбъект.Должность);
    Запрос.УстановитьПараметр("Категория", КатегорияППф);
    Б = НЕ Запрос.Выполнить().Пустой();
    КонецЕсли;
    
    //Сообщить("1"+Б);
    
    Если  РольДоступна("А")  и 
    Б = Истина тогда
    
    ЭлементыФормы.ОсновныеДействияФормы.Доступность = Ложь;
    Отказ = Истина;
    #Если Клиент Тогда
    
    Предупреждение("У текущего пользователя  роль только на чтение информационной базы!", 10, "Недостаточно прав доступа");
    #КонецЕсли
    
    
    КонецЕсли;
    
    
    
  2. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Поздравляю!Спасибо за оставленное решение Вашей проблемы!

Поделиться этой страницей