8.х 1С: ЗУП 8.1

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем tag, 17 июн 2011.

  1. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Мадам а менеджеров по персоналу?=)Это же так называемый реквизит доступа=)
  2. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    что то Вы меня уводите в сторону. Это опять будет или чтение или запись
  3. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Смотрим:Создается док оформления на работу перед открытием проверяется автор,его группа,если подходит отлично нет закрываем доступность.
    Такую же проверку вставляем при перепроведении.Кода строчки 3-4 в пару мест и вуаля.

    Ок другой вариант,создаем справочник группы доступа,туда подгруппы(соответственно Вашим нуждам),Рассовываем Ваш персонал как нужно,я про менеджеров если что.И проверяем находятся ли они в этих группах.

    Такой же вариант про регистры сведений.
    Просто Вы же не говорите что именно у Вас не выходит.

    Еще участки это что подразделения?
    Манагеры оформлены в разных подразделениях?
    Если да сделайте проверку на подразделение.
    Т.е. автор его подразделение.На 2 других он оформлять не может.
  4. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Участки - это должности. Каждый менеджер работает со своими должностями. А не получается: не могу из регистра сведений - категории объектов вызволить категорию Б
    тогда бы в коде написала:
    если категорию Б = истина и роль а тогда
    ...... доступность=ложь
  5. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Как именно не получается ошибки или что?Или просто проходит команда и ничего?
  6. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Ошибки
  7. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Ошибку скопируйте сюда пожалуйста...
  8. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Категории =РегистрыСведений.КатегорииОбъектов;
    ОтборКат = Новый Структура("Должность");
    ВыбКатегории=ОтборКат.Должность;
    ВыборкаКатегорииОбъектов = Категория.Выбрать(, , ОтборКат);
    Пока ВыборкаКатегорииОбъектов.Следующий() Цикл
    Сообщить("Категория " + Наименование категории );
    КонецЦикла;
  9. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Просил ошибку которая система выдавала а так в коде у Вас ошибка в орфографии...

    Категории =РегистрыСведений.КатегорииОбъектов;

    Вы задали Категории,а выбрать пытаетесь из Категория.

    ВыборкаКатегорииОбъектов = Категория.Выбрать(, , ОтборКат);
  10. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Спасибо, уже голова не соображает, а ошибка.....
    Слишком много фактических параметров
    ВыборкаКатегорииОбъектов = Кат.Выбрать(, , ОтборДолжность);
  11. o1eg
    Offline

    o1eg Опытный в 1С

    Регистрация:
    25 июн 2006
    Сообщения:
    235
    Симпатии:
    0
    Баллы:
    26
    1. Можно пожалуйста весь код.
    2. Заключайте свой код в теги "
    Код:
    
    
    "
  12. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Извените, я вам завтра пошлю
  13. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Правильно=)Вы смотрели синтаксис?=)Вышлите завтра код подправлю=)
  14. o1eg
    Offline

    o1eg Опытный в 1С

    Регистрация:
    25 июн 2006
    Сообщения:
    235
    Симпатии:
    0
    Баллы:
    26
    Синтаксис проверит конфигуратор :) Ctrl + F7 )
  15. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Не я имел ввиду синтаксис вообще команды=)
    Т.к. он ругается на параметры.
    Потому что напишите любую функцию а в скобках напихайте кучу параметров...
    Проверка проглотит.
    Ошибка выскочит уже при реализации этих параметров=)
  16. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Кат =РегистрыСведений.КатегорииОбъектов;
    Д= ЭлементыФормы.Должность.Значение;
    ОтборДолжность = Новый Структура("Категория", Д);
    ВыборкаКатегорииОбъектов = Кат.Выбрать(, ,ОтборДолжность );
    Пока ВыборкаКатегорииОбъектов.Следующий() Цикл
    Сообщить("2"+ Строка(ВыборкаКатегорииОбъектов.Категория));
    КонецЦикла;
    К=Строка(ВыборкаКатегорииОбъектов.Категория);
    Если РольДоступна("А")
    И
    К=Истина
    тогда
    ЭлементыФормы.ОсновныеДействияФормы.Доступность = Ложь;

    Отказ = Истина;
    #Если Клиент Тогда
    Предупреждение("У текущего пользователя роль для Б только чтение");
    #КонецЕсли

    КонецЕсли;
  17. o1eg
    Offline

    o1eg Опытный в 1С

    Регистрация:
    25 июн 2006
    Сообщения:
    235
    Симпатии:
    0
    Баллы:
    26
    1. Заключайте свой код в тексте сообщения тегами (
    Код:
    
    
    ).
    2. У регистра сведений "КатегорииОбъектов" признак периодичности установлен?
  18. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    2. У регистра сведений "КатегорииОбъектов" признак непериодичности установлен
  19. o1eg
    Offline

    o1eg Опытный в 1С

    Регистрация:
    25 июн 2006
    Сообщения:
    235
    Симпатии:
    0
    Баллы:
    26
    Вариант синтаксиса: Для непериодического регистра

    Синтаксис:
    Выбрать(<Отбор>, <Порядок>)
    Параметры:
    <Отбор> (необязательный)
  20. TopicStarter Overlay
    tag
    Offline

    tag

    Регистрация:
    6 май 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо! Она выбрала все категории . Теперь моя задача вытащить нужную мне категорию

Поделиться этой страницей