7.7 1С ТиС 7.7 Как переименовать "неподтвержденная заявка" в счет

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем FSlonik, 29 мар 2011.

  1. TopicStarter Overlay
    FSlonik
    Offline

    FSlonik

    Регистрация:
    31 мар 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Собственно вопрос, каким образом в ТиС 7.7 можно переименовать документ "неподтвержденная заявка" в счет?
    Заранее благодарен всем откликнувшимся!
  2. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Кнопочка Операция в верху формы
  3. TopicStarter Overlay
    FSlonik
    Offline

    FSlonik

    Регистрация:
    31 мар 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Так там нет в представленном списке документа "счет", там висят три типа заявок, как в этот список счет добавить?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Смотрим процедуру глНазваниеДокументаВЖурнале в ГМ
  5. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    		ИначеЕсли "ЗаявкаПокупателя" = ДокВид Тогда
    Возврат Строка(?(Док.ВидОперации=Перечисление.ВидыОперацийЗаявок.НаСклад,"Счет",Док.ВидОперации)) + ДопСтрока;
    КонецЕсли;
    
    Кстати у меня средний пункт в кнопке Операция так и называется Счет. Неужели у кого-то по другому. Надо в типовую глянуть.
  6. TopicStarter Overlay
    FSlonik
    Offline

    FSlonik

    Регистрация:
    31 мар 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Что то не могу сообразить куда этот кусок кода вставить...
  7. TopicStarter Overlay
    FSlonik
    Offline

    FSlonik

    Регистрация:
    31 мар 2010
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Спасибо огромное! В очередной раз подсказали пути решения. Все получилось. Еще раз огромное спасибо профессионалам.
  8. evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста куда вставить эти строки? Спасибо
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    У вас ВПФ или встроенная форма?
  10. evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    встроенные
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    в макете (закладка таблица формы документа ЗаявкаПокупателя)
    секция "заголовок"
    изменяем на следующую строку
    Счет № [глНомерНаПечать(Контекст)] от [ДатаДок #Д]
  12. evgenn1
    Offline

    evgenn1

    Регистрация:
    12 мар 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Огромное спасибо! неделю я парился.. пока расшифровал ваши строки (тупил не по детски)
    Еще один вопрос.. Как в ТОРГ12 основание тоже называлось бы счетом (а неп.заявкой)
    Спасибо заранее
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    в модуле документа Реализация ищем
    Код:
        Если ПустоеЗначение(ДокОснование) = 1 Тогда
           ПечДокОснование    = Договор;
        Иначе
            ПечДокОснование    = глПредставлениеДокумента(ДокОснование);
        КонецЕсли;
    заменяем на
    Код:
        Если ПустоеЗначение(ДокОснование) = 1 Тогда
           ПечДокОснование    = Договор;
        Иначе
            ПечДокОснование    = "Счет № "+глНомерНаПечать(ДокОснование)+" от "+ДокОснование.ДатаДок;
        КонецЕсли;

Поделиться этой страницей