8.х 1С салон красоты

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем AndreyP, 2 фев 2014.

  1. TopicStarter Overlay
    AndreyP
    Offline

    AndreyP

    Регистрация:
    2 фев 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.
    Помогите разобраться с конфигурацией 1с салон красоты

    суть вопроса в следующем:

    При создании "графика работы сотрудников" в окне "отмеченные дни" пусто, хотя в рабочей конфигурации должна быть таблица.
    Я так подозреваю, что я не заполнил какое-то поле.... может кто сталкивался с подобной проблемой.

    Если в "графике работы" нажимаю сохранить, возникает следующая ошибка :

    {Обработка.ГрафикРаботыСотрудников.Форма.Форма.Форма(530)}: Индекс находится за границами массива
    НаборЗаписейРегистра.Отбор.СтруктурнаяЕдиница.Установить(ГрафикПериодовРаботы[0].СтруктурнаяЕдиница);


    В конфигураторе это выглядит так:

    Код:
    Процедура СохранитьИзменения(Период)
    
    НаборЗаписейРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьНаборЗаписей();
    НаборЗаписейРегистра.Отбор.СтруктурнаяЕдиница.Установить(ГрафикПериодовРаботы[0].СтруктурнаяЕдиница);
    НаборЗаписейРегистра.Отбор.МесяцОтбор.Установить(НачалоМесяца(ГрафикПериодовРаботы[0].Период));
    НаборЗаписейРегистра.Прочитать();
    ТаблицаЗаписейРегистра = НаборЗаписейРегистра.Выгрузить();
    
    // Удаляем период удаленные из графика
    Для Каждого СтрокаРегистра Из ТаблицаЗаписейРегистра Цикл
    СтруктураЗаписи = Новый Структура("СтруктурнаяЕдиница, Сотрудник", СтрокаРегистра.СтруктурнаяЕдиница, СтрокаРегистра.Сотрудник);
    МассивСтрокГрафика = ГрафикПериодовРаботы.НайтиСтроки(СтруктураЗаписи);
    СтрокаРегистраАктуальна = Ложь;
    Для Каждого СтрокаГрафика Из МассивСтрокГрафика Цикл
    Для Каждого ПериодДняГрафика Из СтрокаГрафика["День" + День(СтрокаРегистра.ДатаВремяНачала)] Цикл
    Если ПериодДняГрафика.Значение.НачалоСмены = СтрокаРегистра.ДатаВремяНачала И ПериодДняГрафика.Значение.ОкончаниеСмены = СтрокаРегистра.ДатаВремяОкончания Тогда
    СтрокаРегистраАктуальна = Истина;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    Если СтрокаРегистраАктуальна = Ложь Тогда
    МенеджерЗаписиРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьМенеджерЗаписи();
    ЗаполнитьЗначенияСвойств(МенеджерЗаписиРегистра, СтрокаРегистра);
    МенеджерЗаписиРегистра.Удалить();
    КонецЕсли;	 
    КонецЦикла;
    
    // Удаляем периоды добавленные в график
    Для Каждого СтрокаГрафика Из ГрафикПериодовРаботы Цикл
    Для ДеньГрафика = 1 По 31 Цикл
    Для Каждого ПериодДняГрафика Из СтрокаГрафика["День" + ДеньГрафика] Цикл
    СтруктураЗаписи = Новый Структура("СтруктурнаяЕдиница, Сотрудник, ДатаВремяНачала, ДатаВремяОкончания", СтрокаГрафика.СтруктурнаяЕдиница, СтрокаГрафика.Сотрудник, ПериодДняГрафика.Значение.НачалоСмены, ПериодДняГрафика.Значение.ОкончаниеСмены);
    Если ТаблицаЗаписейРегистра.НайтиСтроки(СтруктураЗаписи).Количество() = 0 Тогда
    МенеджерЗаписиРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьМенеджерЗаписи();
    МенеджерЗаписиРегистра.СтруктурнаяЕдиница = СтрокаГрафика.СтруктурнаяЕдиница;
    МенеджерЗаписиРегистра.Сотрудник = СтрокаГрафика.Сотрудник;
    МенеджерЗаписиРегистра.МесяцОтбор = СтрокаГрафика.Период;
    МенеджерЗаписиРегистра.ДатаВремяНачала = ПериодДняГрафика.Значение.НачалоСмены;
    МенеджерЗаписиРегистра.ДатаВремяОкончания = ПериодДняГрафика.Значение.ОкончаниеСмены;
    МенеджерЗаписиРегистра.Минуты = (ПериодДняГрафика.Значение.ОкончаниеСмены - ПериодДняГрафика.Значение.НачалоСмены) / 60;
    МенеджерЗаписиРегистра.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
    МодифицированностьГрафикаРаботы = Ложь;
  2. Vladius
    Offline

    Vladius Опытный в 1С

    Регистрация:
    10 ноя 2010
    Сообщения:
    663
    Симпатии:
    3
    Баллы:
    29
    Ошибка означает что в массиве ГрафикПериодовРаботы пусто, может забыли что то заполнить в этих графиках?
Похожие темы
  1. Vlan

    Курилка Конкурс красоты

    Vlan, 23 апр 2013, в разделе: Курилка
    Ответов:
    6
    Просмотров:
    402
  2. dtown
    Ответов:
    0
    Просмотров:
    315
Загрузка...

Поделиться этой страницей