8.х 1С с нуля - кто поможет

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем 0r1on, 11 окт 2007.

  1. TopicStarter Overlay
    0r1on
    Offline

    0r1on

    Регистрация:
    11 окт 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Срочно требуется помощь знающих людей, сам с 1с сталкиваюсь первый раз так что сильно не пинайте...
    Версия 1с:Предприятие 8.0, имеется справочник "Обоснование", в табличной части которого есть некая левая информация и столбцы код1, код2, код3. Нужно написать процедурку, которая данные из столбца код1 скопирует в код3, затем данные столбца код1 будут заменены данными столбца код2, причем если в столбце код2 есть нулевые значения (пустые ячейки), то сохраняются исходные значения столбца код1.
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Код:
        выборка = Справочники.Обоснование.Выбрать();
    пока выборка.Следующий() Цикл
    спр = выборка.ПолучитьОбъект();
    для каждого СтрСпр из спр.ТабличнаяЧасть Цикл
    СтрСпр.Код3 = СтрСпр.Код1;
    Если СтрСпр.Код2 <> 0 Тогда
    СтрСпр.Код1 = СтрСпр.Код2;
    КонецЕсли;
    КонецЦикла;
    спр.Записать();
    КонецЦикла;    
    
    Как то так, но не проверял.
  3. TopicStarter Overlay
    0r1on
    Offline

    0r1on

    Регистрация:
    11 окт 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    lazy большое спасибо - чуток подправил под себя и все прокатило
Похожие темы
  1. Lex09
    Ответов:
    18
    Просмотров:
    1.811
  2. unit
    Ответов:
    1
    Просмотров:
    598
  3. scorpion
    Ответов:
    55
    Просмотров:
    3.408
Загрузка...

Поделиться этой страницей